Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Неназначенных незавершенных заказов: 10, свеженьких 1
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Войти | Зарегистрироваться )


>  Вывод на макет картинки
And1001
Отправлено: 08.10.18, 12:55


Молчаливый
*

Группа: Пользователи
Сообщений: 2
Регистрация: 05.10.18
Пользователь №: 62524


Разобрался. В параметр нельзя передавать изображение. Изображение передается в объект рисунок ( на макете Таблица => Рисунки => Картинка). Затем передавать в этот объект полученные из двоичных данных нашу картинку.
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #146075 · Ответов: 2 · Просмотров: 148
 

>  Вывод на макет картинки
And1001
Отправлено: 05.10.18, 9:40


Молчаливый
*

Группа: Пользователи
Сообщений: 2
Регистрация: 05.10.18
Пользователь №: 62524


Здравствуйте уважаемые программисты. Просьба помочь с выводом на макет картинки. Пример кода :
&НаСервере
Функция СформироватьНаСервере()
    Запрос = Новый Запрос;
    Запрос.Текст =
    "ВЫБРАТЬ
    |    НоменклатураПрисоединенныеФайлы.ВладелецФайла.Ссылка КАК ВладелецФайлаСсылка,
    |    Номенклатура.ФайлКартинки КАК ФайлКартинки,
    |    Номенклатура.Ссылка КАК Ссылка
    |ИЗ
    |    Справочник.Номенклатура КАК Номенклатура
    |        ВНУТРЕННЕЕ СОЕДИНЕНИЕ Справочник.НоменклатураПрисоединенныеФайлы КАК НоменклатураПрисоединенныеФайлы
    |        ПО Номенклатура.ФайлКартинки = НоменклатураПрисоединенныеФайлы.Ссылка";    
    ТабИтог = Запрос.Выполнить().Выбрать();
    ТабДок = Новый ТабличныйДокумент;
    Макет = РеквизитФормыВЗначение("Объект").ПолучитьМакет("Макет");  
    Шапка = Макет.ПолучитьОбласть("Шапка");
    ТабДок.Вывести(Шапка);
    Рез=Макет.ПолучитьОбласть("Результат");
    Пока ТабИтог.Следующий() Цикл
        Рез.Параметры.НаимНоменклатуры = ТабИтог.ВладелецФайлаСсылка.Наименование;
        ДанныеКартинки = УправлениеНебольшойФирмойСервер.ПолучитьДвоичныеДанныеФайла(ТабИтог.ФайлКартинки);
        Если ЗначениеЗаполнено(ДанныеКартинки) Тогда
            Рез.Параметры.Картинка = Новый Картинка(ДанныеКартинки);
        КонецЕсли;            
        ТабДок.Вывести(Рез);
    КонецЦикла;
    возврат  ТабДок;
КонецФункции

В итоге выводится слово "картинка". Другие методы, описанные в интернете мне не помогли.
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #146000 · Ответов: 2 · Просмотров: 148
 


Новые сообщения  Открытая тема (есть новые ответы)
Опрос  Опрос (есть новые голоса)
Нет новых сообщений  Открытая тема (нет новых ответов)
Нет новых голосов  Опрос (нет новых голосов)
Популярная тема  Горячая тема (есть новые ответы)
Закрыта  Закрытая тема
Нет новых  Горячая тема (нет новых ответов) Перемещена  Тема перемещена
 

RSS Текстовая версия Сейчас: 18.10.18, 5:27
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!

Курсы валют: доллар США к гривне Курсы валют: евро к гривне Курсы валют: российский рубль к гривне