Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Неназначенных незавершенных заказов: 8
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Войти | Зарегистрироваться )

История благодарностей участнику mister-x ::: Спасибо сказали: 1327 раз
Дата поста: В теме: За сообщение: Спасибо сказали:
05.10.18, 16:11 Программист 1С, Одесса
Також колись брали на вакансію 1С-програміста в 5-зірковий готель (Трускавець). В результаті хотіли загрузити ще і роботою сис.адміна при тій же з/п. Пішов звідти. Пізніше дізнався, що всі толкові іногородні ІТ-ніки забили на готель болт - також пробували загрузити іншою роботою.
Vladal,
26.07.18, 15:46 Как сделать отбор в отчете?
В умові
|Условие (Клиент в ВыбКлиент);

далі забрати
|Родит = Регистр.ОстаткиТоваров.Товар.Родитель;

і ще забрати
|Группировка Родит;

Тут
|Группировка Товар;

тоді буде виводити товари із групами, групи зверху.
bezzil,
20.07.18, 15:55 Обработка для переноса движений (проводок, расчетов) документа между двумя идентичными базами
От хочу скористатись обробкою Клонируем объекты в стороннюю базу 7.7 DBF у ОС Windows 7 x32. Все установив, що вказано у статті. Можливо хтось нею користувався і вже знає про цю помилку - при відкритті цієї обробки помилка:
Цитата
глОлеДБ = СоздатьОбъект("OLEDBData");
{D:\1\EXTFORMS\1.ERT(584)}: Неудачная попытка создания объекта (OLEDBData)

Зрозуміло, що проблема у "конекті" до Microsoft FoxPro драйвера. При інсталяції під адміном вказав, що потрібно встановити для всіх користувачів (про це вичитав у інеті). Що ще може бути?
Ще викладу текст процедури у якій проходить "конект" до драйвера:
//======================================================================
Процедура ПриОткрытии()
    глОлеДБ = СоздатьОбъект("OLEDBData");
    Соединение = "Provider=VFPOLEDB.1;Data Source=" + КаталогИБ() + ";Mode=ReadWrite;Collating Sequence=MACHINE";

    Рез = глОлеДБ.Соединение(Соединение);
    гЗапрос = глОлеДБ.СоздатьКоманду();
    гЗапрос.Выполнить("EXECSCRIPT('SET ANSI OFF')");  
    // Устанавливаем время ожидания захвата таблиц , если во время выполнения запроса кто то проводит документы
    // Очень полезная функция - аналогична времени ожидания в 1С
    гЗапрос.Выполнить("EXECSCRIPT('SET REPROCESS TO 60 SECONDS')");
    // Убираем буфепизацию, чтобы данные возвращаемые запросам всегда были актуальны
    гЗапрос.Выполнить("EXECSCRIPT('SET REFRESH TO 0,-1')");    
    
    гЗапрос.Выполнить("Exec('SET TABLEVALIDATE TO 0')");// Отключили блокировки
    ТаблицаССылок = СоздатьОбъект("ИндексированнаяТаблица");
    ТаблицаССылок.НоваяКолонка("Объект");
    ТаблицаССылок.НоваяКолонка("ВидОбъекта");
    ТаблицаССылок.НоваяКолонка("ТипОбъекта");
    ТаблицаССылок.НоваяКолонка("ОбъектИд");
    ТаблицаССылок.НоваяКолонка("Отметка");
    ТаблицаССылок.ДобавитьИндекс("Объект","*Объект");
    ТаблицаССылок.ДобавитьИндекс("Отметка","*Отметка");
    
    _Форма=СоздатьОбъект("Форма");
    _Форма.УстановитьФорму(Форма);
    РасшФормы = СоздатьОбъект("РасширениеФормы");
    РасшФормы.УстановитьФорму(Форма);
    СтарВысота=0;СтарШирина=0;
    метаВорк = СоздатьОбъект("MetaDataWork");
    
КонецПроцедуры // ПриОткрытии


Добавив загрузку 1С++.dll
попытка
        ЗагрузитьВнешнююКомпоненту("1cpp.dll");
        Сообщить("Компонента 1С++ загружена!");
    Исключение
        Сообщить("Пытались, но не загрузили компоненту 1С++ :(");
    КонецПопытки;
    
    глОлеДБ = СоздатьОбъект("OLEDBData");
    Соединение = "Provider=VFPOLEDB.1;Data Source=" + КаталогИБ() + ";Mode=ReadWrite;Collating Sequence=MACHINE";

    Рез = глОлеДБ.Соединение(Соединение);

Тепер помилка:
Цитата
Рез = глОлеДБ.Соединение(Соединение);
{D:\1\EXTFORMS\1.ERT(595)}: FAILED! IDataInitialize::GetDataSource(): Не найден указанный модуль.

Gleef,
09.07.18, 11:31 Новая декларация по НДС
По 7.7 слідкуйте за новимами тут http://its.1c.ua, інших даних немає.
KriAn,
17.05.18, 14:23 Бухгалтерия 2.0
Колега здавав і здав. Задачі ті ж, регламент той же.
alx389d,
15.03.18, 17:26 Прикольное видео

присутня ненормативна лексика англ. мовою
Vofka,
15.03.18, 15:20 Бухгалтерия для Украины, переход с редакции 1.2 на 2.0
Правила дозволяють паралельно працювати з іншим франчайзі взагалі без підписки (при умові, що існуюча підписка ще дійсна) wink.gif.
Ksena,
23.01.18, 17:42 Полнотекстовый поиск данных
пароль тут
neonfrost123,
08.12.17, 11:28 Как программно совершить выбор в форме списка справочника?
А так як реалізований підбір для прикладу в розх. накладній в типовій бухгатерії вас не влаштовує - стаємо на кнопку "Подбор" в документі і вибираємо номенклатуру?
Victor Skif,
30.06.17, 16:14 "Вконтакте", "Одноклассники", "Яндекс" та "1С" заблокують - указ Порошенка
Порох "задню" не увімкне icon_beer17.gif
XBrut,
16.06.17, 12:23 Чи можливо за номером документу відкрити його візуальну форму
Цитата(leo10k10 @ 15.06.17, 23:00) *
1.2 Аби не вводити Акцизи зпочатку а використати останній документ на цій же формі є кнопка "Відрити останні набрані Акцизи" і провести його редагування знову при натисненні кнопки "Зберегти" записати його але вже з наступним індивідуальним номером

а якщо ввести деякий документ-шаблон і його надалі копіювати програмно і вносити нові дані / редагувати існуючі, так не підійде?

я би ще таку опцію розглянув - форму для відкриття нового документу
ОткрытьФорму(<ОписательОбъекта>,<КонтекстФормы>,<ДокументОснование>)

Цитата
<КонтекстФормы> - имя переменной, куда можно задать значение любого типа для передачи в открываемую форму.

з останнього документу записати дані у зміну і аналізувати її при відкриті нового документу
leo10k10,
07.06.17, 13:49 FTP отправка из 7.7
Всё чаще встречаются задачи по отправке отчетов поставщику, и нередко подготовленные файлы необходимо записать на FTP сервер. О том, как можно решить подобную задачу, и пойдёт речь.

Способ первый – внешняя компонента
На официальном сайте замечательной компании Агент ПЛЮС в разделе Скачать свободно доступны Конфигурации для 1С:Предприятие с интегрированным модулем обмена для "Агент Плюс: Мобильная торговля. Проф" среди которых Конфигурация "Агент Плюс. Торговля+Склад" (на базе типовой конфигурации "Торговля+Склад", редакция 9.2). В дистрибутиве конфигурации содержится внешняя компонента APPlus.dll и несколько дополнительных библиотек, дабы не мучать читателя подробностями – все они собраны в прикрепленном к статье архиве.

При помощи этой компоненты легко решается поставленная задача:

ЗагрузитьВнешнююКомпоненту("APPlus.dll"); // Регистрируем компоненту 
ФТП = СоздатьОбъект("AddIn.CeDataExch"); // Создаём объект
ФТП.FtpOpenSession(); // Это я не знаю зачем:)
Результат = ФТП.FtpConnect("ftp.filehost.ru","userName","Password"); // Подключаемся
Если Результат = 0 Тогда // Если успешно то отправляем файл
    Результат = ФТП.FtpPutFile(ИмяФайлаЛокально, ИмяФайлаНаФТП);
    Если Результат <> 0 Тогда // не получилось - сообщаем об ошибке
        Сообщить("Не удалось отправить файл по причине: " + ФТП.ErrDescription(Результат), "!");
    КонецЕсли;
Иначе
    Сообщить("Не удалось подключиться по причине: " + ФТП.ErrDescription(Результат), "!");
КонецЕсли;
ФТП.FtpCloseSession();

Преимущества: один из самых всеядных способов в плане серверов + контроль результата выполнения, легко организовать обработку исключительных ситуаций, так же сильны и методы чтения с фтп.

Недостатки: внешние компоненты в 7.7 требуют регистрации с правами администратора; относительно медленный способ.

По поводу правомерности использования компоненты мне официально ответили «Компонента APPlus.dll бесплатная, Вы можете использовать её в любых целях»



Способ второй – консольный

Заключается в использовании стандартной команды windows «ftp» с параметрами.

Решение может выглядеть так:

Текст = СоздатьОбъект("Текст"); // Создаём файл с командами для ftp
Текст.ДобавитьСтроку("open " + ФТПсервер);
Текст.ДобавитьСтроку(ФТПимяПользователя);
Текст.ДобавитьСтроку(ФТПпароль);
Текст.ДобавитьСтроку("put " + ИмяФайлаЛокально);
Текст.ДобавитьСтроку("quit");
Текст.Записать(КаталогИБ() + "ftpcmd.dat");
ФС.УстТекКаталог(КаталогИБ()); // место расположения ftpcmd.dat
КомандаСистемы("ftp  -s:ftpcmd.dat"); // вызываем
ФС.УдалитьФайл(КаталогИБ() + "ftpcmd.dat"); // убираем за собой

Преимущества: никаких компонент, всё стандартное и понятное.

Недостатки: работает не всегда и не везде – капризный к серверам, для результата выполнения требуется анализ выводимых сообщений, можно сделать так.

"ftp  -s:ftpcmd.dat > naprimer.log"


После выполнения команды файл naprimer.log считывается программно и анализируется.



Способ третий – пассивный режим

История возникновения этого способа связана с тем, что первые два не имеют возможности перехода в пассивный режим обмена (как Web-браузер) и в некоторых случаях из-за этого не работают. Связано ли это с настройками фтп-серверов или политикой безопасности компьютера-клиента и его сети, лично для меня как необременённого сетевыми знаниями специалиста, загадка, а искать ответ или специалиста который бы помог в каждом новом случае – смерти подобно. Поэтому силами яндекса было найдено решение – использовать свободно доступную консольную программу «curl.exe» следующим образом:

ФС.УстТекКаталог(КаталогИБ()); // место расположения curl.exe и её компонент
КомандаСистемы("curl.exe  -T """+ИмяФайлаЛокально+""" -u "+ФТПимяПользователя+":"+ФТПпароль+" "+ФТПсервер); // вот и всё

Достоинства: пассивный режим, относительно быстрый, достаточно лояльный к серверам.

Недостаток: нет возможности программно определить результат отправки.



В прилагаемом архиве содержится конфигурации со всеми описанными способами и примененными компонентами, что позволяет, указав параметры своего сервера, быстро определиться с подходящим решением.

О том как можно организовать регулярную автоматическую отправку отчетов можно узнать здесь.



Конечно же, есть и множество других способов решить поставленную в заголовке задачу, однако мне вполне хватает вышеизложенных. Все три способа на момент публикации реально используются, поэтому делюсь, чтобы другим помогло и самому не забыть.

(с)
nysysimara, Vofka,
26.05.17, 10:32 "Вконтакте", "Одноклассники", "Яндекс" та "1С" заблокують - указ Порошенка
Цитата
Прошу разрешить использование 1с на Украине. Аргументы:
- Свободная конкуренция
- Закончил курсы 1с бухалтер
- Закончил курсы 1с программист
- Не заслуживаю, чтобы против меня были применены санкции

(с)
32541510.gif 12201689.gif

Batchir,
17.05.17, 16:53 "Вконтакте", "Одноклассники", "Яндекс" та "1С" заблокують - указ Порошенка
Не звертати уваги на петицію про разблокування "Вконтакте" © 32541510.gif 12201689.gif
XBrut,
12.05.17, 16:13 Лицензия 1С: сколько денег остается в Украине, а сколько уходит в Россию?
Цитата(Vofka @ 21.03.17, 14:42) *
У руководства 1С хватает ума не лезть в политику

"кагбе" Типовые конфигурации фирмы "1С" для Крыма2014
Мичман Харитонов,
22.01.17, 19:50 УНФ или Бухгалтерия ред.2?
Знаю історію одного "крупного" клієнта. В нього вірус зашифрував всі дані на сервері, в т.ч. архіви. Він заплатив вказану суму здирнику в у.е. Здирник всі дані розшифрував - "чесним" виявився 32541510.gif
f12,
06.01.17, 13:15 Рейтинг и ТОП 100
при переході по вищевказаних посиланнях - помилка:
Цитата
Сообщение форума
Обнаружена ошибка. Если вам неизвестны причины ошибки, попробуйте обратиться к разделам помощи.

Цитата
Причина:
Некоторые требуемые файлы отсутствуют. Если вы хотели просмотреть тему, возможно эта тема перемещена или удалена. Вернитесь назад и попробуйте снова.
Vofka,
08.12.16, 16:19 Улыбнуло
YOPTASCRIPT
Первый в мире скриптовый язык программирования
для гопников и реальных пацанов.
©
logist,
10.11.16, 22:31 Новий звіт по ЄСВ
Інфа сьогоднішня:
- для 7.7 з нової
Цитата
Отчет по Единому социальному взносу для "Бухгалтерии" (4 кв. 2016, релиз 002) с выгрузкой в XML

http://rusfolder.com/45405631

- для 8-ки з нової
Цитата
Отчет по Единому социальному взносу в редакции от 08.11.2016 с выгрузкой в XML

http://rusfolder.com/45405593
andr_andrey, kasper232, Ksena, RedCat77, Vofka, XBrut, yur,
09.11.16, 23:33 Новий звіт по ЄСВ
на новій зараз побачив таке
Цитата
Регламентированный отчет ESVdod4.ert ("Отчет в пенсионный фонд (ЕСВ)")
с выгрузкой в dbf
- J30T405.dbf (для таблиці 5 додатку 4),
- J30T406.dbf (для таблиці 6 додатку 4),
- J30T407.dbf (для таблиці 7 додатку 4),

лінк

ЗІ. ще не дивився чи останній
kasper232, Ksena,
08.11.16, 22:07 Изменение оформления просмотра тем
Цитата(Sharzem @ 08.11.16, 21:15) *
далее сумрак..., Logist, не в обиду но это скорее всего бага...Другими браузерами не пользуюсь, религия не позволяет...

кеш хрому чистили?

Сьогодні помітив: в цій темі тільки в мене зверху не вказано розділ до якого вона відноситься чи форум зараз перебуває в тестовому режимі?

PS. і в цій така ж ситуація

тю вже показує розділ коли поновив сторінку, знову поновив - не показує, містика якась
Vofka,
04.11.16, 21:28 Система самостоятельной подготовки по вводу начальных остатков в 1С:УТП/Шевченко А./2013
Тримайте лінк (pdf-ка).
audit7buh, pqvv, Sad Mirror,
29.09.16, 16:38 Інтеграційна стиковка для 1С 7.7 та M.E.Doc
Цю обробку розробник вже не підтримує, шукайте альтернативу.
deniskafed,
25.09.16, 21:54 О музыке
підсів... rulez.gif 32541510.gif
andr_andrey,
14.07.16, 16:58 Отчет ЕСВ - как создать и экспортировать в MEDOC
sasha007 @ 07.07.16, 17:11 *,
ага, на новій знайшов - https://drive.google.com/file/d/0B-fkB0_F7E...ref=2&pli=1
Yanina_P,

18 страниц V   1 2 3 > » 
RSS Текстовая версия Сейчас: 15.11.18, 8:45
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!

Курсы валют: доллар США к гривне Курсы валют: евро к гривне Курсы валют: российский рубль к гривне