Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Неназначенных незавершенных заказов: 6
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Войти | Зарегистрироваться )

История благодарностей участнику podcast ::: Спасибо сказали: 60 раз
Дата поста: В теме: За сообщение: Спасибо сказали:
05.04.18, 8:28 Начисление по больничному листу.
Gazulo @ Вчера, 21:13 * ,
По первому скорей всего у вас в каких то видах расчета стоит галочка учитывать календарные дни, от должны были заполнить в документе начисления календарные дни.
По второму из-за праздника.
Gazulo,
06.03.18, 16:40 Установить отбор документов по пользователю (сотруднику)
sanytch @ Сегодня, 16:20 * ,
Ссылка.
sanytch,
06.03.18, 12:00 Получить данные из регистра накопления по условию
burza @ Сегодня, 11:58 * ,
Запрос = Новый Запрос;
    Запрос.Текст =
        "ВЫБРАТЬ
        |   РегистрСчетов.Период,
        |   РегистрСчетов.Регистратор,
        |   РегистрСчетов.НомерСтроки,
        |   РегистрСчетов.Активность,
        |   РегистрСчетов.Контрагент,
        |   РегистрСчетов.Организация,
        |   РегистрСчетов.НомерДоговора,
        |   РегистрСчетов.НомерСчета,
        |   РегистрСчетов.Санаторий,
        |   РегистрСчетов.СуммаПоСчету КАК  СуммаПоСчету
        |ИЗ
        |   РегистрНакопления.РегистрСчетов КАК РегистрСчетов
        |ГДЕ
        |   РегистрСчетов.Организация = &ВыбОрганизация И
        |   РегистрСчетов.Регистратор.НомерДоговора = &НомерДоговора
        | ";

    Запрос.УстановитьПараметр("ВыбОрганизация",
        Справочники.Организации.НайтиПоНаименованию("Накра"));
  Запрос.УстановитьПараметр("НомерДоговора ",НомерДоговора ); //Указать нужный номер договора.
   Выборка = Запрос.Выполнить().Выгрузить();
СуммаПоСчету = Выборка.Итог("СуммаПоСчету");    

Возврат СуммаПоСчету;
burza,
06.03.18, 11:56 Получить данные из регистра накопления по условию
burza @ Сегодня, 11:52 * ,
 Запрос = Новый Запрос;
    Запрос.Текст =
        "ВЫБРАТЬ
        |   РегистрСчетов.Период,
        |   РегистрСчетов.Регистратор,
        |   РегистрСчетов.НомерСтроки,
        |   РегистрСчетов.Активность,
        |   РегистрСчетов.Контрагент,
        |   РегистрСчетов.Организация,
        |   РегистрСчетов.НомерДоговора,
        |   РегистрСчетов.НомерСчета,
        |   РегистрСчетов.Санаторий,
        |   РегистрСчетов.СуммаПоСчету КАК  СуммаПоСчету
        |ИЗ
        |   РегистрНакопления.РегистрСчетов КАК РегистрСчетов
        |ГДЕ
        |   РегистрСчетов.Организация = &ВыбОрганизация И
        |   РегистрСчетов.Регистратор.НомерДоговора = &НомерДоговора
        | ";

    Запрос.УстановитьПараметр("ВыбОрганизация",
        Справочники.Организации.НайтиПоНаименованию("Накра"));
  Запрос.УстановитьПараметр("НомерДоговора ",НомерДоговора ); //Указать нужный номер договора.
   Выборка = Запрос.Выполнить().Выбрать();
СуммаПоСчету = 0;    
Пока Выборка.Следующий() Цикл

    СуммаПоСчету  = СуммаПоСчету + Выборка.СуммаПоСчету;

КонецЦикла
Возврат СуммаПоСчету;

Это самый простой вариант, можно Итог с запроса взять.
burza,
02.03.18, 14:12 УПП 1.3 настройка смен 12+12/48
Vofka @ Сегодня, 10:26 * ,
Спасибо буду знать.

_Valery_ @ Сегодня, 10:20 * ,
Вам нужно сделать смены Смена1 будет работать с 7:00 заканчивается в 19:00, Смена2 с 19:00 до 7:00 утра, и заполнить смены, у вас должно получиться когда в смене 1 рабочий, то в смене 2 выходной и наоборот.
_Valery_,
02.03.18, 10:16 УПП 1.3 настройка смен 12+12/48
_Valery_ @ Сегодня, 9:57 * ,

_Valery_,
28.02.18, 12:10 Префикс автонумерации документов.
Alex78 @ Сегодня, 12:02 * ,
Подписка на событие УстановитьПрефиксИнформационнойБазыНомеруДокумента, добавить в модуле проверку на Тип документа.
Alex78,
22.02.18, 14:51 Выплаты в натуральной форме
Belara @ Сегодня, 14:25 * ,
Настраивать налоги это справочник Виды доходов НДФЛ, код 101 облагается, если вам не нужно облагать то выберите код который не облагается, или создайте свой, по расчетному листку в типовому не выводится.
Belara,
14.02.18, 16:52 Передача таблицы значений между 2мя серверными процедурами.
Alex78 @ Сегодня, 16:39 * ,
Делаете с первой процедуру функцию с клиента вызываете вторую процедуру в которой в начале обращайтесь к первой уже функции получаете ТЗ, и обрабатывайте, или так не получится?
Alex78,
08.02.18, 13:28 Локальная проблема с печаться документа
bizisoft @ Сегодня, 12:11 * ,
Обработка для чистки настроек, ссыль, мне часто помогала.
bizisoft,
01.02.18, 15:37 1с 8.3 УПП 1.3 Код який працює в файловому режимі непрацює в серверному.
s.vitaliy @ Сегодня, 14:47 * ,
Обычно в модуле объекта сначала всех процедур связанных с печать ставят условие, и после них закрывают.
s.vitaliy,
01.02.18, 10:23 1с 8.3 УПП 1.3 Код який працює в файловому режимі непрацює в серверному.
s.vitaliy @ Сегодня, 10:07 * ,
Скорей всего у вас не правильно стоят условия #Если Клиент Тогда, просмотрите на них, попробуйте добавить если их нету, там где у вас есть вызовы клиентских процедур.
s.vitaliy,
22.01.18, 13:36 Где находится табель учета рабочего времени?
senia @ Сегодня, 13:11 * ,
В типовом нету, только искать доработку, на 2.0 ещё не встречал.
senia,
12.01.18, 10:20 Купить методическую литературу по 1С - это проблема у нас?
alx389d @ Вчера, 16:17 * ,
Сдавал УТ некоторые вопросы с русской УТ 2015 года, с новой УТ 11.3 их не много, добавили ещё вопросы наши по Налоговым накладным и НДС их нету не в старых русских тестах, не в новых, но таких вопросов порядка 10 всего.
alx389d,
22.12.17, 10:34 СКД отчет таблицей со своими колонками вместо общих итогов
info230a02 @ Сегодня, 9:41 * ,
Посмотрите должно помочь Пример Итогов.
info230a02,
21.12.17, 14:51 СКД отчет таблицей со своими колонками вместо общих итогов
info230a02 @ Сегодня, 12:39 * ,
Получите остаток на последний месяц отдельно в запросе, а потом в вычисляемом поле Суммируйте итог по Продажам плюс ваш остаток.
info230a02,
13.12.17, 9:34 Кадровое перемещение не проводится
Ariesod @ Вчера, 17:46 * ,
Проверить документ Кадровое перемещение в ТЧ удержание на дубли, похоже что вы ввели кого два раза.
Ariesod,
12.12.17, 17:17 Кадровое перемещение не проводится
Ariesod @ Сегодня, 15:25 * ,
Похоже что у вас в документе уже есть такая строка, а вы добавили её ещё раз.
Ariesod,
12.12.17, 14:16 Кадровое перемещение не проводится
Ariesod @ Сегодня, 12:22 * ,
Выложите скрин ТЧ Удержание и Регистр Плановые удержания.
Ariesod,
12.12.17, 10:22 Кадровое перемещение не проводится
Ariesod @ Сегодня, 10:07 * ,
Удержание на которое ругается был введён документ в этом периоде, уберите с документа это удержание и должно провестись, Кадровое перемещение проводят если меняется должность или подразделение, а просто для повышение оклада достаточно Ввод сведений и желательно что б документ заполнялся при изменении Сотрудника, а не вручную.
Ariesod,
11.12.17, 14:25 Загрузка зарплаты из Excel
Юля @ Сегодня, 14:08 * ,
На основании вашего документа есть возможность внести документ для изменение базового месяца.
Юля,
06.12.17, 10:40 Алименты (база-НДФЛ)*25%
Zene4ka @ Сегодня, 10:01 * ,
В Бухгалтерія никак, в ЗУП или УТП ещё можно как то формулы настроить.
Zene4ka,
30.11.17, 9:27 8.0.13.32 В отладке не срабатывает параметр запроса.В консоли отчетов срабатывает.
Sergey.pro1c.org.ua @ Сегодня, 0:35 * ,
Попробуйте не равно, а Подобно.
Sergey.pro1c.org.ua,
08.11.17, 15:16 Запуск фонового завдання
SaintDaemon @ Сегодня, 15:01 * ,
Я вам это и пытаюсь объяснить, в типовой конфигурации при начале работы системы есть проверка, если база файловая, тогда подключается обработчик ожидания для выполнения Регламентного задания, можно сделать обработку в которой подключите Обработчик ожидания для вашего Регламентного задания, или сделайте как в типовой.
Процедура ПриНачалеРаботыСистемы()
    ЭтоФайловаяИБ = ОпределитьЭтаИнформационнаяБазаФайловая();
        
    Если ЭтоФайловаяИБ Тогда
                    
        ПользовательДляВыполненияРеглЗаданий = Константы.ПользовательДляВыполненияРегламентныхЗаданийВФайловомВарианте.Получить();
        
        Если мТекущийПользователь = ПользовательДляВыполненияРеглЗаданий Тогда
            
            // с интервалом секунд вызываем процедуру работы с регламентными заданиями
            ПоддержкаРегламентныхЗаданиеДляФайловойВерсии();
            
            ПодключитьОбработчикОжидания("ПоддержкаРегламентныхЗаданиеДляФайловойВерсии", глЗначениеПеременной("глКоличествоСекундОпросаОбмена"));
            
            ИнтервалДляОпроса = Константы.ИнтервалДляОпросаРегламентныхЗаданийВФайловомВарианте.Получить();
            
            Если ИнтервалДляОпроса = Неопределено
                ИЛИ ИнтервалДляОпроса = 0 Тогда
                
                ИнтервалДляОпроса = 60;    
                
            КонецЕсли;
            
        КонецЕсли;
        
    КонецЕсли;
КонецПроцедуры // ПриНачалеРаботыСистемы()


Функция ОпределитьЭтаИнформационнаяБазаФайловая(СтрокаСоединенияСБД = "") Экспорт
            
    СтрокаСоединенияСБД = ?(ПустаяСтрока(СтрокаСоединенияСБД), СтрокаСоединенияИнформационнойБазы(), СтрокаСоединенияСБД);
    
    // в зависимости от того файловый это вариант БД или нет немного по-разному путь в БД формируется
    ПозицияПоиска = Найти(Врег(СтрокаСоединенияСБД), "FILE=");
    
    Возврат ПозицияПоиска = 1;    
    
КонецФункции

// процедура служит для поддержки работы регламентных заданий в файловой версии
Процедура ПоддержкаРегламентныхЗаданиеДляФайловойВерсии() Экспорт
    
    ВыполнитьОбработкуЗаданий();
    
КонецПроцедуры
MATEVI,
30.10.17, 15:32 Событие ПриИзменении нужно добавлять текст в наименование другого реквизита
Krushiv @ Сегодня, 14:53 * ,
&НаКлиенте
Процедура ЧерныйСписокПриИзменении(Элемент)
    
    Если  ЧерныйСписок Тогда
        Объект.Наименование = "Черный список " + Объект.Наименование;
    КонецЕсли;
        
КонецПроцедуры
Krushiv,

3 страниц V   1 2 3 >
RSS Текстовая версия Сейчас: 24.05.18, 2:26
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!

Курсы валют: доллар США к гривне Курсы валют: евро к гривне Курсы валют: российский рубль к гривне