Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Неназначенных незавершенных заказов: 8
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Войти | Зарегистрироваться )


>  Не получается зафиксировать на внешней ПФ сверху 3 строки
Stemesseder
Отправлено: 12.06.18, 20:15


Молчаливый
*

Группа: Пользователи
Сообщений: 8
Регистрация: 04.08.17
Пользователь №: 57226


sava1 @ Сегодня, 8:02 * ,

Спасибо огромное, работает. Ваш вариант проще гораздо и не требует менять конфигурацию. Думаю будет полезно и для Prospero. Вопрос закрыт. Еще раз спасибо.

Prospero @ Вчера, 23:41 * ,

Вам спасибо за подробное пояснение, правда проверить работу не успел, появился следующий ответ. Но в любом случае спасибо что не прошли мимо.
  Форум: Программирование обычных форм 1С 8.2 и не интер... · Просмотр сообщения: #142471 · Ответов: 5 · Просмотров: 491
 

>  Не получается зафиксировать на внешней ПФ сверху 3 строки
Stemesseder
Отправлено: 11.06.18, 16:25


Молчаливый
*

Группа: Пользователи
Сообщений: 8
Регистрация: 04.08.17
Пользователь №: 57226


Prospero @ Сегодня, 16:56 * ,

Поправить конфу не проблема, пожалуйста немного подробнее опишите что и куда
  Форум: Программирование обычных форм 1С 8.2 и не интер... · Просмотр сообщения: #142432 · Ответов: 5 · Просмотров: 491
 

>  Не получается зафиксировать на внешней ПФ сверху 3 строки
Stemesseder
Отправлено: 09.06.18, 20:27


Молчаливый
*

Группа: Пользователи
Сообщений: 8
Регистрация: 04.08.17
Пользователь №: 57226


Здравствуйте
1С:Предприятие 8.3 (8.3.10.2580) "Управление торговым предприятием для Украины", редакция 1.2.

На внешней печатной форме не получается зафиксировать сверху шапку таблицы, в модуле внешней объекта обработки функция

Функция Печать() Экспорт
ТабДок = Новый ТабличныйДокумент;
        ТабДок.ТолькоПросмотр = Истина;
        Макет = ПолучитьМакет("Макет");
        ШапкаТаблицы = Макет.ПолучитьОбласть("ШапкаТаблицы");
        ТабДок.Вывести(ШапкаТаблицы);
        СтрокаТаблицы=Макет.ПолучитьОбласть("Строка");
        Запрос = Новый Запрос;
        Запрос.Текст =
        "ВЫБРАТЬ
                |    ЗаказПоставщикуТовары.Номенклатура КАК Описание,
                // пропускаю текст как не важное

        РезультатЗапроса = Запрос.Выполнить();
        ВыборкаДетальныеЗаписи = РезультатЗапроса.Выбрать();
        Номер = 0;
        Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
            Номер = Номер + 1;
            СтрокаТаблицы.Параметры.Номер=Номер;
            ТабДок.Вывести(СтрокаТаблицы);
        КонецЦикла;

ТабДок.ФиксацияСверху = 3; // Это не фиксирует
Возврат ТабДок;
КонецФункции;


Подскажите как закрепить сверху печатной формы 3 строки (первая пустая, 2 и 3 - это как раз область "Шапка таблицы"
  Форум: Программирование обычных форм 1С 8.2 и не интер... · Просмотр сообщения: #142372 · Ответов: 5 · Просмотров: 491
 

>  ПовторятьПриПечатиСтроки - повторяет не то что нужно
Stemesseder
Отправлено: 05.09.17, 11:47


Молчаливый
*

Группа: Пользователи
Сообщений: 8
Регистрация: 04.08.17
Пользователь №: 57226


logist @ Сегодня, 11:51 * ,

О, спасибо, прогресс наметился - ПроверитьВывод срабатывает, однако и в случае 1 страницы сообщает "1" и в случае 2-х страниц тоже сообщает "1"

Значит массив не правильно заполняется ?
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #131698 · Ответов: 8 · Просмотров: 1011
 

>  ПовторятьПриПечатиСтроки - повторяет не то что нужно
Stemesseder
Отправлено: 04.09.17, 15:55


Молчаливый
*

Группа: Пользователи
Сообщений: 8
Регистрация: 04.08.17
Пользователь №: 57226


logist @ 01.09.17, 20:39 * ,

Подскажите как заполнить в моем случае массив, так что бы тип элементов был правильный с сработала проверка.
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #131652 · Ответов: 8 · Просмотров: 1011
 

>  ПовторятьПриПечатиСтроки - повторяет не то что нужно
Stemesseder
Отправлено: 01.09.17, 16:37


Молчаливый
*

Группа: Пользователи
Сообщений: 8
Регистрация: 04.08.17
Пользователь №: 57226


Bernet @ Вчера, 14:41 * ,

Переделал так

МассивОбластей = Новый массив;

ОбластьМакета = Макет.ПолучитьОбласть("Шапка"); //много всего написано - получена область "шапка", заполнена и после ее вывода помещена в массив областей документа

ТабДокумент.Вывести(ОбластьМакета);
МассивОбластей.Добавить(ОбластьМакета.Область("Шапка"));//заполнение массива

//Аналогично по области макета "ЗаголовокТаблицы"

ЗаголовокТаблицы = Макет.ПолучитьОбласть("ЗаголовокТаблицы");
ТабДокумент.Вывести(ЗаголовокТаблицы);
МассивОбластей.Добавить(ЗаголовокТаблицы);

//Аналогично по области макета "строка"

ОбластьМакета = Макет.ПолучитьОбласть("Строка");
ТабДокумент.Вывести(ОбластьМакета);
МассивОбластей.Добавить(ОбластьМакета.Область("Строка"));


//т.к именно помещается или нет область "строка" меня интересует то так написано:

Если Не ТабДокумент.ПроверитьВывод(МассивОбластей) тогда
                сообщить("1");
Иначе
                Сообщить("2");
КонецЕсли


В результате
{Документ.ТТН.МодульОбъекта(1571)}: Ошибка при вызове метода контекста (ПроверитьВывод)
Если Не ТабДокумент.ПроверитьВывод(МассивОбластей) тогда
по причине:
Несоответствие типов (параметр номер '1')

Не получается
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #131600 · Ответов: 8 · Просмотров: 1011
 

>  ПовторятьПриПечатиСтроки - повторяет не то что нужно
Stemesseder
Отправлено: 31.08.17, 13:14


Молчаливый
*

Группа: Пользователи
Сообщений: 8
Регистрация: 04.08.17
Пользователь №: 57226


podcast @ Сегодня, 13:34 * ,

Спасибо но ПроверитьВывод не работал в этом документе и раньше и сейчас не срабатывает. Вернее срабатывает с ошибкой:

{Документ.ТТН.МодульОбъекта(1577)}: Ошибка при вызове метода контекста (ПроверитьВывод)
Если ТабДокумент.ПроверитьВывод("Строка") тогда
по причине:
Несоответствие типов (параметр номер '1')

Написано было так:
    ОбластьМакета = Макет.ПолучитьОбласть("Строка");
    Если Документы.Количество() > 0 Тогда
НомерСтроки = 0;
        Для каждого Строка из ТЗ Цикл

            ОбластьМакета.Параметры.Заполнить(Строка);
            НомерСтроки = НомерСтроки + 1;
            ОбластьМакета.Параметры.КодПродукции = НомерСтроки;
            ТабДокумент.Вывести(ОбластьМакета);
                       Если Не ТабДокумент.ПроверитьВывод("Строка") тогда

                сообщить("1"); //просто проверяю

            КонецЕсли;


У документа в начале установлено
ТабДокумент.АвтоМасштаб             = Истина;
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #131545 · Ответов: 8 · Просмотров: 1011
 

>  ПовторятьПриПечатиСтроки - повторяет не то что нужно
Stemesseder
Отправлено: 31.08.17, 11:22


Молчаливый
*

Группа: Пользователи
Сообщений: 8
Регистрация: 04.08.17
Пользователь №: 57226


Здравствуйте, я не программист, есть возможность и желание менять ту конфигурацию что имею к лучшему.
Начинаю так сказать этот процесс. Пока на повестке есть такой вопрос. Помогите пожалуйста понять что не так.

В печатной форме с таблицей которая может иметь разный размер нужно повторить заголовок таблицы, при продолжении табличной части на следующей странице.
Для этого после получения и вывода заголовка таблицы дописал следующее:

ТабДокумент.ПовторятьПриПечатиСтроки = Макет.Область("ЗаголовокТаблицы");


В результате на следующей станице повторяется не заголовок к таблице а первые 2 строки самой таблицы.
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #131529 · Ответов: 8 · Просмотров: 1011
 


Новые сообщения  Открытая тема (есть новые ответы)
Опрос  Опрос (есть новые голоса)
Нет новых сообщений  Открытая тема (нет новых ответов)
Нет новых голосов  Опрос (нет новых голосов)
Популярная тема  Горячая тема (есть новые ответы)
Закрыта  Закрытая тема
Нет новых  Горячая тема (нет новых ответов) Перемещена  Тема перемещена
 

RSS Текстовая версия Сейчас: 17.11.18, 9:09
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!

Курсы валют: доллар США к гривне Курсы валют: евро к гривне Курсы валют: российский рубль к гривне