Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Неназначенных незавершенных заказов: 4
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Войти | Зарегистрироваться )

29 страниц V   1 2 3 > » 

>  Работа с "ХранилищеВариантовОтчетов" для настроек отчетов
Constantus
Отправлено: 19.01.19, 11:42


Почти ветеран
******

Группа: Пользователи
Сообщений: 701
Регистрация: 19.09.15
Пользователь №: 45918


Vofka @ 17.01.19, 20:26 * ,

Не помогло...
  Форум: Система компоновки данных · Просмотр сообщения: #149115 · Ответов: 3 · Просмотров: 91
 

>  Работа с "ХранилищеВариантовОтчетов" для настроек отчетов
Constantus
Отправлено: 17.01.19, 17:13


Почти ветеран
******

Группа: Пользователи
Сообщений: 701
Регистрация: 19.09.15
Пользователь №: 45918


Приветствую, форумчане!

Имеется полностью самописная конфигурация на платформе 8.3.6

Основной функционал взят из "БСП", в том числе и работа с хранением настроек отчетов, написанных на СКД: ХранилищеВариантовОтчетов.

Произошла такая странная ситуация. Был некий отчет "ОтчетХХЛ", на него пользователи насохраняли много своих персональных настроек.

Пришло время и пришлось добавить в этот отчет некоторые поля и добавить период отчета как стандартный период. Т.е. до этого отбора по периоду не было.

Запустили отчет поверх старого (обновленный старый отчет). Вот тут начались чудеса.

Как я сказал в этом отчете был добавлен механизм отбора по периоду, Но как это не прозвучит странно, данный отчет полностью игнорировал наличием отбора по данному отбору, т.е. я мог и не указывать период, а отчет выдавал результат. Причем появились новые поля, т.е. отчет отрабатывал свой хлеб. Но это касалось только "старых" вариантов отчета, если создать отчет по новой (с новым вариантом отчета), то там уже как положено требовалось указать период.

Сложилось впечатление, что старые варианты настроек отчета держат где-то не просто параметры, но и весь предыдущий запрос СКД, игнорируя моими новыми условиями в новом запросе СКД. Т.е. я написал (дописал, изменил) старый запрос, сделав из него довольно сильно отличающийся от старого, а при запуске старых вариантов отчетов, Отчет обращается к предыдущему запросу и выдает результаты.

Далее интереснее, когда заметили этот парадокс, то откатили этот запрос СКД к предыдущему варианту. После отката и запуска отчета отчет начал требовать наличие новых полей, которых теперь нет в старом запросе. Т.е. теперь отчет обращается к несуществующему запросу, который я написал как новый.

Кто-нибудь сталкивался с подобным явлением? Как такое может быть, что отчет СКД работает по несуществующему запросу?

Как работать и изменять отчеты, которые хранятся в "ХранилищеВариантовОтчетов"? Где храняться эти настройки, чтобы посмотреть их в читабельном виде? Посмотреть к какому запросу этот отчет обращается?

Еще один парадокс. Имеется некий отчет. При его запуске у одних пользователей, у него есть кнопка "Варианты отчетов", что позволяет выбирать варианты отчетов. А у меня (полные права, администратор) только у этого отчета эта кнопка отсутствует... Как так?

Пожалуйста разъясните эту загадку и как с ней бороться...
  Форум: Система компоновки данных · Просмотр сообщения: #149068 · Ответов: 3 · Просмотров: 91
 

>  Выбор % или суммы при оповещении ввода значения
Constantus
Отправлено: 08.01.19, 15:10


Почти ветеран
******

Группа: Пользователи
Сообщений: 701
Регистрация: 19.09.15
Пользователь №: 45918


Применил такое изобретение:

    СП = Новый СписокЗначений;
    СП.Добавить("Процент");
    СП.Добавить("Сумма");
    Выборка = СП.ВыбратьЭлемент("Выберите нужный вид скидки:");
    Если Выборка.Значение = "Процент" Тогда
        Сообщить(Выборка.Значение);
        Оповещение = Новый ОписаниеОповещения("ВведенПроцентСкидкиМенеджераЗавершение", ЭтотОбъект, ДополнительныеПараметры);
        ПоказатьВводЧисла( Оповещение, 0, ДополнительныеПараметры.МассивДанныхАкций[0].ПредставлениеСкидки );
    ИначеЕсли Выборка.Значение = "Сумма" Тогда
        Сообщить(Выборка.Значение);
        Оповещение = Новый ОписаниеОповещения("ВведенаСуммаСкидкиМенеджераЗавершение", ЭтотОбъект, ДополнительныеПараметры);
        ПоказатьВводЧисла( Оповещение, 0, ДополнительныеПараметры.МассивДанныхАкций[0].ПредставлениеСкидки );
    ИначеЕсли Выборка = Неопределено Тогда    
        Возврат;
    КонецЕсли;


Вроде работает, но это модальный метод. Хоть у меня в конфигурате и разрешено применение модального режима, но как-то болезнено это воспринимаю. В хелпах нашел такой метод для НеМодального выбора:



&НаКлиенте
Процедура КакСделатьНемодальныйВыборЗначения(Команда)

    Цвета = Новый СписокЗначений;
    Цвета.Добавить("Красный");
    Цвета.Добавить("Зелёный");
    Цвета.Добавить("Синий");

    // процедура ПослеВыбораЭлемента определена чуть ниже
    ОповещениеПослеВыбораЭлемента = Новый ОписаниеОповещения(
        "ПослеВыбораЭлемента", ЭтотОбъект
    );

    Цвета.ПоказатьВыборЭлемента(
        ОповещениеПослеВыбораЭлемента,
        "Выберите любимый цвет"
    );

КонецПроцедуры

&НаКлиенте
Процедура ПослеВыбораЭлемента(Элемент, Параметры) Экспорт

    Если Элемент <> Неопределено Тогда
        Сообщить(Элемент.Значение);
    КонецЕсли;

КонецПроцедуры


Но как тогда сделать проверку на выбранное значение из "ПослеВыбораЭлемента(Элемент, Параметры)" в основном модуле выбора?
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #148766 · Ответов: 7 · Просмотров: 216
 

>  Выбор % или суммы при оповещении ввода значения
Constantus
Отправлено: 08.01.19, 14:05


Почти ветеран
******

Группа: Пользователи
Сообщений: 701
Регистрация: 19.09.15
Пользователь №: 45918


Перепробовал много методов, но самое страшное, что вместе с кодом при вызове формы выбора срабатывает код:


 Оповещение = Новый ОписаниеОповещения( "ВведенаСуммаСкидкиМенеджераЗавершение", ЭтотОбъект, ДополнительныеПараметры);
    ПоказатьВводЧисла( Оповещение, 0, ДополнительныеПараметры.МассивДанныхАкций[0].ПредставлениеСкидки );


Хотя по планам должен быть сработан после обработки предыдущего выбора...


Процедура ПрименитьСкидкуМенеджераЗавершение(РезультатВопроса, ДополнительныеПараметры) Экспорт
Перем ВЗ;    
  Оповещение = Новый ОписаниеОповещения("ПослеВводаЗначения", ЭтаФорма);//, Параметры);
   ОткрытьФорму("Документ.Заказ.Форма.ФормаПС",,,,,,Оповещение);
  
  
   // Здесть обработать результат выбора, потом перейти дальше


    //Оповещение = Новый ОписаниеОповещения("ВведенПроцентСкидкиМенеджераЗавершение", ЭтотОбъект, ДополнительныеПараметры); //Ввод Процента
    Оповещение = Новый ОписаниеОповещения("ВведенаСуммаСкидкиМенеджераЗавершение", ЭтотОбъект, ДополнительныеПараметры);
    ПоказатьВводЧисла( Оповещение, 0, ДополнительныеПараметры.МассивДанныхАкций[0].ПредставлениеСкидки );

КонецПроцедуры

// Выбор Типа скидки Процент/Сумма
&НаКлиенте
Процедура ПослеВводаЗначения(ВыбЗнач, Параметры) Экспорт
    Если ВыбЗнач<>Неопределено Тогда
        // обработка введенного значения
        ВыборТипаСкидки = ВыбЗнач;
    КонецЕсли;
КонецПроцедуры



ВыборТипаСкидки - сделал глобальной переменной в модуле формы...

Пробовал через

ПоказатьВводЗначения(Оповещение, ВЗ, "Выбор типа скидки: Сумма/Процент", ОписаниеТипов); // один из вариантов


Тоже не блокирует срабатывание вызова нового оповещения с вводом числа...

Вообщем совсем зарыл себя... Может есть метод ПоказатьВводЗначения, который открывает окно с выбором 2-х значений (выпадающий список), потом получает это значение и далее в зависимости от выбранного значения определяет срабатывание одного из кодов?



Применил

Массив = Новый Массив;
Массив.Добавить(Тип("ПеречислениеСсылка.ВидМодели"));

ОписаниеТипов = Новый ОписаниеТипов(Массив);
Если ВвестиЗначение(ВЗ, "Введите значение", ОписаниеТипов) Тогда
    // обработка введенного значения
    //Сообщить("Введенное значение: "+ВЗ);
КонецЕсли;


1. А как можно в этом случае вместо ссылки на Перечисления, указать конкретные текстовые значения "Сумма" и "Процент", чтобы выходило в массиве выбор этих значений? //Не хочется добавлять еще одно перечисление...

2. Будет ли такая конструкция работать в тонком клиенте?
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #148764 · Ответов: 7 · Просмотров: 216
 

>  Выбор % или суммы при оповещении ввода значения
Constantus
Отправлено: 07.01.19, 14:39


Почти ветеран
******

Группа: Пользователи
Сообщений: 701
Регистрация: 19.09.15
Пользователь №: 45918


nik389 @ Сегодня, 16:46 * ,


Ну я сейчас так и пытаюсь сделать... Подскажите как это сделать в УФ. Нужно же открыть эту форму, выбрать нужное значение и потом выбранное значение передать в код для дальнейшей обработки...

ОткрытьФорму("Документ.Заказ.Форма.ФормаПС");

На форме есть строковый реквизит. "СписокВыбора": Процент(Процент), Сумма(Сумма)

Как теперь выбранное значение передать код?


&НаКлиенте
Процедура ПрименитьСкидкуМенеджераЗавершение(РезультатВопроса, ДополнительныеПараметры) Экспорт
    
    
ОткрытьФорму("Документ.Заказ.Форма.ФормаПС").ОткрытьМодально();

//??????????????????? как обработать выбранное значение из спискавыбора формы "ФормаПС"?

    Оповещение = Новый ОписаниеОповещения( "ВведенаСуммаСкидкиМенеджераЗавершение", ЭтотОбъект, ДополнительныеПараметры);
    ПоказатьВводЧисла( Оповещение, 0, ДополнительныеПараметры.МассивДанныхАкций[0].ПредставлениеСкидки );
    
    РассчитатьИтоговыеЗначенияДокумента();
    
    
КонецПроцедуры
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #148737 · Ответов: 7 · Просмотров: 216
 

>  Выбор % или суммы при оповещении ввода значения
Constantus
Отправлено: 07.01.19, 13:41


Почти ветеран
******

Группа: Пользователи
Сообщений: 701
Регистрация: 19.09.15
Пользователь №: 45918


Приветствую, форумчане!
Самописная, 8.3, управляемые формы

Имеется вот такая процедура

&НаКлиенте
Процедура ПрименитьСкидкуМенеджераЗавершение(РезультатВопроса, ДополнительныеПараметры) Экспорт
    
    
    Оповещение = Новый ОписаниеОповещения( "ВведенаСуммаСкидкиМенеджераЗавершение", ЭтотОбъект, ДополнительныеПараметры);
    ПоказатьВводЧисла( Оповещение, 0, ДополнительныеПараметры.МассивДанныхАкций[0].ПредставлениеСкидки );
    
    РассчитатьИтоговыеЗначенияДокумента();
    
    
КонецПроцедуры


Никак не могу сообразить как лучше и правильно сделать, чтобы перед запуском оповещения задавался вопрос в каком формате будет введено число в процентах или числом, типа так:

Если Число Тогда

Оповещение = Новый ОписаниеОповещения( "ВведенаСуммаСкидкиМенеджераЗавершение", ЭтотОбъект, ДополнительныеПараметры);
ПоказатьВводЧисла( Оповещение, 0, ДополнительныеПараметры.МассивДанныхАкций[0].ПредставлениеСкидки );
Иначе //(Процент)
Оповещение = Новый ОписаниеОповещения( "ВведенПроцентСкидкиМенеджераЗавершение", ЭтотОбъект, ДополнительныеПараметры);
ПоказатьВводЧисла( Оповещение, 0, ДополнительныеПараметры.МассивДанныхАкций[0].ПредставлениеСкидки );
КонецЕсли;

Как дать понять, что сейчас будет вводиться процент или просто сумма??? Посоветуйте как бы Вы это сделали...

  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #148734 · Ответов: 7 · Просмотров: 216
 

>  Запрет на ввод даты больше текущей в документе с сообщением в УФ
Constantus
Отправлено: 03.12.18, 12:00


Почти ветеран
******

Группа: Пользователи
Сообщений: 701
Регистрация: 19.09.15
Пользователь №: 45918


sava1 @ Сегодня, 14:35 * ,

Проблема в том, что вообще нет опыта в управляемых формах. тут еще система работает в тонком клиенте, возможно где-то слышал, что "Сообщить" не может работать в тонком...

Так лучше приЗаписи или передЗаписью? На клиенте или на сервере?
  Форум: Программирование управляемых форм 1С 8.2 · Просмотр сообщения: #147735 · Ответов: 5 · Просмотров: 195
 

>  Запрет на ввод даты больше текущей в документе с сообщением в УФ
Constantus
Отправлено: 03.12.18, 10:53


Почти ветеран
******

Группа: Пользователи
Сообщений: 701
Регистрация: 19.09.15
Пользователь №: 45918


Приветствую, Форумчане!

Имеется самописная конфигурация на УФ 8.3. Документ РКО.
Требуется, что в случае, если пользователь выбрал дату больше текущей, то выходило сообщение типа "так нельзя", затирало некорректную дату и не давала возможность записать, сохранить, провести документ. Т.е. либо вводи текущую дату, лио закрывай документ без сохранения...
  Форум: Программирование управляемых форм 1С 8.2 · Просмотр сообщения: #147723 · Ответов: 5 · Просмотров: 195
 

>  Отбор минимальных значений по дате в запросе объединения
Constantus
Отправлено: 30.11.18, 10:45


Почти ветеран
******

Группа: Пользователи
Сообщений: 701
Регистрация: 19.09.15
Пользователь №: 45918


Приветствую, Форумчане!

В СКД сделал запрос на объединение нескольких документов: ПКО, БанкПоступление.

В результате получил данные типа

Закзз01 ПКО_01 01.01.2018
Закзз01 ПКО_02 01.01.2017
Закзз01 ПКО_03 01.01.2015
Закзз01 банк_01 01.01.2014
Закзз01 банк_02 01.01.2013
..............
Закзз02 ПКО_01 01.01.2018
Закзз02 ПКО_02 01.01.2017
Закзз02 ПКО_03 01.01.2015
Закзз02 банк_01 01.01.2014
Закзз02 банк_02 01.01.2013

Как видно по одному и тому же Заказу имеются различные поступления по типу и датам. Необходимо из этого запроса объединения выбрать только одно поступление с минимальной датой для каждого Заказа:

Закзз01 банк_02 01.01.2013
Закзз02 банк_02 01.01.2013

Как можно в запросе на объединение вырать минимальные значения по датам для каждого Заказа?
  Форум: Система компоновки данных · Просмотр сообщения: #147665 · Ответов: 1 · Просмотров: 163
 

>  Из формы вызвать форму выбора подразделений и заполнить ТЧ формы всеми записями (НеГруппа)
Constantus
Отправлено: 26.11.18, 12:20


Почти ветеран
******

Группа: Пользователи
Сообщений: 701
Регистрация: 19.09.15
Пользователь №: 45918


Приветствую, Форумчане!

1С:Предприятие 8.3 (8.3.6.2237), Самописная, Серверная!

Имеется некий документ. В Документе есть ТЧ с записями реквизитов "Подразделения" (справочник "Подразделения")

Требуется создать кнопку, которая вызовет форму выбора подразделений. Далее, пользователь может выбрать либо конкретное подразделение, либо выбрать группу подразделений и в ТЧ документа заполнятся все подразделения этой группы, включая подразделения вложенных групп.

Подскажите как это сделать в управляемых формах.
  Форум: Программирование управляемых форм 1С 8.2 · Просмотр сообщения: #147504 · Ответов: 1 · Просмотров: 147
 

>  Печать из обработки с учетом фильтрации данных
Constantus
Отправлено: 29.08.18, 10:03


Почти ветеран
******

Группа: Пользователи
Сообщений: 701
Регистрация: 19.09.15
Пользователь №: 45918


данный пример сработал для Обработки.

Теперь пытаюсь вывести на печать данные из табличной части документа с учетом отбора.

Печать идет из Модуля Объекта классическим способом...

    Для каждого СТР Из Начисления Цикл
        
    //Если НЕ ПроверитьСтроку(СТР) Тогда
        // Продолжить;  
        //КонецЕсли;

        
        
    Если СТР.ОфициальныйОклад > 0 Тогда;    
        
    ОбластьМакета.Параметры.Н = Н;
    ОбластьМакета.Параметры.ТН = СТР.Сотрудник.Код;
.....................................


Как в случае печати из модуля объекта вывести на печать только отобранные фильтром данные?

ЭлементыФормы.Начисления.ПроверитьСтроку(Стр)
- как применить или что применить?
  Форум: Программирование обычных форм 1С 8.2 и не интер... · Просмотр сообщения: #144854 · Ответов: 4 · Просмотров: 318
 

>  Дозаполнение ТЧ документа "забытыми" или "новыми" данными из справочника
Constantus
Отправлено: 27.08.18, 11:21


Почти ветеран
******

Группа: Пользователи
Сообщений: 701
Регистрация: 19.09.15
Пользователь №: 45918


Придумал "гениальнейшее решение".
В ТЧ справочника ввел новый реквизит "ИД" (текст, 200)

При создании новой записи в ТЧ справочника добавил код:

Элемент.ТекущиеДанные.ИД = Новый УникальныйИдентификатор;


Уникальный код создается типа: d831cd77-2b82-42b1-9153-9b1a44831329

Вот теперь планирую этот код вставлять в ТЧ документа и при добавлении (обновлении) данных ТЧ сравнивать этот код с "новыми забытыми" сотрудниками... Типа если такой код есть, то ничего не предпринимать...

Теперь тогда вопрос: насколько это гениальное решение гениально? Где подводные валуны?
  Форум: Программирование обычных форм 1С 8.2 и не интер... · Просмотр сообщения: #144791 · Ответов: 4 · Просмотров: 313
 

>  Дозаполнение ТЧ документа "забытыми" или "новыми" данными из справочника
Constantus
Отправлено: 27.08.18, 8:18


Почти ветеран
******

Группа: Пользователи
Сообщений: 701
Регистрация: 19.09.15
Пользователь №: 45918


Приветствую, форумчане!
"Управление торговлей 10.3", (Моби-С 5.5). "ABBYY Ukraine", 2003-2014 (2.3.20.1)

Имеется самописные справочник "Сотрудники" и самописный документ "Начисление заработной платы.

В документе "Начисление" ТЧ заполняется автоматически по кнопке. Код обходит справочник "Сотрудники" и по определенному алгоритму заполняет нужных сотрудников в ТЧ документа "Начисление".

Код работает правильно и без проблем. Но столкнулся со следующей проблемой.

Предположим забыли добавить в справочник "Сотрудники" нового сотрудника и/или перевели в другой отдел, поменяли оклад и т.д.

Конечно, можно взять и нажать вышеупомянутую кнопку и ТЧ "Начисления" заполнится новым правильным списком, но данные расчета по "старым" сотрудникам естественно затруться и расчет нужно будет проводить заново, что крайне плохо...

Каким образом можно сделать при заполнении ТЧ документа проверку, что по такому-то сотруднику уже есть данные в ТЧ и добавлять его не нужно, т.е. оставить данные ТЧ не измененными? Т.е. дозаполнить ТЧ только "новыми" или "забытыми" сотрудниками?
  Форум: Программирование обычных форм 1С 8.2 и не интер... · Просмотр сообщения: #144787 · Ответов: 4 · Просмотров: 313
 

>  Настройки договоров по аналогии с 10.3
Constantus
Отправлено: 13.08.18, 13:21


Почти ветеран
******

Группа: Пользователи
Сообщений: 701
Регистрация: 19.09.15
Пользователь №: 45918


Управление торговлей, редакция 11.2 (11.2.3.124)

Пытаюсь самостоятельно изучить эту конфигурацию. Много чего непонятного и навороченного, но хочу (пытаюсь) понять следующее.

В 10.3 Договора с контрагентами (покупателями) настраивались легко и визуально (интуитивно) понятно.
У меня есть контрагенты покупатели, создаю договор "Основной", указываю вести "по договору в целом", "вести учет по документам взаиморасчетов"

Пытаюсь в 11.2 сделать нечто подобное, но никак не могу настроить такой учет. При создании договора выходит несколько вариантов "по договору" (заказам/накладным)

Нигде не могу найти нечто, что позволит вести учет по документам взаиморасчетов, чтобы потом при формировании например ПКО выбирать нужную реализацию, по которой пришли деньги.

Посоветуйте куда идти? Или там вообще реализована другая логика?
  Форум: Управление торговлей для Украины редакция 3 (Уп... · Просмотр сообщения: #144352 · Ответов: 1 · Просмотров: 213
 

>  АвтоОбмен РИБ: проблема с rphost.exe
Constantus
Отправлено: 13.08.18, 10:35


Почти ветеран
******

Группа: Пользователи
Сообщений: 701
Регистрация: 19.09.15
Пользователь №: 45918


Приветствую, форумчане!
"Управление торговлей 10.3", (Моби-С 5.5). "ABBYY Ukraine", 2003-2014 (2.3.20.1)

Иногда возникает ситуация, что автообмен встает замертво на филиале.

Выявил долгим творческим путем, что обмен зависает из-за того, что временная папка, куда скидываются временные файлы для обмена, заблокирована процессом rphost.exe

Для устранения этой неприятности, написал БАТник, где этот процесс удаляется и автообмен восстанавливается.

Из-за чего такое может быть и как побороть эту проблему?

На филиале установлен Посгрес 9.4 1с.
  Форум: Управление торговлей для Украины редакция 2 (Уп... · Просмотр сообщения: #144340 · Ответов: 0 · Просмотров: 227
 

>  Печать из обработки с учетом фильтрации данных
Constantus
Отправлено: 09.08.18, 14:34


Почти ветеран
******

Группа: Пользователи
Сообщений: 701
Регистрация: 19.09.15
Пользователь №: 45918


ed.kharkov @ Сегодня, 17:22 * ,

Вроде сработало, но объясните логику работы кода!!!
  Форум: Программирование обычных форм 1С 8.2 и не интер... · Просмотр сообщения: #144229 · Ответов: 4 · Просмотров: 318
 

>  Печать из обработки с учетом фильтрации данных
Constantus
Отправлено: 09.08.18, 12:19


Почти ветеран
******

Группа: Пользователи
Сообщений: 701
Регистрация: 19.09.15
Пользователь №: 45918


Приветствую, форумчане!
"Управление торговлей 10.3", (Моби-С 5.5). "ABBYY Ukraine", 2003-2014 (2.3.20.1)

Создал обработку. В обработке имеется командная панель с фильтрами отбора данных.

Создал кнопку печати

Код
    ТабДок = Новый ТабличныйДокумент;
    Макет = ПолучитьМакет("Макет");
    
    ОбластьМакета = Макет.ПолучитьОбласть("Шапка");
    ОбластьМакета.Параметры.ДатаНачала = Формат(ДатаНачала,    "ДФ='dd.MM.yyyy'");
    ОбластьМакета.Параметры.ДатаОкончания = Формат(ДатаОкончания,    "ДФ='dd.MM.yyyy'");
    ТабДок.Вывести(ОбластьМакета);

    
    ОбластьМакета = Макет.ПолучитьОбласть("ОбластьПечати");
    
    Для Каждого Стр Из Детально Цикл
        
    ОбластьМакета.Параметры.Снят = Стр.Снят;
    ОбластьМакета.Параметры.Удален = Стр.Удален;
    ОбластьМакета.Параметры.Дата = Формат(Стр.Дата,    "ДФ='dd.MM.yyyy'");
    ОбластьМакета.Параметры.Номер = Стр.Номер;
*************
    
    ТабДок.Вывести(ОбластьМакета);
    КонецЦикла;
    
    УниверсальныеМеханизмы.НапечататьДокумент(ТабДок, 1, Ложь, "Отчет по счет-фактурам (аналитический) за период с " + Формат(ДатаНачала, "ДФ='dd.MM.yyyy'") + " по " + Формат(ДатаОкончания,    "ДФ='dd.MM.yyyy'") );


Печатает как надо, но если я на командной панели ставлю отбор, то кнопка печати срабатывает без учета фильтров и печатает опять таки все данные, полученные обработкой

Как нужно изменить код печати из обработки с учетом фильтров, установленных на командной панели?
  Форум: Программирование обычных форм 1С 8.2 и не интер... · Просмотр сообщения: #144221 · Ответов: 4 · Просмотров: 318
 

>  Восстановить базу Постгресс из файла *.sql
Constantus
Отправлено: 08.08.18, 8:47


Почти ветеран
******

Группа: Пользователи
Сообщений: 701
Регистрация: 19.09.15
Пользователь №: 45918


Flexy @ Вчера, 18:43 * ,

Переименование расширения не помогло
  Форум: Администрирование и настройка серверов баз данных · Просмотр сообщения: #144154 · Ответов: 5 · Просмотров: 337
 

>  Восстановить базу Постгресс из файла *.sql
Constantus
Отправлено: 07.08.18, 14:11


Почти ветеран
******

Группа: Пользователи
Сообщений: 701
Регистрация: 19.09.15
Пользователь №: 45918


Flexy @ Сегодня, 16:36 * ,

Я пытался через pgАdmin-3, но там восстановление требует файл basename.backup
а у меня есть архив

basename.sql
  Форум: Администрирование и настройка серверов баз данных · Просмотр сообщения: #144128 · Ответов: 5 · Просмотров: 337
 

>  Восстановить базу Постгресс из файла *.sql
Constantus
Отправлено: 07.08.18, 9:12


Почти ветеран
******

Группа: Пользователи
Сообщений: 701
Регистрация: 19.09.15
Пользователь №: 45918


PostgresPro 1C 9.4 1c

С помощью программы PostgreSQL Backup делаю суточные бакапы (UT_ASB201808050200.sql)

Подскажите как максимально просто восстановить эту базу, если можно с картинками?
Или укажите ресурс с картинками icon_beer17.gif
  Форум: Администрирование и настройка серверов баз данных · Просмотр сообщения: #144121 · Ответов: 5 · Просмотров: 337
 

>  При открытии не вносить изменения в поле выбора
Constantus
Отправлено: 03.08.18, 15:40


Почти ветеран
******

Группа: Пользователи
Сообщений: 701
Регистрация: 19.09.15
Пользователь №: 45918


Vidocq05 @ Сегодня, 18:35 * ,

Это реквизит объекта...
  Форум: Программирование обычных форм 1С 8.2 и не интер... · Просмотр сообщения: #144034 · Ответов: 6 · Просмотров: 368
 

>  При открытии не вносить изменения в поле выбора
Constantus
Отправлено: 03.08.18, 15:23


Почти ветеран
******

Группа: Пользователи
Сообщений: 701
Регистрация: 19.09.15
Пользователь №: 45918


Vidocq05 @ Сегодня, 18:06 * ,

Может быть, но перенос этого кода не помог. При открытии формы данное поле пустое, хотя когда тыкаешь, то он фокусирует в списке нужное значение, а визуально всё пусто
  Форум: Программирование обычных форм 1С 8.2 и не интер... · Просмотр сообщения: #144032 · Ответов: 6 · Просмотров: 368
 

>  При открытии не вносить изменения в поле выбора
Constantus
Отправлено: 03.08.18, 14:44


Почти ветеран
******

Группа: Пользователи
Сообщений: 701
Регистрация: 19.09.15
Пользователь №: 45918


Приветствую, форумчане!
"Управление торговлей 10.3", (Моби-С 5.5). "ABBYY Ukraine", 2003-2014 (2.3.20.1)

У меня при открытии формы (нетипового документа) стоит код, который заполняет реквизит "ПериодНачисления" (дата) в формате "Месяц год".
Этот реквизит оформлен как поле выбора. Код заполняет список выбора и в зависимости от даты (первый день месяца) заполняет в нужном формате.

    Если НЕ ЗначениеЗаполнено(ПериодНачисления) Тогда
        СформироватьСписокВыбораМесяца(Год(ТекущаяДата()));
    Иначе
        СформироватьСписокВыбораМесяца(Год(ПериодНачисления));
        ПериодНачисления = ЭлементыФормы.ПериодНачисления.СписокВыбора[Месяц(ПериодНачисления)+1].Значение;
    КонецЕсли;



Процедура СформироватьСписокВыбораМесяца(Знач Год)
    
    Год = Число(Год);
    СписокВыбора = ЭлементыФормы.ПериодНачисления.СписокВыбора;
    СписокВыбора.Очистить();
    СписокВыбора.Добавить(Null);
    СписокВыбора.Добавить(Формат(Год-1, "ЧГ=0"), Формат(Год-1, "ЧГ=0"));
    Для М = 1 По 12 Цикл
        СформДата = Дата(Год, М, 1);
        Наим = Формат(СформДата, "ДФ='ММММ гггг"" г.""'");
        СписокВыбора.Добавить(СформДата, Наим);    
    КонецЦикла;
    СписокВыбора.Добавить(Формат(Год+1, "ЧГ=0"), Формат(Год+1, "ЧГ=0"));
    
КонецПроцедуры



Но столкнулся с такой проблемой, получается так, что всегда при открытии этот код переопределяет значение "ПериодНачисления" и если ты даже просто открыл документ для просмотра, то при закрытии сообщает, что данные были изменены и требуется сохранить.

Как можно используя эти код, при открытии не проводить переопределение старого значения на новое?

Если ремачу
//ПериодНачисления = ЭлементыФормы.ПериодНачисления.СписокВыбора[Месяц(ПериодНачисления)+1].Значение;

то реквизит после открытия пустой.
  Форум: Программирование обычных форм 1С 8.2 и не интер... · Просмотр сообщения: #144029 · Ответов: 6 · Просмотров: 368
 

>  Ввод на основании Заявки: не заполняются некоторые реквизиты в РКО
Constantus
Отправлено: 26.07.18, 10:37


Почти ветеран
******

Группа: Пользователи
Сообщений: 701
Регистрация: 19.09.15
Пользователь №: 45918


Нашел

В модуле формы документа в Процедуре ЗаполнитьКонтрагента() стоял код:

    УстановитьОграничениеТипаКонтрагента();
    Контрагент = ЭлементыФормы.Контрагент.ОграничениеТипа.ПривестиЗначение(Контрагент);



А нужен был:
    Если ВидОперации = Перечисления.ВидыОперацийРКО.РасходДенежныхСредствПрочее 
        ИЛИ ВидОперации = Перечисления.ВидыОперацийРКО.ВзносНаличнымиВБанк Тогда
        Контрагент = Неопределено;
    Иначе
        УстановитьОграничениеТипаКонтрагента();
        Контрагент = ЭлементыФормы.Контрагент.ОграничениеТипа.ПривестиЗначение(Контрагент);
    КонецЕсли;


Недостающее не делала Контрагента неопределенным, а там далее шла проверка на СДДС...
  Форум: Программирование обычных форм 1С 8.2 и не интер... · Просмотр сообщения: #143770 · Ответов: 1 · Просмотров: 296
 

>  Ввод на основании Заявки: не заполняются некоторые реквизиты в РКО
Constantus
Отправлено: 26.07.18, 8:54


Почти ветеран
******

Группа: Пользователи
Сообщений: 701
Регистрация: 19.09.15
Пользователь №: 45918


Приветствую, форумчане!
"Управление торговлей 10.3", (Моби-С 5.5). "ABBYY Ukraine", 2003-2014 (2.3.20.1)

На основании Заявки пытаюсь сформировать РКО.
Когда Заявка имеет операцию "Прочий расход денежных средств", то при формировании на ее основе РКО не заполняются реквизиты:
1. Статья движения денежных средств
2. Документ основания, т.е. сама Заявка

Данные поля пустые. Если выбирать другие типы операций, то эти данные переносятся в РКО, только при этом виде операции идет такой конфуз.

Конфигурация досталась в наследство, может, что и было изменено. Но так ничего не нашел.

Прошелся по модулю "ОбработкаЗаполнения(Основание)", вроде всё нормально.
Прошелся по модулю при открытии. Обнаружил такое

При выполнении "УправлениеДенежнымиСредствами.УстановитьСтатьюДДСПоУмолчанию(СтрокаПлатеж,ВидОперации);"

    Если НЕ СтрокаПлатеж.СтатьяДвиженияДенежныхСредств=Справочники.СтатьиДвиженияДенежныхСредств.ПустаяСсылка() Тогда
        Возврат;


Условие не выполняется, т.е. при открытии статья становится пустой ссылкой. Никак не могу найти место, где происходит уничтожение ссылки на статью из Заявки...

Сравнил с другой конфигурацией (последнее обновление УТ 10.3, демо), там вроде всё тоже самое, но всё заполняется.

Помогите разобраться, где еще может происходит затирание ссылок на эти реквизиты при формировании на основании?
  Форум: Программирование обычных форм 1С 8.2 и не интер... · Просмотр сообщения: #143764 · Ответов: 1 · Просмотров: 296
 

29 страниц V   1 2 3 > » 

Новые сообщения  Открытая тема (есть новые ответы)
Опрос  Опрос (есть новые голоса)
Нет новых сообщений  Открытая тема (нет новых ответов)
Нет новых голосов  Опрос (нет новых голосов)
Популярная тема  Горячая тема (есть новые ответы)
Закрыта  Закрытая тема
Нет новых  Горячая тема (нет новых ответов) Перемещена  Тема перемещена
 

RSS Текстовая версия Сейчас: 22.01.19, 12:48
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!

Курсы валют: доллар США к гривне Курсы валют: евро к гривне Курсы валют: российский рубль к гривне