Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Неназначенных незавершенных заказов: 1
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Войти | Зарегистрироваться )

43 страниц V   1 2 3 > » 

>  1с начала подвисать при работе
Flexy
Отправлено: 11.01.18, 17:39


Танцор с Бубном
Иконка группы

Группа: Местный
Сообщений: 1079
Регистрация: 15.03.10
Из: Днепра
Пользователь №: 2944


Цитата(Alexandro @ 11.01.18, 14:07) *
все работало стабильно и без изменений около 4 лет на этом же железе.

База росла...Железо старело...
  Форум: Управление торговлей для Украины редакция 2 (Уп... · Просмотр сообщения: #137110 · Ответов: 7 · Просмотров: 359
 

>  Как программно разрешить или запретить сохранение реквизита...
Flexy
Отправлено: 29.12.17, 12:45


Танцор с Бубном
Иконка группы

Группа: Местный
Сообщений: 1079
Регистрация: 15.03.10
Из: Днепра
Пользователь №: 2944


Цитата(Стрелок @ 29.12.17, 12:31) *
2. тыкаем энтер

Дык автор писал, что юзер тыкает энтер.
Цитата(Стрелок @ 29.12.17, 12:31) *
процедура в "дополнительно" срабатывает ТОЛЬКО если значение реквизита изменено и ТОЛЬКО один раз. Для нового срабатывания нужно чтобы реквизит опять изменился.

У меня постоянно срабатывает smile.gif Видимо, какая-то другая 7.7 у меня smile.gif

Да и кстати:
Форма.МойРеквизит.ВыполнятьФормулуТолькоПриИзменении(0);

Ни кто не отменял.
  Форум: Программирование в 1С Предприятие 7.7 · Просмотр сообщения: #136788 · Ответов: 13 · Просмотров: 517
 

>  Как программно разрешить или запретить сохранение реквизита...
Flexy
Отправлено: 26.12.17, 17:47


Танцор с Бубном
Иконка группы

Группа: Местный
Сообщений: 1079
Регистрация: 15.03.10
Из: Днепра
Пользователь №: 2944


Зачем так сложно?
В свойствах поля ввода на закладке "Дополнительно" в поле "Формула" пишите имя Вашей процедуры, в которой будут происходить проверка введенного значения. Напр. ПроверитьЗначение().
В модуле формы:
Процедура ПроверитьЗначение()
Если МойРеквизит <> НужноеЗначение Тогда
        Возврат;
КонецЕсли;
КонецПроцедуры
  Форум: Программирование в 1С Предприятие 7.7 · Просмотр сообщения: #136691 · Ответов: 13 · Просмотров: 517
 

>  HTTPСоединение + SSL. Код состояния 500
Flexy
Отправлено: 15.12.17, 17:04


Танцор с Бубном
Иконка группы

Группа: Местный
Сообщений: 1079
Регистрация: 15.03.10
Из: Днепра
Пользователь №: 2944


А так?
ssl = Новый ЗащищенноеСоединениеOpenSSL(Неопределено, Неопределено);


Соединение = Новый HTTPСоединение(РесурсСSSL,443,,,,,ssl);
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #136254 · Ответов: 5 · Просмотров: 286
 

>  Відслідковування причини вилогінування користувача
Flexy
Отправлено: 06.12.17, 23:13


Танцор с Бубном
Иконка группы

Группа: Местный
Сообщений: 1079
Регистрация: 15.03.10
Из: Днепра
Пользователь №: 2944


Ох...помню как-то давно на 7.7 мне весь мозг выело выполнение регламентов под актив сессиями виртуальных пользователей. Такой гимор....
Психонул....переписал все регламенты на vbs-скрипты, которые поднимали коннект по OLE и делали, что нужно. 32541510.gif А сами скрипты воткнул в в виндовый шэдуллер. Уже лет 5 прошло...а оно так до сих пор и работает 47046430.gif
  Форум: Администрирование и настройка серверов баз данных · Просмотр сообщения: #135792 · Ответов: 11 · Просмотров: 353
 

>  Программист 1С. Одесса.
Flexy
Отправлено: 23.11.17, 22:15


Танцор с Бубном
Иконка группы

Группа: Местный
Сообщений: 1079
Регистрация: 15.03.10
Из: Днепра
Пользователь №: 2944


Цитата(Batchir @ 23.11.17, 20:00) *
Для проверки этой способности я дам вам 40 строчек готового кода и попрошу объяснить, что там написано.

Можно в личку эти строки? Просто интересно проверить свой уровень smile.gif
  Форум: Предложения работы · Просмотр сообщения: #135265 · Ответов: 30 · Просмотров: 1696
 

>  в УТ3 для Украины после установки платформы 8.3.10 нет варианта открытия документов в отдельных окнах
Flexy
Отправлено: 21.11.17, 13:47


Танцор с Бубном
Иконка группы

Группа: Местный
Сообщений: 1079
Регистрация: 15.03.10
Из: Днепра
Пользователь №: 2944


andreykyiv@bigmir.net @ Сегодня, 13:18 * ,
У меня на этом релизе работает: 8.3.8.2027.
  Форум: Платформа 8 · Просмотр сообщения: #135171 · Ответов: 11 · Просмотров: 466
 

>  в УТ3 для Украины после установки платформы 8.3.10 нет варианта открытия документов в отдельных окнах
Flexy
Отправлено: 15.11.17, 23:16


Танцор с Бубном
Иконка группы

Группа: Местный
Сообщений: 1079
Регистрация: 15.03.10
Из: Днепра
Пользователь №: 2944


Цитата(andreykyiv@bigmir.net @ 15.11.17, 23:11) *
неа, не сработало ((

Жаль... Мне такой режим открытия окон тоже очень нравиться.

Спасибо за инфу.
  Форум: Платформа 8 · Просмотр сообщения: #134940 · Ответов: 11 · Просмотров: 466
 

>  в УТ3 для Украины после установки платформы 8.3.10 нет варианта открытия документов в отдельных окнах
Flexy
Отправлено: 15.11.17, 23:06


Танцор с Бубном
Иконка группы

Группа: Местный
Сообщений: 1079
Регистрация: 15.03.10
Из: Днепра
Пользователь №: 2944


Попробуйте: st*******/UT3/ru_RU/?C=isdi
  Форум: Платформа 8 · Просмотр сообщения: #134937 · Ответов: 11 · Просмотров: 466
 

>  в УТ3 для Украины после установки платформы 8.3.10 нет варианта открытия документов в отдельных окнах
Flexy
Отправлено: 15.11.17, 12:40


Танцор с Бубном
Иконка группы

Группа: Местный
Сообщений: 1079
Регистрация: 15.03.10
Из: Днепра
Пользователь №: 2944


Встроенная справка 1С (по кнопке F1):
Запуск 1С:Предприятие 8 в режиме веб-клиента
Для запуска веб-клиента необходимо в адресной строке веб-браузера ввести адрес следующего вида:
http://hostt
где host – адрес сайта, соответствующего информационной базе.

Веб-клиент не поддерживает параметры командной строки толстого и тонкого клиентов. Для веб-клиента существуют свои параметры запуска. Они указываются в строке веб-браузера после символа "?", параметры разделяются символом "&".

Синтаксис строки запроса: http://host?ИмяПараметра1=ЗначениеПараметр...чениеПараметра2

Пример: http://localhost/demo?C=userParameter

Параметры командной строки в режиме веб-клиента
iTaxi — режим интерфейса "Такси".

itdi – режим интерфейса с использованием закладок.

isdi – режим интерфейса с использованием отдельных окон (используется по умолчанию).

  Форум: Платформа 8 · Просмотр сообщения: #134903 · Ответов: 11 · Просмотров: 466
 

>  в УТ3 для Украины после установки платформы 8.3.10 нет варианта открытия документов в отдельных окнах
Flexy
Отправлено: 14.11.17, 14:49


Танцор с Бубном
Иконка группы

Группа: Местный
Сообщений: 1079
Регистрация: 15.03.10
Из: Днепра
Пользователь №: 2944


Нужно добавить в дополнительные параметры базы ключ /isdi
  Форум: Платформа 8 · Просмотр сообщения: #134861 · Ответов: 11 · Просмотров: 466
 

>  Помогите УНФ + синхронизация интернет магазина
Flexy
Отправлено: 12.11.17, 22:53


Танцор с Бубном
Иконка группы

Группа: Местный
Сообщений: 1079
Регистрация: 15.03.10
Из: Днепра
Пользователь №: 2944


Цитата(Kostarika @ 12.11.17, 20:59) *
Такое возможно?

Да.
Цитата(Kostarika @ 12.11.17, 20:59) *
У кого был опыт?

Думаю...у многих.

В чем вопрос?
  Форум: 1С Управление небольшой фирмой для Украины · Просмотр сообщения: #134783 · Ответов: 4 · Просмотров: 322
 

>  Убрать пустые строки в ФормеСписка справочника
Flexy
Отправлено: 12.11.17, 15:09


Танцор с Бубном
Иконка группы

Группа: Местный
Сообщений: 1079
Регистрация: 15.03.10
Из: Днепра
Пользователь №: 2944


Процедура СправочникСписокПриПолученииДанных(Элемент, ОформленияСтрок)
    .......
    
// Flexy
СписокОтбор = Новый СписокЗначений;
//-----
Для Каждого Строка ИЗ ОформленияСтрок Цикл
    
    СтрТЗ = тзВыгрузка.Найти(Строка.ДанныеСтроки.Ссылка, "Партия");
    Если СтрТЗ <> Неопределено Тогда
        Строка.Ячейки.Остаток.УстановитьТекст(СтрТЗ.КоличествоОстаток);
        
        // Flexy
        Если СтрТЗ.КоличествоОстаток = 0 Тогда
            СписокОтбор.Добавить(СтрТЗ.Партия);
        КонецЕсли;
        //-----
        
    КонецЕсли;    
    
КонецЦикла;    
// Flexy
Если СписокОтбор.Количество() > 0 Тогда
    СправочникСписок.Отбор.Ссылка.Использование = Истина;
    СправочникСписок.Отбор.Ссылка.ВидСравнения = ВидСравнения.НеВСписке;
    СправочникСписок.Отбор.Ссылка = СписокОтбор;
КонецЕсли;
//-----
КонецПроцедуры
  Форум: Программирование обычных форм 1С 8.2 и не интер... · Просмотр сообщения: #134779 · Ответов: 6 · Просмотров: 283
 

>  Не оприходуется на второй склад. Как быть?
Flexy
Отправлено: 09.11.17, 13:49


Танцор с Бубном
Иконка группы

Группа: Местный
Сообщений: 1079
Регистрация: 15.03.10
Из: Днепра
Пользователь №: 2944


Склад ордерный? Нужно сделать Ордер на отражение излишков.
  Форум: Управление торговлей для Украины редакция 3 (Уп... · Просмотр сообщения: #134676 · Ответов: 2 · Просмотров: 187
 

>  Ордерная схема при реализации.
Flexy
Отправлено: 09.11.17, 13:43


Танцор с Бубном
Иконка группы

Группа: Местный
Сообщений: 1079
Регистрация: 15.03.10
Из: Днепра
Пользователь №: 2944


Цитата(Constantus @ 09.11.17, 10:15) *
Выписываю расходный ордер на основании этой реализации, но получается, что товара не хватает:

Почему не реализовать столько, сколько "хватает"?
  Форум: Управление торговлей для Украины редакция 2 (Уп... · Просмотр сообщения: #134675 · Ответов: 3 · Просмотров: 256
 

>  Работа с 1С при помощи powershell через OLE
Flexy
Отправлено: 09.11.17, 13:28


Танцор с Бубном
Иконка группы

Группа: Местный
Сообщений: 1079
Регистрация: 15.03.10
Из: Днепра
Пользователь №: 2944


$Base1C = New-Object -comobject V83.ComConnector


$Base1C | Get-Member -MemberType Methods

Name                  MemberType Definition
----                  ---------- ----------
Connect               Method     IDispatch Connect (string)
ConnectAgent          Method     IServerAgentConnection ConnectAgent (string)
ConnectWorkingProcess Method     IWorkingProcessConnection ConnectWorkingProcess (string)
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #134673 · Ответов: 2 · Просмотров: 308
 

>  Отчет по двум запросам
Flexy
Отправлено: 07.11.17, 13:23


Танцор с Бубном
Иконка группы

Группа: Местный
Сообщений: 1079
Регистрация: 15.03.10
Из: Днепра
Пользователь №: 2944


Цитата(ranis @ 07.11.17, 13:17) *
Суть в том что в 1 таблице одно условие, во второй таблице другое условие. В этом и проблема

Сделайте одним запросом
СписокУсловий = СоздатьОбъект("СписокЗначений");
СписокУсловий.Добавить(Расчет1);
СписокУсловий.Добавить(Расчет2);
ТекстЗапроса="
...
|Условие(Расчет В СписокУсловий );
  Форум: Программирование в 1С Предприятие 7.7 · Просмотр сообщения: #134534 · Ответов: 32 · Просмотров: 761
 

>  Отчет по двум запросам
Flexy
Отправлено: 07.11.17, 13:15


Танцор с Бубном
Иконка группы

Группа: Местный
Сообщений: 1079
Регистрация: 15.03.10
Из: Днепра
Пользователь №: 2944


Цитата(ranis @ 07.11.17, 13:01) *
И что сделать?

Выводить в одну таблицу два отчета:
Таб = СоздатьОбъект("ТабличныйДокумент");
//Вывод первого отчета
// Вывод второго отчета
Таб.Показать();

Или в разные шаблоны:
Таб = СоздатьОбъект("ТабличныйДокумент");
Таб.ИсходнаяТаблица("Отчет_1");
// Вывод отчета
Таб.Показать();
Таб = СоздатьОбъект("ТабличныйДокумент");
Таб.ИсходнаяТаблица("Отчет_2");
// Вывод второго отчета в другой шаблон
Таб.Показать();
  Форум: Программирование в 1С Предприятие 7.7 · Просмотр сообщения: #134531 · Ответов: 32 · Просмотров: 761
 

>  Отчет по двум запросам
Flexy
Отправлено: 07.11.17, 12:55


Танцор с Бубном
Иконка группы

Группа: Местный
Сообщений: 1079
Регистрация: 15.03.10
Из: Днепра
Пользователь №: 2944


Табличный документ - переменная "Таб". Перезаписывается, после первого запроса. Она же и выводиться последней.
Таб.ВывестиСекцию("Итого"); 
...
Таб = СоздатьОбъект("Таблица");
  Форум: Программирование в 1С Предприятие 7.7 · Просмотр сообщения: #134529 · Ответов: 32 · Просмотров: 761
 

>  Ручная наценка в % отдельно на каждый товар.
Flexy
Отправлено: 06.11.17, 23:11


Танцор с Бубном
Иконка группы

Группа: Местный
Сообщений: 1079
Регистрация: 15.03.10
Из: Днепра
Пользователь №: 2944


1. Выделить нужные строки в документе.
2. Изменить цены
3. Изменить на процент
4. Задать процент по нужному типу цены
5. Рассчитать
  Форум: Управление торговлей для Украины редакция 3 (Уп... · Просмотр сообщения: #134502 · Ответов: 3 · Просмотров: 196
 

>  Валовая прибыль розници по подразделениям не показывает возврат
Flexy
Отправлено: 03.11.17, 12:53


Танцор с Бубном
Иконка группы

Группа: Местный
Сообщений: 1079
Регистрация: 15.03.10
Из: Днепра
Пользователь №: 2944


Pashaboston @ Сегодня, 12:50 * ,
Сделайте Расчет себестоимости. Если не изменяет память, после этого отчет должен будет показать данный товар с отрицательной валовой прибылью.
  Форум: Управление торговлей для Украины редакция 3 (Уп... · Просмотр сообщения: #134365 · Ответов: 6 · Просмотров: 239
 

>  Валовая прибыль розници по подразделениям не показывает возврат
Flexy
Отправлено: 03.11.17, 12:37


Танцор с Бубном
Иконка группы

Группа: Местный
Сообщений: 1079
Регистрация: 15.03.10
Из: Днепра
Пользователь №: 2944


Pashaboston @ Сегодня, 12:20 * ,
Себестоимость рассчитана? Какая валовая прибыль по возращенному товару?
  Форум: Управление торговлей для Украины редакция 3 (Уп... · Просмотр сообщения: #134362 · Ответов: 6 · Просмотров: 239
 

>  Валовая прибыль розници по подразделениям не показывает возврат
Flexy
Отправлено: 03.11.17, 12:14


Танцор с Бубном
Иконка группы

Группа: Местный
Сообщений: 1079
Регистрация: 15.03.10
Из: Днепра
Пользователь №: 2944


Цитата(Pashaboston @ 03.11.17, 12:01) *
Какая разница между отчетами не пойму?

Возврат товара после закрытия смены делается уже не чеком. А документом "Возврат товара от покупателя". Таким образом это уже не "Розничная операция".
  Форум: Управление торговлей для Украины редакция 3 (Уп... · Просмотр сообщения: #134357 · Ответов: 6 · Просмотров: 239
 

>  Из формы списка открыть другую (дополнительную) форму документа (создавать)
Flexy
Отправлено: 03.11.17, 11:40


Танцор с Бубном
Иконка группы

Группа: Местный
Сообщений: 1079
Регистрация: 15.03.10
Из: Днепра
Пользователь №: 2944


pablo @ 31.10.17, 16:50 * ,
// Ввод нового в форме списка 2
Процедура СписокПередНачаломДобавления(Элемент, Отказ, Копирование)
    Отказ = Истина;
    ОткрытьФорму("Документ.ЗаказПоставщику.Форма.ФормаДокумента1");
КонецПроцедуры

// Открытие в форме списка 2
Процедура СписокВыбор(Элемент, ВыбраннаяСтрока, Колонка, СтандартнаяОбработка)
    СтандартнаяОбработка = Ложь;
    ОткрытьФорму("Документ.ЗаказПоставщику.Форма.ФормаДокумента1", Новый Структура("Ссылка",ВыбраннаяСтрока.Ссылка));
КонецПроцедуры
  Форум: Программирование обычных форм 1С 8.2 и не интер... · Просмотр сообщения: #134355 · Ответов: 8 · Просмотров: 391
 

>  Учет пробега автомобиля
Flexy
Отправлено: 20.10.17, 13:37


Танцор с Бубном
Иконка группы

Группа: Местный
Сообщений: 1079
Регистрация: 15.03.10
Из: Днепра
Пользователь №: 2944


Имхо, лучше оборотный регистр.
  Форум: Программирование обычных форм 1С 8.2 и не интер... · Просмотр сообщения: #133720 · Ответов: 5 · Просмотров: 244
 

43 страниц V   1 2 3 > » 

Новые сообщения  Открытая тема (есть новые ответы)
Опрос  Опрос (есть новые голоса)
Нет новых сообщений  Открытая тема (нет новых ответов)
Нет новых голосов  Опрос (нет новых голосов)
Популярная тема  Горячая тема (есть новые ответы)
Закрыта  Закрытая тема
Нет новых  Горячая тема (нет новых ответов) Перемещена  Тема перемещена
 

RSS Текстовая версия Сейчас: 22.02.18, 9:19
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!

Курсы валют: доллар США к гривне Курсы валют: евро к гривне Курсы валют: российский рубль к гривне