Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Неназначенных незавершенных заказов: 4
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Войти | Зарегистрироваться )


Свернуть

> Добро пожаловать на наш форум

Здравствуйте уважаемый посетитель. К сожалению вы не были распознаны форумом как зарегистрированный пользователь. Для полноценного использования возможностей нашего форума вам необходимо зарегистрироваться. Если вы уже зарегистрированы на форуме, то вам необходимо пройти авторизацию, используя Ваш логин и пароль.

Логин:   
Пароль:
 

Форум:

Новые темы (за 20 дней):

Последние сообщения:

Наши сервисы:

Дополнительно:

Новости для бухгалтера:

 
Сохранить реквизит на форме в обход запрета изменения данных [раздел Программирование управляемых форм 1С 8.2]
Автор Constantus — 24.04.19, 12:45 — 1 комментариев
Приветствую, Форумчане!
1с8.3.6, БСП, самописная, УФ

На всех документах имеется программное ограничение на запись и проведение документов задним числом - подписка на событие "При записи"

Но так сейчас сложилась ситуация, что на некоторых документах есть один реквизит в шапке, который некоторым сотрудникам нужно редактировать при любых условиях.

Есть реквизит "Статус", которых показывает, правильно ли оформлен документ со значениями "Хорошо", "Хорошо, но не совсем", "Плохой"...

имеется кнопка, которая формирует это значение статуса.

Можно ли как-то "обойти" этот запрет, чтобы этот реквизит был изменен и сохранен втихоря в обход события подписки "При записи"???

Этот реквизит не участвует ни в одном регистре, чисто информативный...
Просмотров: 24, последний комментарий от mut   
свод отчетов для апк украины 7.7 [раздел Прочее 1С 7.7]
Автор GoodBoy — 24.04.19, 12:24 — 1 комментариев
найти свод отчетов для апк украины 7.7 2019г.


 ! 

Правила: 7
 
Просмотров: 25, последний комментарий от Vofka   
В УТП раздельное начисление и выплата з/п в упр. и регл. учете [раздел Программирование в 1С Предприятие 8.3]
Автор Vidocq05 — 24.04.19, 10:01 — 2 комментариев
УТП для Украины 1.2

Появилась необходимость раздельного начисления и выплата з/п в упр. и регл. учете. Но проблема в том, что эти галочки недоступны для изменения в документах. Они выставляются автоматически при выборе организации и зависят от настроек учетной политики по персоналу. Т.е. как установлено в регистре сведений "Учетная политика по персоналу" в каком учете отражать з/п для конкретной организации, так эти галочки и будут устанавливаться в документах.
И я так понимаю это сделано не просто так.

Вопрос: Какие негативные последствия будут если я в конфигурации сделаю доступным установку и снятие этих галочек в документах?

Я пока посмотрю по коду. Но может кто-то сразу скажет, что этого делать нельзя или можно, и опишет причины.
Просмотров: 26, последний комментарий от Vidocq05   
Расшифровка по регистратору в отчете по регистр сведений [раздел Система компоновки данных]
Автор Constantus — 24.04.19, 8:46 — 1 комментариев
Приветствую, Форумчане!
1с8.3.6, БСП, самописная, УФ

Имеется простой отчет СКД по регистру сведений:

ВЫБРАТЬ
    СтатусыЗаказов.Заказ,
    КОЛИЧЕСТВО(СтатусыЗаказов.Статус) КАК Статус
ИЗ
    РегистрСведений.СтатусыЗаказов КАК СтатусыЗаказов
ГДЕ
    СтатусыЗаказов.Статус = &Статус

СГРУППИРОВАТЬ ПО
    СтатусыЗаказов.Заказ


Отчет выдает всё правильно. Как доиться, чтобы при двойном клике на количество выдавалась расшифровка по регистратору?
Просмотров: 32, последний комментарий от mut   
Выборка данных из справочника в ТЧ другого справочника [раздел Программирование в 1С Предприятие 8.3]
Автор Susik_haram — 24.04.19, 8:26 — 3 комментариев
Доброго дня. Есть справочник "Модули", в этом справочнике есть ТЧ "Детали", которая должна заполняться из справочника "Детали". На форумах есть информация о выборе данных из справочника в ТЧ документа, но в моем случае это не работает.
Просмотров: 38, последний комментарий от Vofka   
Сотрудник-совместитель для нескольких организаций [раздел Управление торговлей для Украины редакция 2 (Управление торговлей для России редакция 10)]
Автор vegas — 22.04.19, 14:59 — 2 комментариев
Доброе время суток!
Есть сотрудник который работает по совместительству в нескольких организациях, ни на одной из организаций он не работает на основном месте. Как правильно создать сотрудников в 1с?
Просмотров: 84, последний комментарий от vegas   
Табличная часть - Возможность установить только просмотр на всю таблицу и не возможность добавить к тому столбец исключения [раздел Программирование в 1С Предприятие 8.3]
Автор Gigi — 22.04.19, 11:04 — 5 комментариев
Всем привет!
Опять не хотел выходить на форум.
Короче... я вижу что с этой системой начинаешь решать одну ерунду ... потом видишь что слишком много времени уходит на ее решение и вопрос так и не решен.
И думаешь про себя ... делать больше нечего возиться со всем этим ... Поэтому в итоги просто вынужден бросить ... так как других дел валом.
Поэтому и тут вынужден опять выходить на форум и опять по поводу очередной ерунды.
Поэтому уважаемые не могли бы объяснить почему в системе 1С вот в таком стиле не получается?
ТекущийПользовательИмя=FxSub_Пользователи.ТекущийПользователь("Имя");
Если ТекущийПользовательИмя<>"Программер" Тогда
Элементы.["ТЧимя"].ТолькоПросмотр=Истина;
Элементы.ТЧимяФлажокДляПечати.ТолькоПросмотр=Ложь;
КонецЕсли;

Что нужно в итоги...
Что бы все колонки ТЧ были под "ТолькоЧтение", кроме одной из них.
Сделать это опционально не удобно ...
Ибо для этого нужно на каждый столбец вручную ставить: "ТолькоПросмотр". И все это ради одного несчастного столбца. А таких таблиц куча...
И представьте на каждую таблицу для каждого столбца нужно ставить "ТолькоПросмотр". А ведь уважающему себя программисту делать больше нечего кроме как заниматься этой х@й . Тем более, что для этого ведь куча других дел. Более важных.
Именно поэтому вынужден опять выходить на форум ..
Пожалуйста подскажите по быстрому ... как сделать эту ерунду. На которую не охота тратить время.
Что бы все колонки табличной части (НЕ ВАЖНО КАК ОНИ НАЗЫВАЮТСЯ) были под "ТолькоПросмотр", кроме одной колонки с именем на пример: "ФлажокДляПечати". И как сделать этой процедурно.
Я догадываюсь что для этого нужна процедура обхода всех элементов колонок ТЧ с нужным условием. Ибо система 1С ведь не умеет устанавливать параметр на все колонки , кроме указанного исключения.
И именно поэтому опять требует от программиста мудохаться с этой ерундой. И это наверно потому что сильно "блещет" гуманным отношением к не нему.
Ладно... опять извините ... просто опять делюсь приятными "ощущениями" от системы.
Короче ... кто ни будь не может скинуть код процедуры ... просто готовый код.
Сам шарил, но не нашел как можно обойти колонки табличной части... и не охота на это тратить время..
Так что нужен готовый код по быстрому.
Буду признателен!
Просмотров: 192, последний комментарий от Gigi   
Отбор Контрагента-как сделать [раздел Программирование в 1С Предприятие 8.3]
Автор fardo — 20.04.19, 18:58 — 1 комментариев
Привет всем
не могу сделать отбор контрагента
Этот код где надо изменить..или пожалуйста напишите код сюда в ответе



Процедура ПриОткрытии() 
    Если Открыта() Тогда
        //УстановитьСтандартныйИнтервалОтчета(ДатаНач,ДатаКон);
    КонецЕсли;
    ОбновитьПараметрыПериодаПоФорме(КомпоновщикНастроек,ЭтаФорма);    
КонецПроцедуры


Процедура ДействияФормыПечать(Кнопка)
    табдок = ЭлементыФормы.Результат;
    табдок.Записать(КаталогВременныхФайлов()+"\TABLE.xls",ТипФайлаТабличногоДокумента.XLS97);
    ЗапуститьПриложение(КаталогВременныхФайлов()+"\TABLE.xls");
КонецПроцедуры

Процедура ОбновитьПараметрыПериодаПоФорме(КомпоновщикНастроек, Форма) Экспорт
    
    ЗначениеПараметраНачалоПериода = КомпоновщикНастроек.Настройки.ПараметрыДанных.НайтиЗначениеПараметра(Новый ПараметрКомпоновкиДанных("ДатаНач"));
    ЗначениеПараметраКонецПериода = КомпоновщикНастроек.Настройки.ПараметрыДанных.НайтиЗначениеПараметра(Новый ПараметрКомпоновкиДанных("ДатаКон"));
    ЗначениеПараметраСЧ = КомпоновщикНастроек.Настройки.ПараметрыДанных.НайтиЗначениеПараметра(Новый ПараметрКомпоновкиДанных("СЧ"));
    
    Если ЗначениеПараметраНачалоПериода <> Неопределено Тогда
        ЗначениеПараметраНачалоПериода.Значение = Форма.ДатаНач;
        ЗначениеПараметраНачалоПериода.Использование = (Форма.ДатаНач <> '0001-01-01');
    КонецЕсли;
    
    Если ЗначениеПараметраКонецПериода <> Неопределено Тогда
        ЗначениеПараметраКонецПериода.Значение = ?(Форма.ДатаКон = '0001-01-01', Форма.ДатаКон, КонецДня(Форма.ДатаКон));
        ЗначениеПараметраКонецПериода.Использование = (Форма.ДатаКон <> '0001-01-01');
    КонецЕсли;
    Сч = Новый Массив;
    Сч.Добавить("004");
    Сч.Добавить("29.10");
    
    Если ЗначениеПараметраСЧ <> Неопределено Тогда
        ЗначениеПараметраСЧ.Значение = Сч;
        ЗначениеПараметраСЧ.Использование = Истина;
    КонецЕсли;
    
КонецПроцедуры

Процедура НастройкаПериодаНажатие(Элемент)
    Если НП.Редактировать() Тогда
        ДатаНач = НП.ПолучитьДатуНачала();
        ДатаКон = НП.ПолучитьДатуОкончания();
        ОбновитьПараметрыПериодаПоФорме(КомпоновщикНастроек,ЭтаФорма);
    КонецЕсли;
КонецПроцедуры

Процедура ПередОткрытием(Отказ, СтандартнаяОбработка)
    НП = Новый НастройкаПериода;
    НП.ВариантНастройки = ВариантНастройкиПериода.Период;
    НП.УстановитьПериод(НачалоДня(ДатаНач), ?(ДатаКон = '00010101', ДатаКон, КонецДня(ДатаКон)));
    ОбновитьПараметрыПериодаПоФорме(КомпоновщикНастроек,ЭтаФорма);
КонецПроцедуры

Процедура КонтрагентПриИзмении(Элемент)
ОбновитьПараметрыКонтрагента(КомпоновщикНастроек,ЭтаФорма);
КонецПроцедуры

Процедура ОбновитьПараметрыКонтрагента(КомпоновщикНастроек, Форма) Экспорт

ЗначениеКонтрагент = КомпоновщикНастроек.Настройки.ПараметрыДанных.НайтиЗначениеПараметра(Новый ПараметрКомпоновкиДанных("Контрагент"));
    
    Если ЗначениеКонтрагент <> Неопределено Тогда
        ЗначениеКонтрагент .Значение = Форма.Контрагент;
        ЗначениеКонтрагент .Использование = ЗначениеЗаполнено(Форма.Контрагент);
    КонецЕсли;
КонецПроцедуры
Просмотров: 69, последний комментарий от Vidocq05   
Чек-лист в 1с [раздел Программирование управляемых форм 1С 8.2]
Автор Constantus — 19.04.19, 8:40 — 1 комментариев
Приветствую, Форумчане!
1с8.3.6, самописная, БСП, УФ

Имеется задание сформировать чек-лист проверок, имеются куча вопросов, сгруппированных по смыслу.

Как оптимально создать такой чек-лист?

Создам справочник иерархический с этими вопросами.
Создам документ.

Как создать документ с табличной частью в виде дерева, где основными узлами будут папки иерархии (родители) этого справочника?
Просмотров: 91, последний комментарий от Petre   
Ошибка преобразования данных XDTO [раздел Программирование в 1С Предприятие 8.3]
Автор sanytch — 18.04.19, 16:15 — 4 комментариев
Доброго времени суток. Столкнулся с проблемой, которая пока-что за гранью моей области знаний, а именно XML.
История вкратце такова: Есть 3 информационных базы с идентичными конфигурациями (Бухгалтерия для Украины, редакция 2.0. (2.0.16.1)). на платформе 8.3.11.3034
В 2-х из них ведется учет по "Организации_1" и "Организации_2" соответственно, а в третьей по "Организации_3". В неё нужно выгружать данные из этих двух, но подменять "Организацию_1" и "Организацию_2" на "Организацию_3". Зачем - не спрашивайте, такова задумка начальства в сговоре с бухгалтерами и мне она не понятна, да и понимать не хочу.
Показалось что задача выполнима: нашел обычную внешнюю обработку обмена данными через XML и допилил её в разделе "Загрузка" проверкой получаемых данных:
    Пока Сериализатор.ВозможностьЧтенияXML(ЧтениеXML) Цикл
        
        Попытка
            
            ЗаписанноеЗначение = Сериализатор.ПрочитатьXML(ЧтениеXML);

            #Область Обработка_входящих_данных
            
            // Нашли Справочник Организации и поместим в него вместо прочитанной нашу организацию по умолчанию
            Если ТипЗнч(ЗаписанноеЗначение) = Тип("СправочникОбъект.Организации")  Тогда
                ЗаписанноеЗначение = Справочники.Организации.НайтиПоКоду("00-000001").ПолучитьОбъект();
            КонецЕсли;
            // Справочник ПодразделенияОрганизаций иерархически подчинен справочнику Организации, поэтому у него замещаем значение реквизита Владелец
            Если ТипЗнч(ЗаписанноеЗначение) = Тип("СправочникОбъект.ПодразделенияОрганизаций") Тогда
                ЗаписанноеЗначение.Владелец = Справочники.Организации.НайтиПоКоду("00-000001")
            КонецЕсли;
            // Если Объект имеет реквизит Организация то заменим этот реквизит на организацию по умолчанию    
            Если ЗаписанноеЗначение.Метаданные().Реквизиты.Найти("Организация") <> Неопределено Тогда
                ЗаписанноеЗначение.Организация = Справочники.Организации.НайтиПоКоду("00-000001")
            КонецЕсли;
            // У справочника Сотрудники принадлежность сотрудника к организации в реквизите ГоловнаяОрганизация
            Если ЗаписанноеЗначение.Метаданные().Реквизиты.Найти("ГоловнаяОрганизация") <> Неопределено Тогда
                ЗаписанноеЗначение.ГоловнаяОрганизация = Справочники.Организации.НайтиПоКоду("00-000001")
            КонецЕсли;
            ...

Топорно, но работало...
А теперь суть проблемы: Выгрузил данные с обоих баз. Затянул. Все нормально было. Но с недавних пор возникла ошибка при выгрузке одной из баз. Одна по прежнему без проблем выгружается и загружается, а одна выгружается но при загрузке выдает ошибку. Используется как для выгрузки, так и для загрузки одна и та же обработка. Из обоих баз выгружаются один и тот же перечень документов, конфигурации повторю идентичны... А ошибка такая

По кнопке "Подробнее" вот такой текст:

Цитата
{ВнешняяОбработка.ВыгрузкаЗагрузкаДанныхXML.МодульОбъекта(212)}: Ошибка при вызове метода контекста (ПрочитатьXML)
ЗаписанноеЗначение = Сериализатор.ПрочитатьXML(ЧтениеXML);
по причине:
Ошибка преобразования данных XDTO:
НачалоСвойства: {http://v8.1c.ru/8.1/data/enterprise/current-config}DocumentObject.ПоступлениеНаРасчетныйСчет Форма: Элемент Тип: {http://v8.1c.ru/8.1/data/enterprise/current-config}DocumentObject.ПоступлениеНаРасчетныйСчет
по причине:
Ошибка преобразования данных XDTO:
НачалоСвойства: РасшифровкаПлатежа Форма: Элемент Тип: {http://v8.1c.ru/8.1/data/enterprise/current-config}DocumentTabularSectionRow.ПоступлениеНаРасчетныйСчет.РасшифровкаПлатежа


Ругается только на документ "ПоступлениеНаРасчетныйСчет" и, насколько я понимаю на его ТабЧасть "РасшифровкаПлатежа". Нашел в обоих XML-файлах эту часть и сравнил чуть ли не по-символьно - никаких различий в структуре, в данных понятно, они разные, но ругается ведь на какую то ошибку при приобразовании... Подскажите в чем может быть причина?
Просмотров: 115, последний комментарий от sanytch   
Пучить полный адрес файла внешней обработки при ее открытии [раздел Программирование в 1С Предприятие 8.3]
Автор Gigi — 17.04.19, 11:03 — 9 комментариев
Всем привет!
&НаКлиенте
Процедура ПриОткрытии(Отказ)
ПолныйАдресФайла="???????";
Сообщить(ПолныйАдресФайла);
КонецПроцедуры

Шарил в поисковике ... потом надоело... и кроме того времени нет на это...
И если пойск занимает более 5-ти минут то лучше уже здесь... по способу решение задачи в фоновом режиме.... Не отвлекаясь от работы.
Так что, кто нибудь поможет сэкнмить время..
И скинуть готовый код....Вернее вписать строки в эту процедуру как это сделать.
Так что нужен только код по быстрому и безо всяких комментариев.
Буду признателен!
Просмотров: 297, последний комментарий от Gigi   
Работа с синонимом реквизита шапки документа [раздел Программирование в 1С Предприятие 7.7]
Автор leonid_gun — 17.04.19, 9:24 — 10 комментариев
Здравствуйте.
Есть необходимость получить синоним реквизита документа для его последующего отображения в заголовке окна редактирования значения этого реквизита

Процедура ВводПоля(РеквизитДокумента)   // РеквизитДокумента передается в процедуру
    Перем Инф;
    
    //Синоним = РеквизитДокумента.Синоним; // вот здесь не знаю как обратиться к нужному реквизиту, а точнее к его синониму
    
    Инф= РеквизитДокумента;
    Если ВвестиСтроку(Инф, "Введите значение " + Синоним, 999, 1,) = 1 Тогда
        РеквизитДокумента = Инф;
    Иначе
        Возврат;
    КонецЕсли;
КонецПроцедуры


Подскажите как правильно обращаться к Синониму или к Комментарий реквизита шапки, ведь для чего-то они присутствуют в базе. Пробовал через метаданные, но понял только как получить Синоним идентификатора документа, а мне нужен синоним реквизита шапки.
Просмотров: 209, последний комментарий от Batchir   
Аналитик-консультант 1с [раздел Офф-топик]
Автор Kateryna6789 — 16.04.19, 20:46 — 5 комментариев
Добрый день. Подскажите, пожайлуста, сколько получает аналитик-консультант 1с?
Просмотров: 148, последний комментарий от Kateryna6789   
Реализовать автоматическое выполнение задач для данного исполнителя [раздел Программирование в 1С Предприятие 8.3]
Автор Vladal — 16.04.19, 12:55 — 4 комментариев
Конфгурация на БСП 3.0.2, платформа 8.3.13.

Есть бизнес-процесс с "линейной" картой.



По "пожеланиям телезрителей" нужно автоматически закрывать задачу, если этот пользователь (адресат исполнения) в данном бизнес-процессе уже закрывал задачу положительно.
В моем случае "локальный директор", "финансовый" и "исполнительный" - одно и то же лицо и нужно упростить, автоматизировать закрытие последующих задач.

Что есть: при интерактивном закрытии задачи формируется следующая, в которую нужно зайти и нажать кнопку Согласовать, и так три раза (на карте три последние точки маршрута).
Что я дописал:

В отладчике я вижу, что точки бизнес-процесса продвигаются, задача меняется, выполняется, но в конце маршрута вываливается с ошибкой
Цитата
Операция не может быть выполнена из-за несоответствия версии или отсутствия записи базы данных (возможно, запись была изменена или удалена)!

Естественно, ссылка одна и та же, да и открыта интерактивно.

Делал это программно. Получил ссылку на текущую задачу, вызвал метод ВыполнитьЗадачу(), в отладчике прослеживаю все этапы и на последнем шаге получаю ошибку о невозможности закрыть задачу, так как она уже была выполнена.

Как это сделать правильно?

В обработчике точки маршрута ВыполнитьПриСозданииЗадач пишу свой код:
////////////////////////////////////////////////////////////////////////////////
// Обработчики событий элементов карты маршрута.

Процедура ВыполнитьПриСозданииЗадач(ТочкаМаршрутаБизнесПроцесса, ФормируемыеЗадачи, Отказ)
    
    НомерИтерации = НомерИтерации + 1;
    Записать();
    
    // Устанавливаем реквизиты адресации и доп. реквизиты для каждой задачи.
    Для каждого Задача Из ФормируемыеЗадачи Цикл
        
        Если ТочкаМаршрутаБизнесПроцесса.Имя = "СогласованиеФинансовыйКонтролер" Тогда
            Задача.РольИсполнителя = Справочники.РолиИсполнителей.ФинансовыйКонтролер;
...

        // Определить. был ли этот исполнитель в предыдущих точках маршрута
        Запрос = Новый Запрос;
        Запрос.Текст =
        "ВЫБРАТЬ РАЗРЕШЕННЫЕ
        |    ЗадачаИсполнителя.Ссылка КАК Ссылка,
        |    ЗадачаИсполнителя.БизнесПроцесс КАК БизнесПроцесс,
        |    ЗадачаИсполнителя.Выполнена КАК Выполнена,
        |    ЗадачаИсполнителя.ГруппаИсполнителейЗадач КАК ГруппаИсполнителейЗадач,
        
...

Запрос.УстановитьПараметр("ОсновнойОбъектАдресации", Задача.ОсновнойОбъектАдресации);
        
        Результат = Запрос.Выполнить();
        Если Не Результат.Пустой() Тогда
            Выборка = Результат.Выбрать();
            Выборка.Следующий();
            Задача.ГруппаИсполнителейЗадач = Выборка.ГруппаИсполнителейЗадач;
            Задача.Исполнитель = Выборка.Исполнитель;
            Задача.ДополнительныйОбъектАдресации = Выборка.ДополнительныйОбъектАдресации;
            
            //-- сделал и так, но все равно последняя задача рубится с ошибкой, что она выполнена и вся транзакция откатывается назад
            Если Не Задача.Выполнена Тогда
                Задача.ВыполнитьЗадачу();
            КонецЕсли;
            
            //-- вызывал и типовой модуль, но он тоже валится...
            //БизнесПроцессыИЗадачиВызовСервера.ВыполнитьЗадачу(Задача.Ссылка, Истина);
        КонецЕсли;
Просмотров: 161, последний комментарий от Vladal   
Индесация базы 1Сv8 под MS SQL - server 2014 [раздел Администрирование и настройка серверов баз данных]
Автор george_smith — 16.04.19, 11:13 — 4 комментариев
Здравствуйте!
Хочу увеличить производительность системы "Управление торговым предприятием для Украины", редакция 1.2. (1.2.48.1)
База 1Сv8.3 под MS SQL (mdf - файл весить около 15 gb., log урезанный до 1 gb.).
До перестройки индексов запрос sys.dm_db_index_physical_stats показал для многих объектов id avg_fragmentation_in_percent больше 30%.
После Rebuild Indexes ситуация не изменилась. Запрос sys.dm_db_index_physical_stats показал тоже самое.
Подскажите как победить высокий процент не фрагментированых индексов? Может через Reorganize Indexes? Чем эти два способа отличаются.


Просмотров: 164, последний комментарий от Vladal   
Находится ли конфигурация на поддержке? [раздел Программирование в 1С Предприятие 8.3]
Автор Inkognito — 16.04.19, 11:47 — 2 комментариев
Необходимо программно узнать, находится ли конфигурация на поддержке (или снята с поддержки, и можно вносить изменения?) - конфигурациия и платформа может быть самая разнообразная.
Использоваться планируется так: если заказчик/потенциальный заказчик хочет всяко-разного, но не может ответить на простые вопросы. Соберу всю нужную информацию программно.
//---------
Пробовал: СистемнаяИнформация(), Метаданные() - ничего похожего.

Наиболее лучше узнать "Правило поддержки" конфигурации. Но как это сделать программно? upset.gif
Картинка
Просмотров: 114, последний комментарий от Inkognito   
Стандартом присутствия продукции в торговых точках [раздел Программирование в 1С Предприятие 8.3]
Автор i369 — 16.04.19, 10:06 — 4 комментариев
Конфигурация нетиповая самописная. Платформа 8.3.12.1440
Добрый день.
Подскажите пожалуйста кто-нибудь сталкивался при анализе продаж со «Стандартом присутствия продукции в торговых точках» он же Минимальный обязательный ассортимент (Minimum Must List, MML)?
В зависимости от Категории торговой точки устанавливается минимальный набор Продукции, которая должна быть в торговых точках, устанавливается план в зависимости от КатегорииТТ и в отчете высчитывается Факт и %Выполнения Плана.
Может кто-то сталкивался или делал подобное?

Пример...

Просмотров: 106, последний комментарий от podcast   
Не закрывается 231 счет [раздел 1С Управление производственным предприятием 8]
Автор greatdndz — 16.04.19, 9:29 — 4 комментариев
Добрый день!

Конфигурация УПП 1.3.61, ведется РАУЗ. После расчета себестоимости не закрывается 231 счет по дебету по определенной номенклатурной группе. Подскажите пожалуйста какими отчетами либо другими способами найти ошибку?

Просмотров: 116, последний комментарий от Егор Динин   
Можно ли зайти в базу на сервере из другой конфигурации. [раздел Программирование в 1С Предприятие 8.3]
Автор Gigi — 14.04.19, 15:41 — 12 комментариев
Всем привет!
Гууу… даже в выходные дни вынужден работать… и даже в такое время нет покоя.. Это потому что охота отмучиться и забыть… И просто поскорее избавиться
Так вот, проблема такая. И попытаюсь коротко изложить. Если получиться ....что чаще не получается … согласен ))))) И если и на этот раз опять не получилось коротко то опять и тут БОЛЬШИЕ ИЗВИНЕНИЯ ЗА ТАКОЙ ОПЯТЬ ГИГАНТСКИЙ РАЗМЕР. Но это что бы удобнее было знать в деталях суть вопроса.
Представите, что есть две базы. Одна серверная … т.е. рабочая … а другая файловая на ПК.
Обе базы содержат одни и те же данные. Но при этом одна из них первая урезанная, а вторая полная.
Имею ввиду то, что конфигурация у серверной рабочей базы сильно урезана. Почти все возможности есть только по юр лицам. А во всем остальном это просто сухие данные справочников и документов без каких либо созданных форм, отчетов, очень удобных для загрузки данных и прочих целей обработок и т.д. Т.е. только сухие данные. Не отчетов не удобных для работы форм … ничего вообще. Короче в этом полная бездарщина. Хотя в том, как база в корне выстроена тут полная противоположность бездарщине. Потому что копия той же базы с теми же данными но уже в файловом варианте …загруженная уже из другой конфигурации … навороченной ….. с гибкими алгоритмами расчета, те же данные считает по нулям.
Но это фаилово-серверная ситуация. А вопрос в том, как я сам буду с этим работать с той рабочей базой, конфигурация которой урезана. Ибо работаю ведь не только программистом, но начальником технической статистики.
И тут вопрос решил следующим образом ...
Понаписал кучу строк кода для получения всех данных из базы серверной в базу файловую. И вопрос был решен. Т.е. в итоги я сам пользуюсь не рабочим вариантом базы правильно выстроенной, но очень не удобной и практически не возможной работать с ней, которая на сервере, а файловым, навороченным и удобным )) естественно ))
И как получать данные из урезанной базы на сервере в файловую с этим нормально. Файловая база с каждым месяцем пополняется новыми данными от рабочей серверной.
Но я просто хочу сделать еще удобнее.
А именно войти в базу, которая на сервере через другую конфигурацию. Т.е. не через ту с которой синтезируется база на сервере с урезанной конфигурацией, а войти через не урезанный и полный вариант конфигурации.
Вот как хотел.
И для этой цели я понасодавал кучу внешних обработок … т.е. множество фишек из полного варианта конфигурации сохранил виде внешних обработок. И открывал эти внешние обработки из тонкого клиента серверной базы. И они все абсолютно нормально работают и не где не ошибаются. Ибо ведь данные базы одни и те же. Но все дело в том, что этих разных внешних обработок стало куча. И открывать каждую отдельно для своей части работы стало очень не удобно. Поэтому нужно просто всю ту навороченную конфигурацию в целом создать как внешнюю обработку и зайти в базу на сервере через нее. И так что бы данные базы так же отобразить из другой конфигурации.
И не важно как зайти.. через файл/открыть обработку или иным способом.
Поэтому вопрос в том МОЖНО ЛИ ТАК СДЕЛАТЬ?
Только если опять и тут нельзя то не рубите сразу… ))))) …и не будьте жестоки )))
Потому, что буду сильно расстроен если так. )))))
И тогда напрасно столько в деталях описал… относительно того что нужно.
Тогда как может задуманное не реализуемо ибо такой возможности опять и тут просто нет.
И поэтому буду признателен …и это без иронии. Если кто подскажет варианты решения вопроса.
Просмотров: 344, последний комментарий от Gigi   
Связи Физ лиц с контрагентами [раздел 1С Управление производственным предприятием 8]
Автор jojojoba2 — 12.04.19, 15:01 — 2 комментариев
Добрый день!

Может кто нибудь знает какими справочниками,документами или вообще объектами , а также реквизитами связываются контрагенты и физ лица?
Просмотров: 155, последний комментарий от Vofka   
RSS Текстовая версия Сейчас: 24.04.19, 22:57
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!

Курсы валют: доллар США к гривне Курсы валют: евро к гривне Курсы валют: российский рубль к гривне