Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Неназначенных незавершенных заказов: 6
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Войти | Зарегистрироваться )


Свернуть

> Добро пожаловать на наш форум

Здравствуйте уважаемый посетитель. К сожалению вы не были распознаны форумом как зарегистрированный пользователь. Для полноценного использования возможностей нашего форума вам необходимо зарегистрироваться. Если вы уже зарегистрированы на форуме, то вам необходимо пройти авторизацию, используя Ваш логин и пароль.

Логин:   
Пароль:
 

Форум:

Новые темы (за 20 дней):

Последние сообщения:

Наши сервисы:

Дополнительно:

Новости для бухгалтера:

 
Панель навигации формы "Перейти": отразить регистр накопления [раздел Программирование в 1С Предприятие 8.3]
Автор Constantus — 24.06.19, 10:52 — 5 комментариев
Приветствую, Форумчане!
1с8.3.6, самопис, БСП, УФ

Имеется регистр накопления "ВзаиморасчетыПоЗаказам"

Как в форме "Заказы" в командном интерфейсе на панели навигации в "Перейти" отразить этот регистр накопления по конкретному заказу, из формы которого вызывается эта "Перейти"? Т.е. перейти и увидеть все движения по этому документу "Заказы"?
Просмотров: 84, последний комментарий от pablo   
Как в доп.расходы отнести комиссию за реализация товара [раздел Управление торговлей для Украины редакция 3 (Управление торговлей для России редакция 11)]
Автор igor-kopakov — 24.06.19, 9:51 — 0 комментариев
Добрый день!

Задача следующая:

Товары продаются через интернет-магазин посредник (маркетплейс), который от каждой продажи берёт с меня % от суммы продажи в зависимости к какой категории относится товар.

Подскажите, пожалуйста, как отнести на расходы эту комиссию?
Просмотров: 39, оставить комментарий   
Очистка не выбранных строк в таблице [раздел Программирование обычных форм 1С 8.2 и не интерфейсной логики]
Автор Lolita — 23.06.19, 8:24 — 1 комментариев
Добрый день!

Этот код написал:

Если НЕ ЗначениеЗаполнено(КатегорияПоложениеРаботника[0].ОД) Тогда
ТаблицаЗначений.Удалить(0);;
Отказ = Истина;
Если Отказ Тогда
Возврат;
КонецЕсли;
КонецЕсли;

Что здесь не так.

В этом коде хочу, если я выбрал строку (поставил флажок напротив строки). А которые не выбрал исчезали (или вся строка исчезала).

Просмотров: 64, последний комментарий от TrasserZero   
учебная версия [раздел Программирование в 1С Предприятие 8.3]
Автор alex040269 — 22.06.19, 11:50 — 1 комментариев
[необходимо зарегистрироваться для просмотра ссылки]

гле скачать учебную версию 8.3.12?

Спасибо!
Просмотров: 65, последний комментарий от TrasserZero   
Автоматическая очистка полей в таблице не выбранных позиций [раздел Программирование обычных форм 1С 8.2 и не интерфейсной логики]
Автор Lolita — 22.06.19, 10:50 — 1 комментариев
Немного по другому, это в одной таблице нужно.

Есть таблица с определенным количеством наименований (строк).
Как можно реализовать, если выбрать напротив определенные строки, а остальные строки которые не выбраны, исчезали строки.



Рисунок:
Просмотров: 75, последний комментарий от TrasserZero   
Подорожній лист вантажного автомобіля [раздел Прочее 1С 7.7]
Автор ben280365 — 22.06.19, 10:40 — 1 комментариев
Очень надо Подорожній лист вантажного автомобіля для 1с 7
Просмотров: 66, последний комментарий от mut   
Вывод данных в 2 таблицу, что выбрали в первой [раздел Программирование обычных форм 1С 8.2 и не интерфейсной логики]
Автор Lolita — 22.06.19, 8:42 — 2 комментариев
Добрый день!


Есть две таблицы: 1. В первой таблице выбираю некоторые поля, а в второй таблице выводятся те поля которые выбрал в первой таблице. Как можно это реализовать.


Рисунок пример:
Просмотров: 82, последний комментарий от takefive   
Сохранение в эксель по группировками [раздел Программирование обычных форм 1С 8.2 и не интерфейсной логики]
Автор most_fucking — 21.06.19, 11:47 — 4 комментариев
Добрый день, Коллеги!

Столкнулся с такой задачей: Есть обработка. которая собирает все данные по выполненным работам, потом записывает их в макет и сохраняет в эксель! Нужно сохранить все точно так же, но с группировками по всем полям (или хотя бы по первым 5). Подскажите как, буду благодарен за любую помощь! Читаю разные форумы, но толкового ничего не могу найти.
Просмотров: 113, последний комментарий от most_fucking   
Проверка на заполняемость поля ввода в табличной части [раздел Программирование обычных форм 1С 8.2 и не интерфейсной логики]
Автор Lolita — 21.06.19, 8:29 — 6 комментариев
Добрый день!



Проверка на заполняемость:
Использую этот код, но не проверяет почему то:


Если НЕ ЗначениеЗаполнено(КатегорияРеакцияРаботника) Тогда
Сообщить("Не заполнено категория Реакции Работника!");
Отказ = Истина;
Если Отказ Тогда
Возврат;
КонецЕсли;
КонецЕсли;
Просмотров: 98, последний комментарий от Lolita   
Формат() дробного числа [раздел Программирование в 1С Предприятие 8.3]
Автор Inkognito — 20.06.19, 9:09 — 2 комментариев
Бухгалетрия 2.0, управляемые формы.
Нужно получить точное представление числа после запятой. Использую код:
Формат(Переменная, "ЧДЦ=6; ЧРГ=; ЧРД=.")

Проблема: если число целое - все ОК, если дробное, оно так и остается с тем значением дроби, что и до использования функции Формат()
12 ---> 12.000000 //все ОК
292.80  --->  292.80 //тут проблема, нужно получить  292.800000
Просмотров: 77, последний комментарий от Inkognito   
Отправка СМС из очереди в РС: [раздел Программирование управляемых форм 1С 8.2]
Автор Constantus — 19.06.19, 18:21 — 1 комментариев
Приветствую, Форумчане!
1с8.3.6, самопис, БСП, УФ

Имеется регламентное задание, которе раз в сутки из регистра сведений отправляет адресатам СМС соощения:

Процедура ОтправитьСМССообщенияИзОчереди() Экспорт
    
    Запрос = Новый Запрос(
     "ВЫБРАТЬ
     |    СМСДляОтправления.Период КАК Период,
     |    СМСДляОтправления.Регистратор,
     |    СМСДляОтправления.Телефон,
     |    ВЫРАЗИТЬ(СМСДляОтправления.Сообщение КАК СТРОКА(500)) КАК Сообщение
     |ИЗ
     |    РегистрСведений.СМСДляОтправления КАК СМСДляОтправления
     |ГДЕ
     |    НЕ СМСДляОтправления.Телефон = """"
     |    И НЕ (ВЫРАЗИТЬ(СМСДляОтправления.Сообщение КАК СТРОКА(100))) = """"
     |    И НЕ СМСДляОтправления.Отправлено
     |
     |УПОРЯДОЧИТЬ ПО
     |    Период" );
    
    Выборка = Запрос.Выполнить().Выбрать();
    
    Пока Выборка.Следующий() Цикл
        
        //Владимир 2019_06_19
        НомераПолучателей = Новый Массив;
        НомераПолучателей.Добавить(Выборка.Телефон);
        
        ТекстСообщения = Выборка.Сообщение;
        
        // отправка
        РезультатОтправки = ОтправкаSMS.ОтправитьSMS(НомераПолучателей, ТекстСообщения);
    
        // проверка доставки для первого получателя
        Если РезультатОтправки.ОтправленныеСообщения.Количество() > 0 Тогда
            ИдентификаторСообщения = РезультатОтправки.ОтправленныеСообщения[0].ИдентификаторСообщения;
        КонецЕсли;
    
        // вывод идентификаторов отправленных SMS
        Для Каждого ОтправленноеСообщение Из РезультатОтправки.ОтправленныеСообщения Цикл
            КомментарийОтправки = СтроковыеФункцииКлиентСервер.ПодставитьПараметрыВСтроку(НСтр("ru = 'Номер: %1, ID: %2'"),
            ОтправленноеСообщение.НомерПолучателя, ОтправленноеСообщение.ИдентификаторСообщения);
            ЗаписьЖурналаРегистрации("ОповещениеОбОплатеКлиентов", УровеньЖурналаРегистрации.Информация,,, КомментарийОтправки);
        КонецЦикла;
        
        // вывод информации об ошибках в процессе отправки
        Если НЕ ПустаяСтрока(РезультатОтправки.ОписаниеОшибки) Тогда
            ЗаписьЖурналаРегистрации("ОповещениеОбОплатеКлиентов", УровеньЖурналаРегистрации.Ошибка,,, РезультатОтправки.ОписаниеОшибки);
            
        Иначе
            МенЗаписи = РегистрыСведений.СМСДляОтправления.СоздатьМенеджерЗаписи();
            ЗаполнитьЗначенияСвойств( МенЗаписи, Выборка );
            
            МенЗаписи.Отправлено = Истина;
            МенЗаписи.Записать( Истина );
            
        КонецЕсли;
        
    КонецЦикла;    
    
КонецПроцедуры


На:

            МенЗаписи = РегистрыСведений.СМСДляОтправления.СоздатьМенеджерЗаписи();
            ЗаполнитьЗначенияСвойств( МенЗаписи, Выборка );


Выходит сообщение об ошибке при запуске регламента:

"Менеджер записи не может быть использован для регистра с режимом записи "Подчинение регистратору""

Действительно, у данного РС есть 2-а документа по движению.

Почему возникает такая ошибка? И как ее победить?
Зачем вообще создается менеджер записи?

Подскажите куда пройти? Напарник считает, что ошибка кроется в документе, который сбрасывает данные по СМС в этот регистр, но причем здесь это, если сам Регистр сформирован правильно, со всеми полями и телефонами...
Просмотров: 96, последний комментарий от sava1   
1с 8 - как обнулить или отключить НУ ? [раздел 1С Управление Торговым Предприятием 8]
Автор buh-psf — 19.06.19, 14:09 — 2 комментариев
1С:Предприятие 8.3 (8.3.10.2561)
"Управление торговым предприятием для Украины", редакция 1.2. (1.2.48.1)


у меня в общей оборотно-сальдовой бьет красным ПО (НУ), во всех документах задваивается сумма
вроде говорят что оно не на что не влияет, НО , учитывая что я новый бух, на меня смотрят как на не компетентного

позвонили пред буху - она уже не помнит как она обнуляла НУ 19000000.gif

что говорила про : обработки- обновления и там что-то делать запускать, честно не сталкивалась с таким, на предыдущей работе как-то обновили 1с и все а тут не понятное
подскажите пожалуйста как сделать чтоб красным ПО не отображалось и чтоб сумма не задваивалась , должно идти только БУ - но фирма налогоплательщик на общей системе налогообложения +НДС

очень прошу откликнитесь кто знает такую фишку

buh-psf @ Сегодня, 14:01 * ,


вариант , при создании оборотно-сальдовой , не ставить галочку в клеточке НУ - не подходит , должен быть другой вариант
Просмотров: 125, последний комментарий от Gazulo   
Не коректно отображаеться печатная форма... [раздел 1С Бухгалтерия 7.7 для Украины]
Автор Zahar777 — 18.06.19, 14:46 — 3 комментариев
Здравствуйте, есть такая проблема, не корректно отображается печатная форма, везде... Если свернуть и развернуть программу, все нормально... Заранее благодарю за помощь...

Windows 10

Скрины прилагаю...

[необходимо зарегистрироваться для просмотра ссылки][необходимо зарегистрироваться для просмотра ссылки]


[необходимо зарегистрироваться для просмотра ссылки][необходимо зарегистрироваться для просмотра ссылки]
Просмотров: 186, последний комментарий от Zahar777   
как удалить все записи регистра [раздел Программирование в 1С Предприятие 8.3]
Автор lolmatrix — 18.06.19, 11:26 — 8 комментариев
Здравствуйте подскажите пожалуйста как удалить записи регистра все или по условию
Просмотров: 181, последний комментарий от most_fucking   
Управление торговым предприятием 8.3 для Украины [раздел Обучающее видео]
Автор zuzuzu557 — 18.06.19, 11:24 — 1 комментариев
Добрый день помогите найти в просторе инттернета безоплатный источник с видео-уроками по Управление торговым предприятием 8.3 для Украины. Благодарю
Просмотров: 88, последний комментарий от Vladal   
Программное Нажатие Кнопки [раздел Программирование в 1С Предприятие 8.3]
Автор ukr.ray — 17.06.19, 10:43 — 6 комментариев
Добрый день, мне поставили задачу сделать автоматическое закрытие смены. Розница 1.0.
В определено время запускается форма.[необходимо зарегистрироваться для просмотра ссылки]
Форме есть кнопка, как можно программно её нажать средствами 1с?

я пробовал такой вариант, присваивал кнопки "СочитаниеКлавишы" (Например кнопка F1)
Процедура ПриОткрытии()
Shell= Новый COMОбъект("Wscript.Shell");
Shell.SendKeys("{F1}");
КонецПроцедуры

Работает некорректно с 200 точек срабатывает примерно на 150.

У кого есть идеи как можно её нажать средствами 1с. ?

Объясняю почему надо именно нажать кнопку а не выполнить процедур которая прописана в кнопке.

Если просто запустить обработку закрытие смены (без физического нажатие кнопки), в момент закрытия смены, продавцы не читают что написано на экране и просто нажимают мышкой по открытой форме, появляется сообщение windows 1сv8 не отвечает Закрыть программу или Ожидание отклика от программы, ну конечно они нажимают Закрыть программу. и все смена не закрыта.

Просмотров: 202, последний комментарий от pablo   
Импорт-экспорт между двумя базами [раздел Программирование в 1С Предприятие 8.3]
Автор Gigi — 17.06.19, 10:38 — 5 комментариев
Всем привет!
Вообще сам вопрос темы в принципе решен ... и казалось бы результат устроил... все вроде бы нормально работает ...только один нюанс.
Слишком много кодовых строк получилось.
Очень длинная кодовая конструкция..... состоящая в основном из многочисленных функций и процедур подспорья. Да .. только ПОДСПОРЬЯ!!!!
В связи с чем опять понимается, сколько всего в этой супер продвинутой системе, нужно писать самому...
все писать ... без конца края .... и все это только что бы уже наконец подойти к долгожданному решению задачи. И всю эту кучу бедствия, впихнуть всего в ОДНУ КОДОВУЮ ЛИНИЮ. Для того, что бы наконец нажать на эту несчастную кнопку, под которой вписана та самая .. всего ОДНА ЛИНИЯ ))... До нажатия которой, после стольких бед, наверно уже нужно аж перекреститься smile.gifsmile.gif ))
Так что многое понимается после этого... В особенности когда ставишь точки над И... И оглянувшись видишь то количество строк кода, которое по вынужденному обстоятельству было написано до этого. Равно как и то, что если ограничивался бы только встроенными функциями системы, какое это было бы уже просто жалким зрелищем.
Вот что понимается после этого...
Но ладно ... это так ... опять делюсь "ощущениями"
А что касается вопроса темы, он в том, как оптимизировать и сократить код. И сделать его, скажем так, более удобоваримым.
Вот в чем вопрос.
И для того что бы получить рекомендации, для этого необходимо скинуть те самые мною же писанные не малые строки кода )), от которых у самого же голова идет кругом. )) Не говоря уже о тех людях которым он будет представлен.
Так что, до получения каких рекомендаций на этом сайте..., до этого ...к сожалению это необходимо.. Имею ввиду все наглядно представить.
А это если распечатать на бумаге А4, в шрифте на пример 12, займет целых две страницы ... если не больше.
А ведь участникам форума может будет не охота вникать во все это.
Именно поэтому воздерживаюсь скидывать код. И думаю так лучше пока данная тема не получит отклик. Поэтому решил только в таком случае скинуть сам код.
И если кто решит до рекомендаций, не полениться с ознакомлением с деталями вопроса то,
Буду признателен!
Вот собственно суть вопроса.
Просмотров: 222, последний комментарий от Gigi   
Ошибка открытия сохраненного чека ККМ [раздел Программирование в 1С Предприятие 8.3]
Автор ukr.ray — 15.06.19, 19:18 — 1 комментариев
Добрый день, Я только начинаю осваивать навыки программирование в 1с, столкнулся с такой проблемой, при частом выключение света на торговый точках происходит следующая ошибка
Ошибка раборки XML: -1 [1.1]
Фатальная ошибка:
Document is empty
Systemld: file://C:\Users\admin\AppData\Local\Temp\OrdrBack.xml
У меня конфигурация Розница для Украины 1.0.8.1
В инте вычитал что в новых редакциях это исправили (Розница 1.0.15 и выше и Аптеки для Украины Версия 1.0.18.1)
"Исправлены ошибки:"
11. Ошибка открытия сохраненного чека ККМ. При поврежденном файле автосохранения чека ККМ «OrdrBack.xml», не запускается рабочее место кассира.

Кто может поделится кодом что бы избежать эту ошибку.

Все что есть в моей рознице 1.0.8.1
// ПРОЦЕДУРЫ И ФУНКЦИИ АВТОСОХРАНЕНИЯ ЧЕКОВ ККМ
Процедура АвтосохранениеЧекаККМ
Процедура ВосстановитьЧекККМ(
Процедура ОчиститьАвтосохраненныеЧекиККМ
Функция ПолучитьАвтосохраненныйЧекККМ
Функция ПолучитьХМLПредставление(Объект)
///////////////////////////////////////////////////////////////////////////////

ПОМОГИТЕ КТО МОЖЕТ!
Просмотров: 97, последний комментарий от andr_andrey   
номенклатура при изменении [раздел Программирование в 1С Предприятие 8.3]
Автор bodka_ua — 15.06.19, 12:06 — 1 комментариев
Бухгалтерия для Украины, редакция 1.2. (1.2.48.1)
При отладке на табло цена просчитывается, а 1с зависает. Что не так?
Процедура ТоварыНоменклатураПриИзменении(Элемент)

    СтрокаТабличнойЧасти = ЭлементыФормы.Товары.ТекущиеДанные;
СтрокаТабличнойЧасти.Цена = СтрокаТабличнойЧасти.ЦенаЗПДВ - (СтрокаТабличнойЧасти.ЦенаЗПДВ /6);


    // Выполнить общие действия для всех документов при изменении номенклатуры.
    //ОбработкаТабличныхЧастей.ПриИзмененииНоменклатурыТабЧасти(СтрокаТабличнойЧасти, ЭтотОбъект);

    //ПриИзмененииНоменклатурыТоваров(СтрокаТабличнойЧасти);

    // Рассчитываем реквизиты табличной части.
    //ОбработкаТабличныхЧастей.РассчитатьСуммуТабЧасти(СтрокаТабличнойЧасти, ЭтотОбъект);
    //ОбработкаТабличныхЧастей.РассчитатьСуммуНДСТабЧасти(СтрокаТабличнойЧасти, ЭтотОбъект);
КонецПроцедуры
Просмотров: 98, последний комментарий от bodka_ua   
Как присвоить указанный уникальный идентификатор объекту? [раздел Программирование в 1С Предприятие 8.3]
Автор Gigi — 14.06.19, 17:15 — 1 комментариев
Всем привет!
Никто не подскажет как это сделать?
Дело в чем ...
Хотя ладно .... скину часть задачи
Вот эту часть

Функция Сериализация(СоединениеCOM,СериализуемыйОбъектИлиСсылка) Экспорт
//============================
    //Многие говорят "Попытка/Исключение " это "Манера плохого тона". Но при этом не понимают, что хороший тон еще нужно заслуживать.
    //А те которые на пример написали функцию:  "ТипЗнч(Значение)" другого тона точно не зауживают.
    //Поэтому вынужден был в таком тоне....  И хороший программист итак поймет почему решил только в таком тоне.
    Попытка знОбъектИлиСсылка=СериализуемыйОбъектИлиСсылка.ПолучитьОбъект(); Исключение знОбъектИлиСсылка=СериализуемыйОбъектИлиСсылка    КонецПопытки;
//============================
    Если СоединениеCOM=Неопределено Тогда
        Дерево=СериализаторXDTO.ЗаписатьXDTO(знОбъектИлиСсылка);
        ЗаписьXML=Новый ЗаписьXML;
        ЗаписьXML.УстановитьСтроку();
        ФабрикаXDTO.ЗаписатьXML(ЗаписьXML,Дерево);  //Сообщить(Ф.Параметры);
    Иначе
        Дерево=СоединениеCOM.СериализаторXDTO.ЗаписатьXDTO(знОбъектИлиСсылка);
        ЗаписьXML = СоединениеCOM.NewObject("ЗаписьXML");
        ЗаписьXML.УстановитьСтроку();
        СоединениеCOM.ФабрикаXDTO.ЗаписатьXML(ЗаписьXML,Дерево);
    КонецЕсли;
//============================
    Возврат ЗаписьXML.Закрыть();
КонецФункции

Функция Десериализация(СоединениеCOM,ТекстXML,ВозвратСсылкаОбъект) Экспорт
//============================    
Если СоединениеCOM=Неопределено Тогда
    ПарсерXML=Новый ЧтениеXML;
    ПарсерXML.УстановитьСтроку(ТекстXML); //Сообщить(ТекстXML+Символы.ПС+Строка(ПарсерXML)+" - "+ТипЗнч(ПарсерXML));
Иначе
    ПарсерXML = СоединениеCOM.NewObject("ЧтениеXML");
    ПарсерXML.УстановитьСтроку(ТекстXML); //Сообщить(ПарсерXML);    
КонецЕсли;
//============================
    Пока ПарсерXML.Прочитать() Цикл
    Если ПарсерXML.ТипУзла = ТипУзлаXML.НачалоЭлемента Тогда
    МетаОбъект=ПарсерXML.Имя;  //Сообщить(МетаОбъект);
    Прервать;
    КонецЕсли;
    КонецЦикла;
//============================
    Если СоединениеCOM=Неопределено Тогда
        Объект=СериализаторXDTO.ПрочитатьXML(ПарсерXML);
    Иначе
        Объект=СоединениеCOM.СериализаторXDTO.ПрочитатьXML(ПарсерXML);
    КонецЕсли;
//============================
ПарсерXML.Закрыть();
//============================
//Сообщить(МетаОбъект);
    Если Найти(МетаОбъект,"Catalog")>0 или Найти(МетаОбъект,"Document")>0 Тогда
        Если  ВозвратСсылкаОбъект="Ссылка" Тогда  Значение=Объект.Ссылка; Иначе Возврат Значение=Объект; КонецЕсли;
    Иначе
        Значение=Объект;
    КонецЕсли;
//============================
    //Сообщить(Строка(Значение)+" - "+ТипЗнч(Значение));
Возврат Значение;
КонецФункции


Дело в том, что при перезаписи имеющихся объектов в базе приема по данным объектов базы источника, нужна предварительная десериализация.
Которая осуществляется не по коду или номеру, а по уникальному идентификатору.
Поэтому если на пример у принятого из базы источника документа записанного в XML, на пример номер: "00000002". И если документ с таким же номером имеется в базе приема то команда:
Объект=СериализаторXDTO.ПрочитатьXML(ПарсерXML);

Не вернет его как Объект с номером "00000002". А вместо этого вернет пустое значение объекта.
Поэтому нужно как то при создании нового объекта принудительно записать тот идентификатор который указан в данных XML
Вот собственно и весть вопрос.
Короче ... КАК ОБЪЕКТУ ПРИСВОИТЬ УКАЗАННЫЙ ИДЕНТИФИКАТОР И ТАК ЕГО И ЗАПИСАТЬ.
Никто не подскажет как можно это сделать по быстрому.
Буду признателен!


Gigi @ Сегодня, 16:46 * ,
Молчание не всегда золото ... че нет отклика?


Gigi @ Сегодня, 17:10 * ,
Видимо уже не рабочее время...
Ладно... я тоже закруглюсь ...
Но буду признателен за отклик ..
Просмотров: 207, последний комментарий от Gigi   
RSS Текстовая версия Сейчас: 26.06.19, 4:27
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!

Курсы валют: доллар США к гривне Курсы валют: евро к гривне Курсы валют: российский рубль к гривне