Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Неназначенных незавершенных заказов: 3
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Войти | Зарегистрироваться )

История благодарностей участнику sava1 ::: Спасибо сказали: 471 раз
Дата поста: В теме: За сообщение: Спасибо сказали:
13.05.19, 14:44 Группировка разных документов с общим реквизитом по максимальной дате
типо так - вместо Контрагент-ДокументОснование
ВЫБРАТЬ
    РеализацияТоваровУслуг.Ссылка,
    РеализацияТоваровУслуг.Контрагент
ИЗ
    (ВЫБРАТЬ
        МАКСИМУМ(РеализацияТоваровУслуг.Дата) КАК Дата,
        РеализацияТоваровУслуг.Контрагент КАК Контрагент
    ИЗ
        Документ.РеализацияТоваровУслуг КАК РеализацияТоваровУслуг
    
    СГРУППИРОВАТЬ ПО
        РеализацияТоваровУслуг.Контрагент) КАК ВложенныйЗапрос
        ВНУТРЕННЕЕ СОЕДИНЕНИЕ Документ.РеализацияТоваровУслуг КАК РеализацияТоваровУслуг
        ПО ВложенныйЗапрос.Дата = РеализацияТоваровУслуг.Дата
            И ВложенныйЗапрос.Контрагент = РеализацияТоваровУслуг.Контрагент
Constantus,
22.04.19, 14:59 Табличная часть - Возможность установить только просмотр на всю таблицу и не возможность добавить к тому столбец исключения
обход на клиенте/сервере ?

пардон - вместо Колонки - ПодчиненныеЭлементы
Gigi,
22.04.19, 13:34 Табличная часть - Возможность установить только просмотр на всю таблицу и не возможность добавить к тому столбец исключения
типо так

Для каждого Колонка из Элементы.ТЧ.Колонки Цикл
       Если Колонка.Имя = "Флаг" тогда
                Колонка.ТолькоЧтение = 1;
       Иначе
                Колонка.ТолькоЧтение = ложь;
       КонецЕсли;
КонецЦикла
Gigi,
22.04.19, 13:27 При печати не вытягивает "Ответственного"
добавить для организации в ответственные лица человека с типом Руководитель
Vladal,
08.04.19, 13:50 Подпись на событие открытия указанной формы. Возможно ли это в системе 1С?
Если при открытии ПРЯМО указывать форму (типо ОткрытьФорму(".....Форма.Форма..")
Gigi,
08.04.19, 11:57 Подпись на событие открытия указанной формы. Возможно ли это в системе 1С?
подписка для менеджера
Gigi,
08.04.19, 9:07 Подпись на событие открытия указанной формы. Возможно ли это в системе 1С?
в подписках для УФ
Gigi,
20.03.19, 16:42 Фиксация столбцов слева
да
Constantus,
19.03.19, 10:16 Заборона запису документа в базі приймачі
Цитата(SaintDaemon @ 19.03.19, 9:55) *
ПослеЗагрузки написав

Если Не ОбъектНайден Тогда
Отказ = Истина;
КонецЕсли;


просто поставить птису - не создавать новый объект в приемнике....

Цитата(SaintDaemon @ 19.03.19, 9:55) *
Якщо цей новий склад обраний в якомусь документі то він записується, не зважаючи на мою умову.


чудес не бывает - где-то налажал.
SaintDaemon,
14.03.19, 11:33 Вставить ФИО сотрудника в макет, которого пользователь выберет сам в режиме предприятия
через параметры
coder,
05.03.19, 13:51 Документ "заявка на расходование средств" не проводиться
    Если РазмещениеЗаявки.Итог("СуммаПлатежа")>СуммаДокумента Тогда
        Сообщить(Заголовок+"
        |сумма размещения превышает сумму документа.");
        
        Отказ=Истина;
        
    КонецЕсли;


А больше ничого нет.
Sirius83,
11.02.19, 14:21 Запрос по потомкам
смотрите тыц
xtd,
22.01.19, 7:46 Отчет по движению товара Розница 2.х с Аналитикой операции
Использовать физическую таблицу, а не виртуальную.
Володька,
18.01.19, 14:03 Как в СКД вывести значения в колонки.
для группировок в строках убрать группировки, оставить одну по номенклатуре
bizisoft,
17.01.19, 12:56 Внешняя печатная форма
Цитата(1c_lam @ 17.01.19, 12:11) *
Мною реализовано изящно,


Мне бы кто так сказал ....
awp,
16.01.19, 18:29 Заполнение РегистраСведений из макета НачальноеЗаполнение
глобальный поиск - набиваем "2.0.14" - штудируем процедуры обновления - там есть заполнение регистров сведений
sanytch,
16.01.19, 16:41 Новая "заява-розрахунок" больничных для ФСС 2018
Есть выгрузка (с инфостарта). Вопросы в ЛС
DjRain,
26.12.18, 12:29 Разработка механизма гибкой настройки прав доступа
Если только по дням - то РЛС вооще не надо трогать.
Переделать чуть стандартный (добавить КоличествоДней).
РЛС - это доступ к объектам (например Склады - одному можно Склад1, второму Склад2, третьему Склад1 и Склад2)

Если очень хочется - смотрите в сторону БСП
Vidocq05,
07.12.18, 13:45 загрузка в 1 с бух 8.3 версия 1.2 доков в формате эксель
смотря на что: на зверей - в зоопарке, на порядок работы с обработкой - у автора.
TrasserZero,
21.11.18, 13:01 СКД: Левое соединение с условием
Цитата(andreykyiv@bigmir.net @ 21.11.18, 12:38) *
совсем непонятно что имеется в виду ((


Выборку получить простым запросом и уже готовый набор передать в СКД

А зачем в запросе Полное соединение по ценам и штрихкодам? Сервер имеете мощный? простаивает?
andreykyiv@bigmir.net,
19.11.18, 12:13 Перенос Регистра ШтрихКоды
КД
ПКО Номенклатура - Не создавать новые
Штрихкоды - перенестиПоПравилу(....)
alexandr_f,
25.10.18, 13:25 Сохранить табличный документ в формат JPG
вот - еще на 77 юзал
йоксель
Gigi,
16.10.18, 13:06 Заполнение из ТЧ справочника
1. Получаем ЭлементСправочникаЗатраты (неважно как - запрос, тз....) далее ЭСЗ
2. имеем ТЧ документа - далее ТЧД

3. чистим тчД

4. обходим в цикле ТЧ элемента справочника и переносим ее в документ.

Если ЭСЗ много - Обертываем этот кусок кода в цикл по КоллекцииЭлементовСправочника
Lexveritas,
15.10.18, 10:31 Заполнение из ТЧ справочника
где-то так

док.Тч.Очистить();
для каждого стр из спр.ТЧ цикл
    новСтр = док.тч.Добавить();
    заполнитьЗначенияСвойств(новСтр,стр);
Конеццикла;


соответственно на сервере
Lexveritas,
10.10.18, 9:49 Период отпусков в личной карточке
Там жестко прописано ПЕРВЫЕ 10.
Если что, надо править в конфигурации
Проц,

14 страниц V   1 2 3 > » 
RSS Текстовая версия Сейчас: 19.05.19, 11:24
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!

Курсы валют: доллар США к гривне Курсы валют: евро к гривне Курсы валют: российский рубль к гривне