Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Неназначенных незавершенных заказов: 7
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Войти | Зарегистрироваться )


Свернуть

> Добро пожаловать на наш форум

Здравствуйте уважаемый посетитель. К сожалению вы не были распознаны форумом как зарегистрированный пользователь. Для полноценного использования возможностей нашего форума вам необходимо зарегистрироваться. Если вы уже зарегистрированы на форуме, то вам необходимо пройти авторизацию, используя Ваш логин и пароль.

Логин:   
Пароль:
 

Форум:

Новые темы (за 20 дней):

Последние сообщения:

Наши сервисы:

Дополнительно:

Новости для бухгалтера:

 
Отбор по нескольким условиям [раздел Программирование в 1С Предприятие 8.3]
Автор Lexveritas — 18.12.17, 21:55 — 2 комментариев
1С 8.3.10 УПП. Обычное приложение.

Имею регистр и несколько справочников. НоменклатураСлужб, ХарактеристикиНоменклатурыСлужб, СтранаПроизводительНоменклатуры.

В регистр сведений должна заисаться цена. С записью проблем не возникло.

Есть документ, в котором по событию должно вставиться цене, но этого не происходит.
Перебрал все возможные варианты.

В общем модуле:
Функция ПолучитьЦеныНоменклатурыСлужб(АктуальнаяДата, Номенклатура, Характеристика, Страна) Экспорт
    Отбор = Новый Структура();
    Отбор.Вставить("НоменклатураСлужб", Номенклатура);
    Отбор.Вставить("ХарактеристикаНоменклатурыСлужб", Характеристика);
    Отбор.Вставить("СтранаПроизводстваНоменклатурыСлужб", Страна);
    ЗначенияРесурсов = РегистрыСведений.ЦеныНоменклатурыСлужб.ПолучитьПоследнее(АктуальнаяДата, Отбор);
    Возврат ЗначенияРесурсов.Цена;
КонецФункции


В документе:
Процедура ДетальНаименованиеПриИзменении(Элемент)
    АктуальнаяДата =  Дата;
    СтрокаДеталь = ЭлементыФормы.Деталь.ТекущиеДанные;
    СтрокаДеталь.ЦенаДействующая = РаботаСДокументами.ПолучитьЦеныНоменклатурыСлужб(АктуальнаяДата, СтрокаДеталь.Наименование, СтрокаДеталь.Характеристика, СтрокаДеталь.СтранаПроизводстваНоменклатурыСлужб);
КонецПроцедуры


Признак индексирования для номенклатуры, Характеристик и страны установлен, и снимался, и ведущим делался и опять снимался.
Результат одинаковый:
Ошибка при вызове контекста "получить последнее"
по причине:
не допустимое значение параметра параметр 2.

В одном из документов таким же образом получаем отбор по номенклатуре, характеристике, номеру заказа. работает. В жанном случае я просидел 4 часа и не добился НИЧЕГО!

Буду признателен за любую помощь!
Просмотров: 31, последний комментарий от Lexveritas   
Неправильно отредактировал форму [раздел Программирование обычных форм 1С 8.2 и не интерфейсной логики]
Автор СвутЪ — 18.12.17, 12:51 — 16 комментариев
1с 8.3.7.2008
Управление торговлей для Украины редакция 2.3

Добрый день! По неопытности неверно отредактировал форму печати "СчетНаОплатуПокупателю" просто взял и вырезал часть шапки формы, теперь при печати счета на оплату выдает ошибку - Ошибка при вызове метода контекста (ПолучитьОбласть)

Просмотров: 106, последний комментарий от Vofka   
Представление наименований [раздел Программирование в 1С Предприятие 8.3]
Автор rodrigezrobert — 18.12.17, 11:13 — 1 комментариев
Здравствуйте!
Есть справочник "Номенклатура" (иерархический с иерархией элементов и групп). Наименование групп в виде "Системные блоки", "Мониторы", то есть множественное число. Но для печатных форм
мне нужно использовать единственное число значений групп данного справочника ( Системный блок , Монитор) . Как правильно решить данную проблему? Может добавить дополнительный реквизит или расписать все в общем модуле? Ни один их вариантов придуманных мною вариантов меня не впечатляют. Спасибо.
Просмотров: 37, последний комментарий от logist   
Не выводится табличный документ на форме [раздел Программирование в 1С Предприятие 8.3]
Автор vet07 — 16.12.17, 13:42 — 9 комментариев
Платформа 8.3.10.25.61. Конфигурация самописная (на основе БСП). Управляемое приложение.
Задача: Необходимо загрузить данные из эксель и вывести их в табдок на форме.
Решение: файл из клиента через вр.хранилеще передается на сервер. Там обрабатывается и предаеться
на форму клиенту.
Вопрос: Не могу понять почему табдок не передается с сервера на клиента? На сервере он формируется.
    ДополнительныеПараметры = Новый Структура;
    ДополнительныеПараметры.Вставить("РасширениеФайла", РасширениеФайла);
    ДополнительныеПараметры.Вставить("ТабДок", Объект.ДанныеИзФайла);
    
    //Сохранение файла во временное хранилище.
    ОписаниеОповещения = Новый ОписаниеОповещения("ЗагрузитьФайлВХранилище", ЭтаФорма, ДополнительныеПараметры);    
    НачатьПомещениеФайла(ОписаниеОповещения, , ПолноеИмяФайла, Ложь, УникальныйИдентификатор);


Объект.ДанныеИзФайла - это реквизит обработки с типом табдок.
Далее на сервере обрабатывется и формируется табдок. Но через ДополнительныеПараметры.ТабДок не передаеться на клиента.

//Загрузить файл с временного хранилища.
    ФайлВременногоХранилища = ПолучитьИзВременногоХранилища(АдресВХранилище);    
    ИмяФайла = ПолучитьИмяВременногоФайла(ДополнительныеПараметры.РасширениеФайла);
    ФайлВременногоХранилища.Записать(ИмяФайла);
    УдалитьИзВременногоХранилища(АдресВХранилище);
    
    ТабДокДанные = Новый ТабличныйДокумент;
    Попытка
        ТабДокДанные.Прочитать(ИмяФайла, СпособЧтенияЗначенийТабличногоДокумента.Значение);
        УдалитьФайлы(ИмяФайла);
    Исключение
        УдалитьФайлы(ИмяФайла);
        Возврат;
    КонецПопытки;
    
    //Преобразование табличного документа в таблицу значений    
    ТабЗначДанные =  ПреобразоватьТабличныйДокументВТаблицуЗначений(ТабДокДанные);
    ПреобразоватьСтрокуВДату(ТабЗначДанные);
    
    ОпределитьКонечнуюДатуЗаявки(ТабЗначДанные);
        
    //Разделение колонки "Работник" на две: "ИФ_Анг" и "ИОФ_Рус".
    //Измененние колонки ИОФ_Рус на ФИО_Рус
    РазделитьФИОРусскийАнглийский(ТабЗначДанные);    
    
    ПроверитьЗагруженныеДанные(ТабЗначДанные);    
    
    УдалитьПустыеКолонки(ТабЗначДанные);
    
    ДополнительныеПараметры.ТабДок.Очистить();    
    ДополнительныеПараметры.ТабДок = ПреобразоватьТаблицуЗначенийВТабличныйДокумент(ТабЗначДанные);
Просмотров: 118, последний комментарий от vet07   
Обмен данными между базами без РИБ [раздел Программирование обычных форм 1С 8.2 и не интерфейсной логики]
Автор Constantus — 16.12.17, 7:47 — 1 комментариев
Приветствую, форумчане!
"Управление торговлей 10.3", (Моби-С 5.5). "ABBYY Ukraine", 2003-2014 (2.3.20.1)

В данный момент у меня настроен РИБ. Центральная база и 2-а подчиненных узла.
Естественно, что если я вношу изменения в конфигураторе, то мне приходится проводить операцию и по сохранению изменений в конфигурации и в подчиненных узлах.

Моему руководству "надоело" моё "нытьё", что каждый раз мне нужно проводить столь сложные махинации. Ну и мне надоело делать их хотелки и выслушивать мои претензии.

Тогда встал у меня вопрос: а можно сделать обмен между базами так, чтобы при изменении конфигурации, это изменение не требовало изменений конфигураций на подчиненных узлах? Т.е. в основном все "хотелки" затрагивают центральный офис и они не нужны на филиалах.

Возможно ли такое сделать без создания правил обмена?

И еще один вопрос: в планах обмена есть галочка "Распределенная информационная база". За что она отвечает и что будет, если ее отключить?
Просмотров: 77, последний комментарий от Moloko   
HTTPСоединение + SSL. Код состояния 500 [раздел Программирование в 1С Предприятие 8.3]
Автор Inkognito — 15.12.17, 12:57 — 3 комментариев
Необходимо настроить получение данных по защищенному соединению SSL.
Исходные данные: есть работающий ресурс (без SSL) и тестовый, на который планируется переход, который защищен SSL.

РесурсНаСервере = Строка("НекотораяСтрока");
РесурсБезSSL = "НекоторыйРесурс1"; //сейчас работаем с ним
РесурсСSSL = "НекоторыйРесурс2";  //тестовый, на который планируется переход
        
    //-------------------Без SSL
    Сообщить("-------ТЕСТ БЕЗ SSL-------");
    Соединение = Новый HTTPСоединение(НекоторыйРесурс1);
    Запрос = Новый HTTPЗапрос(РесурсНаСервере);
    HTTPОтвет = Соединение.Получить(Запрос);
    Если HTTPОтвет.КодСостояния=Число(200) Тогда
        Сообщить("ОК!");
    Иначе
        Сообщить("НЕ ОК!");
Сообщить("КодСостояния=" + HTTPОтвет.КодСостояния);
    КонецЕсли;

    //-------------------SSL
    Сообщить("-------ТЕСТ SSL-------");
    ssl = Новый ЗащищенноеСоединениеOpenSSL;
    Соединение = Новый HTTPСоединение(РесурсСSSL,,,,,,ssl);
    Запрос = Новый HTTPЗапрос(РесурсНаСервере);
    
    HTTPОтвет = Соединение.Получить(Запрос);
    Если HTTPОтвет.КодСостояния=Число(200) Тогда
        Сообщить("ОК!");
    Иначе
        Сообщить("НЕ ОК!");
        Сообщить("КодСостояния=" + HTTPОтвет.КодСостояния);
    КонецЕсли;


Результат
-------ТЕСТ БЕЗ SSL-------
ОК!
-------ТЕСТ SSL-------
НЕ ОК!
КодСостояния=500


Википедия гласит "500 Internal Server Error — любая внутренняя ошибка сервера, которая не входит в рамки остальных ошибок класса. Появился в HTTP/1.0."
Подскажите, куда копать?
Просмотров: 108, последний комментарий от Flexy   
Обмен УТП Розница2 [раздел Конфигурация "1С:Конвертация данных"]
Автор MoonArrow — 15.12.17, 10:21 — 1 комментариев
Доброе утро, не могу разобраться с обменом между розницей 2 (бсп) и УТП. В розницу добавил новый план обмена (создал план обмена, подписки на события и т.д) он работает, проверял создав копию базы, также поступил с утп обмен с аналогичной базой утп тоже работает. Обмен не работает, когда я пытаюсь выгрузить данные из утп в розницу, через V8Exchan82 обмен работает правила конвертации рабочие (всего один справочник).
Файлы выгрузки разные по формату с УТП выгружается с правилами обмена как с V8Exchan82, а с розницы (бсп) как с ВыгрузкаЗагрузкаДанныхXML82.
Просмотров: 94, последний комментарий от MoonArrow   
Не передает цены и остатки на сайт [раздел Управление торговлей для Украины редакция 3 (Управление торговлей для России редакция 11)]
Автор KriAn — 15.12.17, 1:07 — 2 комментариев
1С:Підприємство 8.3 (8.3.10.2699)

Управление торговлей для Украины, редакция 3.1
Разработка конфигурации: "ABBYY Ukraine", 2005-2016 (3.1.1.122) (http://v8.1c.ru/regional/RegionalSolutions_UA_UT.htm)
Copyright © ООО "1C", 2005-2016. Все права защищены
(http://www.1c.ru)

Добрый день! Пытаюсь настроить синхронизацию с интернет-магазином. Столкнулся с проблемой - формируется xml файл, но в нем нет информации о ценах и остатках....
Перечитал много инструкций, но результата нет - товар на сайте появляется без цены и без наличия....
Может кто знает где копать?
Просмотров: 87, последний комментарий от KriAn   
Изменение цены в табличной части документа [раздел Программирование обычных форм 1С 8.2 и не интерфейсной логики]
Автор Constantus — 14.12.17, 8:57 — 6 комментариев
Приветствую, форумчане!
"Управление торговлей 10.3", (Моби-С 5.5). "ABBYY Ukraine", 2003-2014 (2.3.20.1)

Функция ПоПоступлению()
    
        Отбор = Новый Структура;
        Отбор.Вставить("Объект", ДокументОбъект.Ссылка);
        Отбор.Вставить("Свойство", ПланыВидовХарактеристик.СвойстваОбъектов.НайтиПоНаименованию("По поступлению"));
        
        Если РегистрыСведений.ЗначенияСвойствОбъектов.Получить(Отбор).Значение Тогда
            Сообщить("Хорошо");
            Возврат 1;
        Иначе
            Сообщить("Плохо");
            Возврат 0;
        КонецЕсли;    
    
КонецФункции


Свойство документа Оприходования "По поступлению" тип булево.
При срабатывании этой функции получения значения этого свойства, если ранее это свойство вообще не было заполнено, то выдает ошибку:

{Документ.ОприходованиеТоваров.Форма.ФормаДокумента.Форма(1386)}: Преобразование значения к типу Булево не может быть выполнено
Если РегистрыСведений.ЗначенияСвойствОбъектов.Получить(Отбор).Значение Тогда


Нужно сначала вызвать свойство объекта, потом выбрать это свойство и присвоить ему хоть какое либо значение. Я так понимаю изначально это свойство НУЛЛ.

Как правильно написать код проверки значения, чтобы не выдавало подобной ошибки?
Просмотров: 140, последний комментарий от logist   
Сортировка по доп. колонке на форме списка документов [раздел Программирование обычных форм 1С 8.2 и не интерфейсной логики]
Автор Bernet — 13.12.17, 17:55 — 2 комментариев
Всем привет.
Платформа 8.3.10

Вопрос: Есть форма списка документов, форма обычная (не управляемая), например с заказами. В форму списка выводим колонки с картинками, которые сигнализируют о статусе оплаты / отгрузки заказа, реквизиты которые об этом информируют не являются реквизитами данного объекта (документа). Устанавливаю эти картинки в событии "ПриПолученииДанных" табличного поля. Теперь задача - необходимо отсортировать список с документами по статусу оплаты / отгрузки, чтобы оплаченные, например, поднялись вверх по списку. Можно ли сделать такое на обычных формах? Не хочется всю обработку ради одной закладки со списком документов переделывать на упр форму...

Пробовал через Порядок, НастройкаПорядка не проходит, т.к. мои колонки это не реквизиты документа.

Опять же не хочется делать какие-то таб части и прописывать все стандартные кнопки командной панели руцями. Есть ли какие-то варианты этого избежать?

Спасибо
Просмотров: 115, последний комментарий от sava1   
Как программно переоткрыть форму владельца [раздел Программирование в 1С Предприятие 8.3]
Автор martynovalena — 13.12.17, 11:41 — 0 комментариев
Внешняя обработка прикрепрелена к документу и вызывается по кнопке "Заполнить" .Заполняет реквизиты и при обновлении формы не проставляется один реквизит .Он заполняется , но на форме не выходить (даже после прочтения ее по-новому).А если форму переоткрыть он встает на свое место.Мне же нужно чтобы после того как заполнились реквизиты.Перед клиентом была форма уже сразу со всеми реквизитами , чтобы ему ее не нужно было переоткрывать
&НаСервере 
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
    
    НайденноеЗначение = "";
    ЭтаФорма.Параметры.Свойство("ОбъектыНазначения", НайденноеЗначение);
    
    Объект.ТекущДопСогл = НайденноеЗначение[0];
    
    //заполнить ОсновнойДоговор по ДопСоглаш
    Запрос=Новый Запрос;
    Запрос.Текст=
    "ВЫБРАТЬ
        |    бит_уп_Задача.БизнесПроцесс
        |ПОМЕСТИТЬ Процесс
        |ИЗ
        |    Задача.бит_уп_Задача КАК бит_уп_Задача
        |        ЛЕВОЕ СОЕДИНЕНИЕ Документ.бит_ПроектДоговора КАК бит_ПроектДоговора
        |        ПО (бит_ПроектДоговора.Ссылка = бит_уп_Задача.Предмет)
        |ГДЕ
        |    бит_ПроектДоговора.Ссылка = &Ссылка
        |
        |СГРУППИРОВАТЬ ПО
        |    бит_уп_Задача.БизнесПроцесс
        |;
        |
        |////////////////////////////////////////////////////////////////////////////////
        |ВЫБРАТЬ
        |    бит_уп_ПроцессПараметрыПроцесса.Значение КАК Значение
        |ИЗ
        |    Процесс КАК Процесс
        |        ЛЕВОЕ СОЕДИНЕНИЕ БизнесПроцесс.бит_уп_Процесс.ПараметрыПроцесса КАК бит_уп_ПроцессПараметрыПроцесса
        |        ПО Процесс.БизнесПроцесс = бит_уп_ПроцессПараметрыПроцесса.Ссылка
        |ГДЕ
        |    ТИПЗНАЧЕНИЯ(бит_уп_ПроцессПараметрыПроцесса.Значение) = ТИП(Документ.бит_ПроектДоговора)";
        
        
        Запрос.УстановитьПараметр("Ссылка", Объект.ТекущДопСогл);
        
        РезультатЗапроса = Запрос.Выполнить();
        
        ВыборкаДетальныеЗаписи = РезультатЗапроса.Выбрать();
        
        Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
            // Вставить обработку выборки ВыборкаДетальныеЗаписи
            Если  ТипЗнч(ВыборкаДетальныеЗаписи.Значение)= Тип("ДокументСсылка.бит_ПроектДоговора") тогда
                Объект.ПроектДоговора=ВыборкаДетальныеЗаписи.Значение;
            КонецЕсли;
        КонецЦикла;
        


КонецПроцедуры



&НаСервере
Процедура ЗаполнитьНаСервере()
    Об = Объект.ТекущДопСогл.ПолучитьОбъект();
    ОсновнДоговор=Объект.ПроектДоговора.ПолучитьОбъект();
    //Сообщить("Основной договор тек ДопСог"+Об.ОсновнойДоговор);
    ЕстьИзменения = Ложь;
    Если Об.ОсновнойДоговор=Документы.бит_ПроектДоговора.ПустаяСсылка() или Об.ОсновнойДоговор=неопределено тогда
        Об.ОсновнойДоговор=ОсновнДоговор.Ссылка;
        Сообщить("Основной Договор ДопСоглашения"+ОсновнДоговор.Ссылка);
        ЕстьИзменения=истина;
    КонецЕсли;
        
    
    Если Об.ДатаДоговора=Дата('00010101')  тогда
        Об.ДатаДоговора= ОсновнДоговор.ДатаДоговора;
        Сообщить("Дата ДопСоглашения"+ОсновнДоговор.ДатаДоговора);
        ЕстьИзменения = Истина;
    КонецЕсли;
    
    Если  Об.бит_П_МенеджерПоЗакупкам= справочники.ФизическиеЛица.ПустаяСсылка() тогда
        Об.бит_П_МенеджерПоЗакупкам= ОсновнДоговор.бит_П_МенеджерПоЗакупкам;
        Сообщить("МенеджерПоЗакупкам ДопСоглашения"+ОсновнДоговор.бит_П_МенеджерПоЗакупкам);
        ЕстьИзменения = Истина;
    КонецЕсли;
    
    Если Об.Контрагент = Справочники.Контрагенты.ПустаяСсылка()   Тогда
        //и ОсновнДоговор <> Документы.бит_ПроектДоговора.ПустаяСсылка()    Тогда
        Об.Контрагент = ОсновнДоговор.Контрагент;
        Сообщить("Контрагент ДопСоглашения"+ОсновнДоговор.Контрагент);
        ЕстьИзменения = Истина;
    КонецЕсли;
    
    Если Об.бит_П_Аналитика_1 = Справочники.бит_П_СтатьиРасходов.ПустаяСсылка() Тогда
        Об.бит_П_Аналитика_1 = ОсновнДоговор.бит_П_Аналитика_1;
        Сообщить("Статьи расходов ДопСоглашения"+ОсновнДоговор.бит_П_Аналитика_1);
        ЕстьИзменения = Истина;
    КонецЕсли;
    
    Если Об.бит_П_Аналитика_2 = Справочники.бит_П_ИсточникиФинансирования.ПустаяСсылка() Тогда
        Об.бит_П_Аналитика_2 = ОсновнДоговор.бит_П_Аналитика_2;
        Сообщить("Источники фоинансирования ДопСоглашения"+ОсновнДоговор.бит_П_Аналитика_2);
        ЕстьИзменения = Истина;
    КонецЕсли;                                                      
    
    Если Об.бит_П_Аналитика_6 = Справочники.Подразделения.ПустаяСсылка() или Об.бит_П_Аналитика_6 = Неопределено Тогда
        Об.бит_П_Аналитика_6 = ОсновнДоговор.бит_П_Аналитика_6;
        Сообщить("Инициатор расходов ДопСоглашения"+ОсновнДоговор.бит_П_Аналитика_6);
        ЕстьИзменения = Истина;
    КонецЕсли;                                    
    
    Если Об.ЦФО = Справочники.Подразделения.ПустаяСсылка() Тогда
        Об.ЦФО = ОсновнДоговор.ЦФО;
        Сообщить("ЦФО ДопСоглашения"+ОсновнДоговор.ЦФО);
        ЕстьИзменения = Истина;
    КонецЕсли;
    
    Если ЕстьИзменения Тогда
        Об.Записать(?(Об.Проведен, РежимЗаписиДокумента.Проведение, РежимЗаписиДокумента.Запись));
    КонецЕсли;
    
КонецПроцедуры

&НаКлиенте
Процедура Заполнить(Команда)
    ЗаполнитьНаСервере();
    ОповеститьОбИзменении(Объект.ТекущДопСогл);
    ВладелецФормы.Прочитать();
    ЭтаФорма.Закрыть();
КонецПроцедуры
Просмотров: 78, оставить комментарий   
Фильтрация товаров при вводе по строке. [раздел Программирование в 1С Предприятие 8.3]
Автор Alex78 — 13.12.17, 10:55 — 4 комментариев
Доброго времени суток.
Есть документ с табличной частью. В табличной части есть 2 реквизита с типом значения "СправочникСсылка.Номенклатура". Нужно, чтобы для этих двух реквизитов при вводе по строке показывались не все товары, а только товары из определенных групп (для 1го и 2го реквизита группы разные).
Платформа - 8.3.10.2252. Конфигурация - "Управление торговлей для Украины 3.1.5.1" (на УФ).
Подскажите, пожалуйста, каким образом это можно реализовать?
Просмотров: 111, последний комментарий от Alex78   
Мария 301 мтм [раздел Работа с торговым оборудованием]
Автор insomniac — 12.12.17, 13:28 — 1 комментариев
Всем доброго времени суток.
Я не специалист и даже не системный администратор но по месту моей работы у коллег возникла такая ситуация, на которую штатный сис.админ забил болт)
Решил разобраться сам для себя и возможно помочь коллегам.
Суть вкратце: есть компьютер к которому подключена мария 301 мтм и модем Мария мтм 01.
Все вроде бы как работает но по непонятным причинам иногда не хочет самостоятельно отправляться отчет в налоговую и без помощи консоли администратора и принудительной отправки обойтись не выходит.
Но главный вопрос это - Иногда после выполнения отчета или печати какого либо чека вылазит еще один с текстом "ПОВІДОМЛЕННЯ запис даних, код:#00020000"
Возможно кто-то уже сталкивался с такой ситуацией?
Спасибо всем за внимание и помощь
Просмотров: 109, последний комментарий от logist   
Как подключить внешнюю обработку к документу [раздел Программирование в 1С Предприятие 8.3]
Автор martynovalena — 12.12.17, 13:22 — 3 комментариев
Всем ,здравствуйте. 1С:Предприятие 8.3 (8.3.10.2299) Бухгалтерия предприятия, редакция 3.0 БИТ.ФИНАНС 3.1
У меня задача, нужно чтобы из документа (Допсоглашение) можно было вызвать внеш обработку ,на форме которой ,выбрать договор и заполнить по нему данные доп соглашения.
Внешняя обработка есть , а вот при подключении нет возможности выбрать документ из которого мне нужно. чтобы она вызывалась, только Разделы.
Что делаю не так? или вообще так нельзя сделать при подключении внешней обработки? только прописывать в конфигурации.
Функция СведенияОВнешнейОбработке() Экспорт
    ПараметрыРегистрации = Новый Структура;
    МассивНазначений = Новый Массив;
    МассивНазначений.Добавить("Документ.бит_ПроектДоговора"); //Указываем документ к которому делаем внешнюю печ. форму
    ПараметрыРегистрации.Вставить("Вид", "ДополнительнаяОбработка"); //может быть - ПечатнаяФорма, ЗаполнениеОбъекта, ДополнительныйОтчет, СозданиеСвязанныхОбъектов...
    ПараметрыРегистрации.Вставить("Назначение", МассивНазначений);
    ПараметрыРегистрации.Вставить("Наименование", "ЗаполнениеДоговора"); //имя под которым обработка будет зарегестрирована в справочнике внешних обработок
    ПараметрыРегистрации.Вставить("БезопасныйРежим", ложь);
    ПараметрыРегистрации.Вставить("Версия", "1.0");
    ПараметрыРегистрации.Вставить("Информация", "Заполнение реквизитов допсоглашения из основного договора процесса");
    ТаблицаКоманд = ПолучитьТаблицуКоманд();
    ДобавитьКоманду(ТаблицаКоманд, "ЗаполнениеДоговора", "Заполнение Договора", "ОткрытиеФормы", Истина, "");
    //ДобавитьКоманду(ТаблицаКоманд, "ЗаполнениеРеквизитовДоговора", "ЗаполнениеРеквизитовДоговора", "ВызовСерверногоМетода", Истина, "");
    ПараметрыРегистрации.Вставить("Команды", ТаблицаКоманд);
    
    Возврат ПараметрыРегистрации;
КонецФункции




Функция ПолучитьТаблицуКоманд()
    Команды = Новый ТаблицаЗначений;
    Команды.Колонки.Добавить("Представление", Новый ОписаниеТипов("Строка"));//как будет выглядеть описание печ.формы для пользователя
    Команды.Колонки.Добавить("Идентификатор", Новый ОписаниеТипов("Строка")); //имя макета печ.формы
    Команды.Колонки.Добавить("Использование", Новый ОписаниеТипов("Строка")); //ВызовСерверногоМетода
    Команды.Колонки.Добавить("ПоказыватьОповещение", Новый ОписаниеТипов("Булево"));
    Команды.Колонки.Добавить("Модификатор", Новый ОписаниеТипов("Строка"));
    Возврат Команды;
КонецФункции

Процедура ДобавитьКоманду(ТаблицаКоманд, Представление, Идентификатор, Использование, ПоказыватьОповещение = Ложь, Модификатор = "")
    
    НоваяКоманда = ТаблицаКоманд.Добавить();
    НоваяКоманда.Представление = Представление;
    НоваяКоманда.Идентификатор = Идентификатор;
    НоваяКоманда.Использование = Использование;
    НоваяКоманда.ПоказыватьОповещение = ПоказыватьОповещение;
    НоваяКоманда.Модификатор = Модификатор;
    
КонецПроцедуры



 ! 

Правила: 4,5
 
Просмотров: 149, последний комментарий от Petre   
Доступ к варианту отчета [раздел Управление торговлей для Украины редакция 3 (Управление торговлей для России редакция 11)]
Автор Zene4ka — 12.12.17, 11:59 — 1 комментариев
1С:Предприятие 8.3 (8.3.9.1818)
Управление торговлей для Украины, редакция 3.1
Делаю вариацию отчета Валовая прибыль (нужен разрез склад/Контрагент/реализация/номенклатура только в количестве).
Все получается. Но у пользователя , которому этот отчет нужен , нет доступа к отчетам по Валовой прибыли.
Вопрос: Можно ли дать доступ именно к этому варианту отчета без возможности изменения варианта отчета?
Просмотров: 68, последний комментарий от logist   
Кадровое перемещение не проводится [раздел 1С Управление Торговым Предприятием 8]
Автор Ariesod — 12.12.17, 10:07 — 17 комментариев
Доброго времени суток.
Помогите разобраться, пожалуйста.

Конфигурация УТП, редакция 1.1, версия 8.2
Бухгалтерия желает провести документ кадровое перемещение в связи с изменением оклада, но при проведение выдает ошибку: Запись с такими ключевыми полями существует!: ПлановыеУдержаниеРаботниковОрганизаций 30.11.2017 23.59.59 ... (Регистр сведений: Плановые удержания работников организаций; Номер строки 4)

Иду в регистр сведений, да, там есть записи по сотруднику от 30.11.2017 23.59.59 но документ Кадровое перемещение хотят провести 01.12.2017. И, кстати, документ проводится 31.11.2017. Но бухгалтерии надо 01.12.2017
Знаю, что, вроде, изменение оклада можно отобразить документом Ввод сведений о плановых начислениях и удержаниях.
Помогите понять как правильно должна быть построена цепочка документов. Или на что нужно обратить внимание при проведении кадровых перемещений. Как этот документ нужно проводить той датой, которая нужна бухгалтерии. Заранее всем спасибо за советы и ответы.
Просмотров: 292, последний комментарий от Ariesod   
Не потягивается эмайл контрагента для отправки письма из счета. [раздел 1С Управление Торговым Предприятием 8]
Автор fria — 12.12.17, 1:05 — 3 комментариев
Доброй ночи знатоки, помогите решить проблему. Я обычный пользователь 1с. Настроил отправку документов по электронной почте. Но не потягивается емайл который я вношу в карточку контрагента. В чем может быть проблема? может где то в настройка галочку забыл, или это доработки и нужно искать человека и платить, тогда сколько за такую работу вообще могут брать?



 ! 

Правила: 3,4,5
 
Просмотров: 194, последний комментарий от Gazulo   
Нумерация документа с использованием префикса номера. [раздел Программирование в 1С Предприятие 8.3]
Автор Alex78 — 11.12.17, 16:35 — 2 комментариев
Доброго времени суток.
Есть документ, у него есть строковый реквизит "Тип".
Нужно, чтобы при изменении этого реквизита в форме документа номер документа изменялся на новый номер с соответствующим префиксом (префикс - значение реквизита "Тип").
Я реализую это следующим образом:

&НаКлиенте
Процедура ТипПриИзменении(Элемент)
    УстНовыйНомер();
КонецПроцедуры

&НаСервере
Процедура УстНовыйНомер()
    Префикс=Объект.Тип;
    Об=РеквизитФормыВЗначение("Объект");
    Об.УстановитьНовыйНомер(Префикс);
    ЗначениеВРеквизитФормы(Об,"Объект");
КонецПроцедуры


Проблема в следующем - если выбрать тип, к примеру, "а", номер = "а0001". Если потом выбрать другой тип, к примеру, "д", номер = "д0001". Если после этого снова выбрать "а", то номер уже "а0002", хотя должен быть "а0001" (в 7ке именно так). Более того, если закрыть документ, не сохраняя его, и создать новый, то при выборе "а" номер уже - "а003".

Платформа - 8.3.10.2252.
Конфигурация - "Управление торговлей для Украины 3.1.5.1" (на УФ).

Подскажите, пожалуйста, как можно решить эту проблему.
Спасибо.


Просмотров: 100, последний комментарий от Alex78   
Загрузка зарплаты из Excel [раздел Бухгалтерия 8, редакция 1 для Украины]
Автор Юля — 11.12.17, 11:46 — 8 комментариев
Привет, нужна ваша помощь, начисленную зарплату загружаем из Excel обработкой, в самой таблице есть столбцы: зарплата, премия , больничные..., строки КодПоДРФО по какому заполняются работники, проблема в том, что когда создаю строку с индексацией базовой месяц индексации берет из приема на работу, хотя было кадровое перемещения работников, строку добавляю просто:

СтрНачисления.ВидРасчета =  ПланыВидовРасчета.ОсновныеНачисленияОрганизаций.ИндексацияЗарплаты;
СтрНачисления.Авторасчет = Истина;


Когда документ создано, на закладке начисление просто нажимаю рассчитать и индексация рассчитываться, но с тем базовым месяцем.
Просмотров: 190, последний комментарий от Юля   
Изменение разрядности количества при выгрузке в типовой XML налоговых накладных [раздел Программирование в 1С Предприятие 8.3]
Автор kihor — 08.12.17, 19:15 — 7 комментариев
Коллеги,

Мы используем конфигурацию УТП (1.2.43.1). При выгрузке в типовой XML налоговой накладной и приложения 2, поле "количество" передается с 6 знаками после запятой. Хотелось бы увеличить эту разрядность. Насколько я понял, разрядность "зашита" где-то в XML схеме в 1С. Никто не пытался ее редактировать с указанной выше целью? Если пытались, то как это сделать? Заранее спасибо за ответ.
Просмотров: 174, последний комментарий от kihor   
RSS Текстовая версия Сейчас: 19.12.17, 0:28
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!

Курсы валют: доллар США к гривне Курсы валют: евро к гривне Курсы валют: российский рубль к гривне