Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Неназначенных незавершенных заказов: 9, свеженьких 2
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Войти | Зарегистрироваться )


Свернуть

> Добро пожаловать на наш форум

Здравствуйте уважаемый посетитель. К сожалению вы не были распознаны форумом как зарегистрированный пользователь. Для полноценного использования возможностей нашего форума вам необходимо зарегистрироваться. Если вы уже зарегистрированы на форуме, то вам необходимо пройти авторизацию, используя Ваш логин и пароль.

Логин:   
Пароль:
 

Форум:

Новые темы (за 20 дней):

Последние сообщения:

Наши сервисы:

Дополнительно:

Новости для бухгалтера:

 
Проводки услуг и приходных накладных [раздел 1С Торговля и Склад 7.7 для Украины]
Автор ЕленаMirko — 20.02.19, 10:18 — 0 комментариев
Добрый день. Подскажите пожалуйста как правильно в номенклатуре услуг и материалов в приходных накладных отображать счет учета, счет затрат и вид затрат. Есть импортный товар соответственно услуги брокеров,перевалка груза, хранение груза (как правильно эти услуги отобразить в 1С и надо ли их относить на увеличение себестоимости товара и если да, то как это сделать, есть свой транспорт - приходую запчасти, топливо, шины, аккумуляторы, масла, есть стройка и стройматериалы к ней
Просмотров: 8, оставить комментарий   
Работа и подключение Фискального Регистратора Datecs Exelio FPU-550es в 1с v.7 [раздел Работа с торговым оборудованием]
Автор Pepe — 19.02.19, 21:51 — 3 комментариев
Не хочется писать с "нуля", но стоит задача "подружить" сильно измененную конфигурацию Бухгалтерский учет для печати чеков на данном ФР.
Посему интересует информация, обработка обслуживания, примеры (код или процедура) использования данного фискального аппарата, подводные камни, глюки.
Просмотров: 54, последний комментарий от nik389   
Как в СКД вычесть итоги из разных наборов данных [раздел Система компоновки данных]
Автор annex — 18.02.19, 14:53 — 4 комментариев
Есть два набора данных.
Первый-Приход
--------------------
Товар кол Сумма
--------------------
Итого1

-----
Второй-Расход
---------------------
Товар кол Сумма
---------------------
Итого2

Ниже должно быть

Разница Итого1-Итого2
Просмотров: 88, последний комментарий от annex   
УПП форма печати УПП форма печати КомплектацияНоменклатуры с выодом суммы и итого [раздел Программирование в 1С Предприятие 8.3]
Автор jojojoba2 — 18.02.19, 12:48 — 0 комментариев
Здраствуйте!

Помогите новичку доделать форму печати документа 1С8.3 УПП Комплектация номенклатуры. Нужно чтобы выводилась сумма напротив товара и также выводилась общая сумма(Итого).
Прикол в том что сумма не отображается в самом документе. Ее,я так понимаю, нужно брать с проводок из РегистраБухгалтерии.Хозрасчетный. Я пытался запросом вывести эту сумму с регистра,но выводится все проводки и суммы каторые есть.
Посоветовали дописать условие ГДЕ Регистратор ССЫЛКА Документ.КомплектацияНоменклатуры ,но он берет инфу по всему документу.Как взять инфу по полю номер в этом документе? Оно Уникально для товара.

| Хозрасчетный.Сумма
|ИЗ
|    РегистрБухгалтерии.Хозрасчетный КАК Хозрасчетный
| ГДЕ Регистратор ССЫЛКА Документ.КомплектацияНоменклатуры";
Просмотров: 39, оставить комментарий   
Создать 2 вида входа на 1 компьютере [раздел Администрирование и настройка 1С]
Автор andreykyiv@bigmir.net — 18.02.19, 12:40 — 6 комментариев
Доброго дня всем. Не нахожу решения в сети, а нужно срочно сделать.
На одном рабочем компе есть два пользователя: Завсклада и кладовщик. Пользуются компом время от времени то тот, то другой.

Для кладовщика под тонкий клиент создано рабочее место на управляемых формах.
Чтоб были только опции сканирования и сверки с данными в документе.

У Завсклада полный интерфейс под толстым клиентом. Побольше функций.

Кладовщик под толстым клиентом также получает дополнительные избыточные возможности.
И научился при запуске 1с сам менять вариант клиента при запуске.
Как этому умнику обрезать возможности?

База УТП доработанная, клиент-серверный вариант, платформа 8.3.10

ДЯкую
Просмотров: 135, последний комментарий от andreykyiv@bigmir.net   
Внешние печатные формы: как добраться до кода обработки данных (запроса)? [раздел Программирование управляемых форм 1С 8.2]
Автор Constantus — 18.02.19, 12:28 — 2 комментариев
Приветствую, форумчане!

8.3.6, УФ, полностью самописная, досталась в наследство.

Имеется некий документ. На нем расположена группа кнопок с разными формами печати. Как выяснилось, для печати применяются внешние печатные формы, которые расположены в справочнике "Дополнительные отчеты и обработки" (Наверное механизм БСП)...

Сохранил одну из этих форм как внешний отчет (епф). Открыл его в конфигураторе и пытаюсь разобраться в коде.
Этот отчет формирует некий список из Реализаций и Заказов. Нужно отследить, почему отчет некорректно данные некоторые выводит.

Для этого пытаюсь разглядеть, где эти данные формируются, но вошел в тупик. На форме этого внешнего отчета есть короткий код.
Помогите понять, где всё это происходит, где формируется запрос для печати этого отчета? макеты также на этой внешнем отчете...

Код
&НаСервере
Процедура ПечатьНаСервере(Мастера = Ложь, Отверстия = Ложь)
    
    АдресРезультата = "";
    ОбработкаОбъект = РеквизитФормыВЗначение("Объект");
    
    Если Мастера Тогда
        ТабДокумент = ОбработкаОбъект.ПечатьМастеров(Ссылка, Неопределено);
    ИначеЕсли Отверстия Тогда    
        ТабДокумент = ОбработкаОбъект.ПечатьНестандартныхОтверстий(Ссылка, Неопределено);
    Иначе    
        ТабДокумент = ОбработкаОбъект.ПечатьДляКомплектовщиков(Ссылка, Неопределено);
    КонецЕсли;
    
    АдресРезультата = ПоместитьВоВременноеХранилище(ТабДокумент);
    
КонецПроцедуры

&НаКлиенте
Процедура Печать(Команда)
    
    ПечатьНаСервере();
    
    Если ЭтоАдресВременногоХранилища(АдресРезультата) Тогда
        ТабДок = ПолучитьИзВременногоХранилища(АдресРезультата);
        ТабДок.Показать();
    КонецЕсли;
    
КонецПроцедуры

&НаКлиенте
Процедура Печать_Отверстия(Команда)
    ПечатьНаСервере(,Истина);
    Если ЭтоАдресВременногоХранилища(АдресРезультата) Тогда
        ТабДок = ПолучитьИзВременногоХранилища(АдресРезультата);
        ТабДок.Показать();
    КонецЕсли;
КонецПроцедуры

&НаКлиенте
Процедура Печать_Мастера(Команда)
    ПечатьНаСервере(Истина);
    Если ЭтоАдресВременногоХранилища(АдресРезультата) Тогда
        ТабДок = ПолучитьИзВременногоХранилища(АдресРезультата);
        ТабДок.Показать();
    КонецЕсли;
КонецПроцедуры


Имеются также дополнительные реквизиты:
АдресРезультата (строка)
Ссылка - ссылка на исходный документ, из которого производится печать отчета



ТабДокумент = ОбработкаОбъект.ПечатьНестандартныхОтверстий(Ссылка, Неопределено);

Судя по всему здесь получают данные. Но где этот "ПечатьНестандартныхОтверстий" и где идет обработка макета печатной формы - вот загадка природы...
Просмотров: 60, последний комментарий от Constantus   
Как в себестоимость выпуска продукции включить затраты на електроенергию [раздел 1С Управление Торговым Предприятием 8]
Автор Kostya_77 — 15.02.19, 14:38 — 9 комментариев
Как в себестоимость выпуска продукции включить затраты на електроенергию, зарплату персонала и тд.


 ! 

Правила: 5
 
Просмотров: 159, последний комментарий от Bernet   
Работа с Деревом в обработке: группирует данные, а не нужно [раздел Программирование в 1С Предприятие 8.3]
Автор Constantus — 15.02.19, 13:11 — 2 комментариев
Приветствую, форумчане!

1с 8.3, полностью самописная, уф.

Досталось в наследство: имеется обработка, в ней дерево. Одним из реквизитов является булево, если он отмечен, то обработка обходит всё дерево, далее отмеченные строки формирует нечто и создает документ с этими данными.

Всё работает, но, если в дереве имеются отмеченные строки с абсолютно одинаковыми реквизитами, то код типа их группирует и в создаваемый документ шлет одну строку.
Например:

1. Что-то 23/4 "дада" 5 шт
2. Что-то 23/4 "дада" 5 шт

В документ кидает "Что-то 23/4 "дада" 5 шт", а нужно все 2-е штуки позиций.

Никак не могу разобраться в коде, где этот код группирует одинаковые по реквизитам данные...

Код
    массНоменклатур = Новый Массив;
    ссылкаПрЗадание = Неопределено;
    ПрЗадание = Неопределено;
    
    Для шаг = 0 по 1 Цикл
        Для каждого тСтрокаЗаказа из ДеревоПроизводственныхЛистов.ПолучитьЭлементы() Цикл
            Если НЕ ЗначениеЗаполнено( тСтрокаЗаказа.ЗаказНоменклатура ) Тогда
                Продолжить;
                
            КонецЕсли;    
            
            массНоменклатур.Очистить();
            
            Для каждого тСтрокаНоменклатуры из тСтрокаЗаказа.ПолучитьЭлементы() Цикл
                Если тСтрокаНоменклатуры.Произвести И
                    НЕ ЗначениеЗаполнено( тСтрокаНоменклатуры.ПроизводственноеЗадание )
                    И ЗначениеЗаполнено( тСтрокаНоменклатуры.ЗаказНоменклатура )
                    И ТипЗнч( тСтрокаНоменклатуры.ЗаказНоменклатура ) = Тип("СправочникСсылка.Номенклатура") Тогда
                    
                    Если шаг = 0 И массНоменклатур.Найти( тСтрокаНоменклатуры.ЗаказНоменклатура ) = Неопределено Тогда
                        массНоменклатур.Добавить( тСтрокаНоменклатуры.ЗаказНоменклатура );
                        
                        Если ПрЗадание = Неопределено Тогда
                            ПрЗадание = Документы.ПроизводственноеЗадание.СоздатьДокумент();
                            ПрЗадание.Дата = ТекущаяДата();
                            
                        КонецЕсли;
                    
                        НовСтр = ПрЗадание.ОсновнаяКомплектация.Добавить();
                        ЗаполнитьЗначенияСвойств( НовСтр, тСтрокаНоменклатуры );
                            
                        НовСтр.Заказ         = тСтрокаЗаказа.ЗаказНоменклатура;
                        НовСтр.Номенклатура = тСтрокаНоменклатуры.ЗаказНоменклатура;
                        
                        НовСтр.ПроизводственныйЛист = тСтрокаЗаказа.ПроизводственныйЛистМодель;
                        НовСтр.Модель         = тСтрокаНоменклатуры.ПроизводственныйЛистМодель;
                            
                    ИначеЕсли шаг = 1 Тогда
                        тСтрокаНоменклатуры.ПроизводственноеЗадание = ссылкаПрЗадание;
                        
                    КонецЕсли;
                КонецЕсли;
            КонецЦикла;
            
        КонецЦикла;
        
        Если НЕ ПрЗадание = Неопределено Тогда
            ПрЗадание.Записать();
            ссылкаПрЗадание = ПрЗадание.Ссылка;
            
        КонецЕсли;
    КонецЦикла;


ЗаполнитьЗначенияСвойств( НовСтр, тСтрокаНоменклатуры ) - грешу на это, точнее на "тСтрокаНоменклатуры"

тСтрокаНоменклатуры из тСтрокаЗаказа.ПолучитьЭлементы() - такое ощущение, что ПолучитьЭлементы группирует сразу.

Помогите разобраться с этой группировкой!


 ! 

Правила: 9
 
Просмотров: 92, последний комментарий от volodya1122   
Запрос по РегиструНакопления и ТабличнойЧасти документа [раздел Программирование обычных форм 1С 8.2 и не интерфейсной логики]
Автор sanytch — 14.02.19, 18:15 — 1 комментариев
Доброго времени суток!
Немного вводной информации: Есть документ ЧекККМ, в нем есть возможность установить ТипОплаты как Наличные или ПлатежнаяКарта. При оплате наличными документ создает движения по РегистрамНакопления РозничнаяВыручка и ТоварыНаСкладах, а при оплате ПлатежнойКартой только по регистру ТоварыНаСкладах. Также есть отчет "Ведомость по денежным средствам в розничных точках". Он формируется исключительно по запросу к РегиструНакопления РозничнаяВыручка.
Собственно вопрос: как отразить в этом отчете и сумму оплаты ПлатежнойКартой?
Что было сделано: Сделал вложенный запрос по ТабличнойЧасти документа. В нём выбираю из документов только по ТипуОплаты (ТипОплаты - реквизит табличной части) = ПлатежнаяКарта все равно не вижу этих сумм, установив связь между основным запросом и вложенным по РегистрНакопления.Регистратор = ВложенныйЗапрос.Ссылка получил увеличение итоговой суммы ровно во столько раз сколько вложеный запрос отбирает записей (т.е. если было 3 оплаты ПлатежнойКартой) то вместо требуемых 100 грн в отчете вижу 300.
Подскажите как правильно прицепить к запросу из регистра РозничнаяВыручка данные из Документа ЧекККМ, по отдельности сам запрос выводит правильную сумму продаж за наличку, а вложенный правильную сумму продаж по Платежной карте, а вот сцепить их как не знаю. Подскажите или поделитесь мыслью. Заранее спасибо всем откликнувшимся.
П.С.

Основной запрос (типовой)
ВЫБРАТЬ РАЗРЕШЕННЫЕ
    ИсточникДанных.РозничнаяТочка КАК РозничнаяТочка,
    ПРЕДСТАВЛЕНИЕ(ИсточникДанных.РозничнаяТочка) КАК РозничнаяТочкаПредставление,
    ИсточникДанных.ВидРозничнойВыручки КАК ВидРозничнойВыручки,
    ПРЕДСТАВЛЕНИЕ(ИсточникДанных.ВидРозничнойВыручки) КАК ВидРозничнойВыручкиПредставление,
    ИсточникДанных.РозничнаяТочка.Владелец КАК Организация,
    ПРЕДСТАВЛЕНИЕ(ИсточникДанных.РозничнаяТочка.Владелец) КАК ОрганизацияПредставление,
    ИсточникДанных.СуммаНачальныйОстаток КАК СуммаНачальныйОстаток,
    СУММА(ИсточникДанных.СуммаПриход) КАК СуммаПриход,
    ИсточникДанных.СуммаРасход КАК СуммаРасход,
    ИсточникДанных.СуммаКонечныйОстаток КАК СуммаКонечныйОстаток,
    ИсточникДанных.СуммаОборот КАК СуммаОборот,
    ИсточникДанных.Регистратор КАК Регистратор,
    ПРЕДСТАВЛЕНИЕ(ИсточникДанных.Регистратор) КАК РегистраторПредставление,
    ИсточникДанных.Период КАК Период,
    НАЧАЛОПЕРИОДА(ИсточникДанных.Период, ДЕНЬ) КАК ПериодДень,
    НАЧАЛОПЕРИОДА(ИсточникДанных.Период, НЕДЕЛЯ) КАК ПериодНеделя,
    НАЧАЛОПЕРИОДА(ИсточникДанных.Период, ДЕКАДА) КАК ПериодДекада,
    НАЧАЛОПЕРИОДА(ИсточникДанных.Период, МЕСЯЦ) КАК ПериодМесяц,
    НАЧАЛОПЕРИОДА(ИсточникДанных.Период, КВАРТАЛ) КАК ПериодКвартал,
    НАЧАЛОПЕРИОДА(ИсточникДанных.Период, ПОЛУГОДИЕ) КАК ПериодПолугодие,
    НАЧАЛОПЕРИОДА(ИсточникДанных.Период, ГОД) КАК ПериодГод
{ВЫБРАТЬ
    РозничнаяТочка.*,
    ВидРозничнойВыручки.*,
    Организация.*,
    СуммаНачальныйОстаток,
    СуммаПриход,
    СуммаРасход,
    СуммаКонечныйОстаток,
    СуммаОборот,
    Регистратор.* КАК Регистратор,
    Период КАК Период,
    ПериодДень,
    ПериодНеделя,
    ПериодДекада,
    ПериодМесяц,
    ПериодКвартал,
    ПериодПолугодие,
    ПериодГод}
ИЗ
    РегистрНакопления.РозничнаяВыручка.ОстаткиИОбороты(&ДатаНач, &ДатаКон, Регистратор {(&Периодичность)},,
                                                                                               {(РозничнаяТочка).* КАК РозничнаяТочка,
                                                                                               (ВидРозничнойВыручки).* КАК ВидРозничнойВыручки,
                                                                                               (РозничнаяТочка.Владелец).* КАК Организация}) КАК ИсточникДанных
{ГДЕ
    ИсточникДанных.СуммаНачальныйОстаток КАК СуммаНачальныйОстаток,
    ИсточникДанных.СуммаПриход КАК СуммаПриход,
    ИсточникДанных.СуммаРасход КАК СуммаРасход,
    ИсточникДанных.СуммаКонечныйОстаток КАК СуммаКонечныйОстаток,
    ИсточникДанных.СуммаОборот КАК СуммаОборот,
    ИсточникДанных.Регистратор.* КАК Регистратор,
    ИсточникДанных.Период КАК Период,
    (НАЧАЛОПЕРИОДА(ИсточникДанных.Период, ДЕНЬ)) КАК ПериодДень,
    (НАЧАЛОПЕРИОДА(ИсточникДанных.Период, НЕДЕЛЯ)) КАК ПериодНеделя,
    (НАЧАЛОПЕРИОДА(ИсточникДанных.Период, ДЕКАДА)) КАК ПериодДекада,
    (НАЧАЛОПЕРИОДА(ИсточникДанных.Период, МЕСЯЦ)) КАК ПериодМесяц,
    (НАЧАЛОПЕРИОДА(ИсточникДанных.Период, КВАРТАЛ)) КАК ПериодКвартал,
    (НАЧАЛОПЕРИОДА(ИсточникДанных.Период, ПОЛУГОДИЕ)) КАК ПериодПолугодие,
    (НАЧАЛОПЕРИОДА(ИсточникДанных.Период, ГОД)) КАК ПериодГод}

СГРУППИРОВАТЬ ПО
    ИсточникДанных.РозничнаяТочка,
    ИсточникДанных.ВидРозничнойВыручки,
    ИсточникДанных.РозничнаяТочка.Владелец,
    ИсточникДанных.СуммаНачальныйОстаток,
    ИсточникДанных.СуммаРасход,
    ИсточникДанных.СуммаКонечныйОстаток,
    ИсточникДанных.СуммаОборот,
    ИсточникДанных.Регистратор,
    ИсточникДанных.Период
{УПОРЯДОЧИТЬ ПО
    РозничнаяТочка.*,
    ВидРозничнойВыручки.*,
    Организация.*,
    СуммаНачальныйОстаток,
    СуммаПриход,
    СуммаРасход,
    СуммаКонечныйОстаток,
    СуммаОборот,
    Регистратор.*,
    Период,
    ПериодДень,
    ПериодНеделя,
    ПериодДекада,
    ПериодМесяц,
    ПериодКвартал,
    ПериодПолугодие,
    ПериодГод}
ИТОГИ
    СУММА(СуммаНачальныйОстаток),
    СУММА(СуммаПриход),
    СУММА(СуммаРасход),
    СУММА(СуммаКонечныйОстаток),
    СУММА(СуммаОборот)
ПО
    ОБЩИЕ
{ИТОГИ ПО
    РозничнаяТочка.*,
    ВидРозничнойВыручки.*,
    Организация.*,
    Регистратор.*,
    Период,
    ПериодДень,
    ПериодНеделя,
    ПериодДекада,
    ПериодМесяц,
    ПериодКвартал,
    ПериодПолугодие,
    ПериодГод}


Это вложенный запрос (в нем СуммаДокумента идет со знаком минус если был возврат, в качестве условия тип оплаты НЕ Наличные):
Тыц
ВЫБРАТЬ
    ЧекККМ.КассаККМ КАК КассаККМ,
    ПРЕДСТАВЛЕНИЕ(ЧекККМ.КассаККМ) КАК КассаККМПредставление,
    ЧекККМОплата.ВидОплаты.ТипОплаты КАК ВидОплатыТипОплаты,
    СУММА(ВЫБОР
            КОГДА ЧекККМ.ВидОперации = ЗНАЧЕНИЕ(Перечисление.ВидыОперацийЧекККМ.Продажа)
                ТОГДА ЧекККМ.СуммаДокумента
            ИНАЧЕ -ЧекККМ.СуммаДокумента
        КОНЕЦ) КАК СуммаДокумента,
    ЧекККМ.Дата КАК Дата,
    ЧекККМ.Проведен КАК Проведен,
    ЧекККМ.ВидОперации КАК ВидОперации,
    ЧекККМ.Ссылка КАК Ссылка,
    ЧекККМ.Представление КАК Представление
ИЗ
    Документ.ЧекККМ.Оплата КАК ЧекККМОплата
        ЛЕВОЕ СОЕДИНЕНИЕ Документ.ЧекККМ КАК ЧекККМ
        ПО ЧекККМОплата.Ссылка = ЧекККМ.Ссылка
ГДЕ
    ЧекККМ.Дата МЕЖДУ &ДатаНач И &ДатаКон
    И ЧекККМОплата.ВидОплаты.ТипОплаты <> ЗНАЧЕНИЕ(Перечисление.ТипыОплатЧекаККМ.Наличные)
    И ЧекККМ.Проведен = ИСТИНА

СГРУППИРОВАТЬ ПО
    ЧекККМ.КассаККМ,
    ЧекККМОплата.ВидОплаты.ТипОплаты,
    ЧекККМ.Дата,
    ЧекККМ.Проведен,
    ЧекККМ.ВидОперации,
    ЧекККМ.Ссылка,
    ЧекККМ.Представление
Просмотров: 80, последний комментарий от Vidocq05   
Перенес с x86 на x64 платформу и начало страшно тормозить [раздел Администрирование и настройка 1С]
Автор vbi — 14.02.19, 12:46 — 12 комментариев
1С:Предприятие 8.3 (8.3.10.2252)

"Управление торговлей для Украины", редакция 2.3.
(2.3.17.1)

Раньше был SQL 2014 x64. Платформа 8.3.8 не помню какая, работало кое-как. Платформа и клиент и сервер x86. Тоесть SQL x64, 1С x86.

Переустановил все. Установил SQL 2016 x64, 1С 8.3.10 x64 сервер, x86 клиент - все стало тормозить, больше конфликтов блокировок. Вроде и скуль настроил и базы. и все на SSD и Shared Memory, но запросы выполняются медленнее. Почему?

База 313 гб. Одновременных пользователей и соединений в районе 100 - 200

Сервер:



Подскажите пожалуйста в чем может быть проблема?
Просмотров: 206, последний комментарий от Vofka   
Внешняя печатная форма РасходныйКассовыйОрдер [раздел Программирование в 1С Предприятие 8.3]
Автор 1c_lam — 14.02.19, 9:32 — 9 комментариев
1С:Предприятие 8.3 (8.3.12.1616)
"Управление торговым предприятием для Украины", редакция 1.2. (1.2.48.1)
Доброго!
Вояю ВПФ для документа "РасходныйКассовыйОрдер", все по методике: процедурки и функции повыдергивал, себе в модуль вставил, проверил ошибки, переменные. ОК.
Прогоняю через отладчик с точкой останова, ошибок не дает. Но и ТабДокумент не возвращает!!
А когда прикручиваю к доку ч-з Серви/Внешние печатные формы, то при попытке печатнуть дает такую ошибку:
"Не удалось сформировать внешнюю печатную форму!
Преобразование значения к типу Число не может быть выполнено"
При отладке эту ошибку получить не могу. 64000000.gif
Просьба, помочь/направить/подсказать. Вот код:

Код
Функция ОпределитьКодЯзыкаДляФормат(КодЯзыка) Экспорт
    
    Возврат ОпределитьКодЯзыкаДляФормат1(КодЯзыка);
    
КонецФункции // ОпределитьКодЯзыкаДляФормат()
Функция ОпределитьКодЯзыкаДляФормат1(КодЯзыка) Экспорт
    
    Возврат ?(КодЯзыка = "uk","uk_UA","ru_RU");
    
КонецФункции // ОпределитьКодЯзыкаДляФормат()
Функция ФорматСумм(Сумма, Валюта = Неопределено, ЧН = "", ЧРГ = "") Экспорт

    ФорматнаяСтрока = "ЧЦ=15;ЧДЦ=2" +
                    ?(НЕ ЗначениеЗаполнено(ЧН), "", ";" + "ЧН=" + ЧН) +
                    ?(НЕ ЗначениеЗаполнено(ЧРГ),"", ";" + "ЧРГ=" + ЧРГ);
    РезультирующаяСтрока = СокрЛ(Формат(Сумма, ФорматнаяСтрока));
    
    //Если ЗначениеЗаполнено(Валюта) Тогда
    //    РезультирующаяСтрока = РезультирующаяСтрока + " " + СокрП(Валюта);
    //КонецЕсли;

    Возврат РезультирующаяСтрока;
    КонецФункции
Функция СформироватьСуммуПрописью(Сумма, Валюта, КодЯзыка = "ua") Экспорт

    ПараметрыПрописи = ПараметрыПрописи(Валюта, КодЯзыка);
    Если ПараметрыПрописи = "" Тогда
        Возврат ФорматСумм(Сумма);
    Иначе
        Попытка
        Возврат        ЧислоПрописью(Сумма,"Л="+ОпределитьКодЯзыкаДляФормат(КодЯзыка),ПараметрыПрописи);
        Исключение
    Сообщить(ОписаниеОшибки());
КонецПопытки;
КонецЕсли;
КонецФункции
Функция ПараметрыПрописи(Валюта, КодЯзыка) Экспорт
    
    Рез = ("гривня, гривні, гривень, ж, копійка, копійки, копійок, ж, 2");
    Если Рез = "" Тогда
        ОбщегоНазначения.СообщитьСлужебнуюИнформацию("Для валюты " + Валюта + " не установлены параметры прописи для кода языка " + КодЯзыка);
    КонецЕсли;
    
    Возврат Рез;
    
КонецФункции // ПараметрыПрописи()
Функция Печать()Экспорт

    Запрос = Новый Запрос;
    Запрос.УстановитьПараметр("ТекущийДокумент", СсылкаНаОбъект);

    Запрос.Текст =
    "ВЫБРАТЬ
    |    Номер,
    |    Дата                          КАК ДатаДокумента,
    |    Организация,
    |    Касса.ОбособленноеПодразделение                     КАК ОбособленноеПодразделениеОрганизации,
    |    Касса.ОбособленноеПодразделение.НаименованиеПолное     КАК ОбособленноеПодразделениеОрганизацииПредставление,
    |    СуммаДокумента                КАК Сумма,
    |    Контрагент.Представление      КАК ФИОПолучателя,
    |    ВалютаДокумента               КАК Валюта,
    |    ВалютаДокумента.Представление КАК ВалютаПредставление,
    |    Выдать,
    |    Приложение,
    |    ПоДокументу,
    |    Основание,
    |    НомерОрдера
    |ИЗ
    |    Документ.РасходныйКассовыйОрдер КАК РасходныйКассовыйОрдер
    |
    |ГДЕ
    |    РасходныйКассовыйОрдер.Ссылка = &ТекущийДокумент";

        
    Шапка = Запрос.Выполнить().Выбрать();
    Если   Шапка.Сумма = неопределено
        ИЛИ
        Шапка.Сумма = NULL
        Тогда
        Сумма=0;
    Иначе
        Сумма = Шапка.Сумма;
    КонецЕсли;
    Шапка.Следующий();
    
    
    ТабДокумент   = Новый ТабличныйДокумент;
    //ТабДокумент.ИмяПараметровПечати = "ПАРАМЕТРЫ_ПЕЧАТИ_РасходныйКассовыйОрдер_КО2";
    
    Вариант2018 = Ложь;
    Если СсылкаНаОбъект.Дата >= Дата('20180105') Тогда
        Макет = ПолучитьМакет("КО2ф");
        Вариант2018 = Истина;
    ИначеЕсли СсылкаНаОбъект.Дата >= Дата('20090616') Тогда
        Макет = ПолучитьМакет("КО2ф");
    Иначе
        Макет = ПолучитьМакет("КО2ф");
    КонецЕсли;
    
    
    ОбластьМакета = Макет.ПолучитьОбласть("Шапка");
    КодЯзыкаПечать = "uk";

    СведенияОбОрганизации = УправлениеКонтактнойИнформацией.СведенияОЮрФизЛице(Шапка.Организация, Шапка.ДатаДокумента);
    
    Если Вариант2018 Тогда
        ПредставлениеДаты = Формат(Шапка.ДатаДокумента, "Л=uk_UA; ДЛФ=ДД");
        ПредставлениеДаты = Сред(ПредставлениеДаты, 1, СтрДлина(ПредставлениеДаты) - 2) + "року";
        ОбластьМакета.Параметры.ДатаДокумента = Шапка.ДатаДокумента+ "року";
    КонецЕсли;

    // Выводим шапку ордера
    ОбластьМакета.Параметры.Заполнить(Шапка);
    
    Если НЕ ЗначениеЗаполнено(Шапка.ОбособленноеПодразделениеОрганизации) Тогда
        ОбластьМакета.Параметры.ПолноеНаименование     = СведенияОбОрганизации.ПолноеНаименование;
    Иначе
        ОбластьМакета.Параметры.ПолноеНаименование = Шапка.ОбособленноеПодразделениеОрганизацииПредставление;
    КонецЕсли;
    
    ОбластьМакета.Параметры.Сумма                 = ФорматСумм(Шапка.Сумма);//, Шапка.Валюта);
    
    //Если Вариант2018
    //    И     СсылкаНаОбъект.ВидОперации = Перечисления.ВидыОперацийРКО.ВзносНаличнымиВБанк
    //    ИЛИ СсылкаНаОбъект.ВидОперации = Перечисления.ВидыОперацийРКО.ИнкассацияДенежныхСредств  
    //    Или СсылкаНаОбъект.ВидОперации = Перечисления.ВидыОперацийРКО.ВыплатаЗаработнойПлатыПоВедомостям Тогда
        //ОбластьМакета.Параметры.СуммаПрописью = ?(Шапка.Валюта = мВалютаРегламентированногоУчета,"грн      коп.","");
    //Иначе
        ОбластьМакета.Параметры.СуммаПрописью         = СформироватьСуммуПрописью(Сумма, Шапка.Валюта, КодЯзыкаПечать);    
    //КонецЕсли;
    
    Если СсылкаНаОбъект.ВидОперации = Перечисления.ВидыОперацийРКО.ВыплатаЗаработнойПлатыРаботнику ИЛИ СсылкаНаОбъект.ВидОперации = Перечисления.ВидыОперацийРКО.ВыдачаДенежныхСредствПодотчетнику Тогда
        КодПоДРФО = ?(СсылкаНаОбъект.ВидОперации = Перечисления.ВидыОперацийРКО.ВыплатаЗаработнойПлатыРаботнику,СсылкаНаОбъект.Контрагент.Физлицо.КодПоДРФО,СсылкаНаОбъект.Контрагент.КодПоДРФО);
        ОбластьМакета.Параметры.Выдать = Шапка.Выдать + ?(КодПоДРФО="",""," ("+КодПоДРФО+")");
    КонецЕсли;
    
        
    ОбластьМакета.Параметры.КодПоЕДРПОУ         = УправлениеКонтактнойИнформацией.ПолучитьКодОрганизации(СведенияОбОрганизации);

    Если НЕ ЗначениеЗаполнено(Шапка.ОбособленноеПодразделениеОрганизации) Тогда
        Руководители = ОбщегоНазначения.ОтветственныеЛица(Шапка.Организация, Шапка.ДатаДокумента);
    Иначе
        Руководители = ОбщегоНазначения.ОтветственныеЛицаОбособленногоПодразделения(Шапка.ОбособленноеПодразделениеОрганизации, Шапка.ДатаДокумента);
    КонецЕсли;

    Если ЗначениеЗаполнено(Руководители.РуководительФИО) Тогда
        Руководитель = ОбщегоНазначения.ПолучитьФамилиюИмяОтчество(Руководители.РуководительФИО.Фамилия, Руководители.РуководительФИО.Имя, Руководители.РуководительФИО.Отчество);
    КонецЕсли;
    
    Если ЗначениеЗаполнено(Руководители.ГлавныйБухгалтерФИО) Тогда
        ГлавныйБухгалтер = ОбщегоНазначения.ПолучитьФамилиюИмяОтчество(Руководители.ГлавныйБухгалтерФИО.Фамилия, Руководители.ГлавныйБухгалтерФИО.Имя, Руководители.ГлавныйБухгалтерФИО.Отчество);
    КонецЕсли;
    
    Если ЗначениеЗаполнено(Руководители.КассирФИО) Тогда
        Кассир = ОбщегоНазначения.ПолучитьФамилиюИмяОтчество(Руководители.КассирФИО.Фамилия, Руководители.КассирФИО.Имя, Руководители.КассирФИО.Отчество);
    КонецЕсли;
    
    ОбластьМакета.Параметры.ФИОРуководителя     = Руководитель;
    ОбластьМакета.Параметры.ФИОБухгалтера         = ГлавныйБухгалтер;
    ОбластьМакета.Параметры.ФИОКассира          = "Узун Н.П.";
    
    
    
    ТабДокумент.Вывести(ОбластьМакета);

    Возврат ТабДокумент;

КонецФункции // ПечатьРКО()
Просмотров: 182, последний комментарий от VXIIIZ   
Отбор документов по контрагенту в списке (из ТЧ) [раздел Программирование в 1С Предприятие 8.3]
Автор Inkognito — 14.02.19, 0:04 — 3 комментариев
Обычные формы, УТП.
Дано:
1) Запрос к документам "РеализацияТоваровУслуг":

"ВЫБРАТЬ РАЗРЕШЕННЫЕ
    |    РеализацияТоваровУслуг.Ссылка КАК Документ,
    |    РеализацияТоваровУслуг.Дата КАК Дата,
    |    РеализацияТоваровУслуг.Контрагент КАК Контрагент,
...


2) Далее используем ПостроительЗапроса():

ЭлементОтбора = Отбор.Добавить("Контрагент");
ЭлементОтбора.Использование = Истина;

Отбор = Новый Структура;
Отбор.Вставить("...", ....);
Отбор.Вставить("...",  ...);                
Строки = ТЧКонтрагентыДляОтбора.НайтиСтроки(Отбор); //табличная часть
            
ОтборСписок = новый СписокЗначений();
Для Каждого Строка Из Строки Цикл
    ОтборСписок.Добавить(Строка.Контрагент); //реквизит табличной части, справочник Контрагентов
КонецЦикла;

ЭлементОтбора.Значение      = ОтборСписок;
ЭлементОтбора.ВидСравнения  = ВидСравнения.ВСписке;


3) При попытке выполнить запрос, - ошибка:

Ошибка при установке значения атрибута контекста (Значение)
ЭлементОтбора.Значение      = ОтборСписок;
Неправильний тип значення
//----------------------------
Если сделать ОтборСписок = Справочники.Контрагенты.НайтиПоКоду("000000188"); -тогда все работает, документы подбираются, - но только по этому конкретному контрагенту.
//----------------------------

Цель: в выборку документов должны попадать только те, контрагенты которых определены в табличной части "ТЧКонтрагентыДляОтбора".
Просмотров: 97, последний комментарий от Vofka   
Неверно применяется коэфициент повышения оклада? [раздел 1С Зарплата и Управление Персоналом 8]
Автор eact — 13.02.19, 16:38 — 8 комментариев
ЗУП 2.1.48.2 1С 8.3.

Ситуация следующая. Бухгалтерия утверждает, что неверно применяется коэфициен повышения оклада при расчете средней ЗП. Прошу, помогите - что делается не так.

За период (расчета средней) был дважды! повышен оклад сотрудника.

01.11.2018 был повышен оклад. Коэфициент повышения оклада составил: "1.05"
01.01.2019 был снова повышен оклад. Коэфициент повышения оклада составил: "1.1"

В итоге, при рачете средзней ЗП за февраль-октябрь применился коэфициент "1,155", который, со слов бухгалтерии неверный, а должен был применяться коэфициент на момент ближайшего повышения оклада (в нашем случае это 01.11.2018) - тоесть: 1.05.

Вроде как пытался читать нормативную документацию - и также понимаю, что "1.155" это неверный коэфициент (и как он рассчитан???)
Что сделано не так?

Просмотров: 190, последний комментарий от Meest   
как обратиться к реквизиту формы на серевере [раздел Программирование в 1С Предприятие 8.3]
Автор lolmatrix — 13.02.19, 15:44 — 4 комментариев
Здравствуйте, пишу собственную конфигурацию, на управляемых формах 1с 8.3, . хочу заполнить реквизит и обратиться к нему с сервера как это сделать, на клиенте
 объект.ИмяРеквизита
, а на сервере как обратиться к реквизиту? заранее спасибо

мне нужно записать в реквизит значение
Просмотров: 129, последний комментарий от lolmatrix   
Быстрый поиск по первым символам в колонке динамического списка. [раздел Программирование в 1С Предприятие 8.3]
Автор Alex78 — 13.02.19, 12:30 — 1 комментариев
Можно ли сделать в динамическом списке поиск в колонке по первым символам (как в 7ке - набираем символы и сразу происходит позиционирование на ту или иную строку)?
Конфигурация УТ 3.1.5.1 на УФ.
Платформа 8.3.10.2252.
Извините, если "баян".
Просмотров: 86, последний комментарий от Fynjy   
потрібна обробка вигрузка в xml первинних документів із БДУ2.0 [раздел Программирование в 1С Предприятие 8.3]
Автор bandrah — 13.02.19, 10:00 — 6 комментариев
Добрий день, потрібна обробка, щоб не використовувати стиковку, для ручної вигрузки актів, видаткових накладних, рахунків в xml, щось на подобі вигрузки ручної ПН і РК
Просмотров: 125, последний комментарий от Vofka   
Разовые начисления ЗУП обработка [раздел Программирование обычных форм 1С 8.2 и не интерфейсной логики]
Автор kinoma — 12.02.19, 21:07 — 0 комментариев
Столкнулся с небольшой проблемой в Запросе. Я новичок.
Нужно автоматизировать разовое начисление (вредность) по формуле Оклад\Норма рабочего времени как Тарифная ставка.
И по табелю 75% времени - время по вредности как отработанное время для расчёта результата.
Я создал обработку, из которой хочу получить такие данные как всех Сотрудников определенного подразделения и должности если указана, Оклад, Норма рабочего времени и Отработанное время за период для того, чтобы вставить полученные данные в соответствующие поля табличного представления.

Сотрудников с окладом вытащить не проблема, проблема соединить их по отработанному времени без переданного параметра определенного сотрудника.

ВЫБРАТЬ
    Начисления.Сотрудник,
    ВЫБОР
        КОГДА Начисления.ТарифныйРазряд1 <> ЗНАЧЕНИЕ(Справочник.ТарифныеРазряды.ПустаяСсылка) ТОГДА РазмерТарифныхСтавок.Размер
        ИНАЧЕ Начисления.Показатель1
    КОНЕЦ КАК ОкладТариф
ИЗ
РегистрСведений.ПлановыеНачисленияРаботниковОрганизаций.СрезПоследних(&парамДатаСобытия, ) КАК Начисления
ЛЕВОЕ СОЕДИНЕНИЕ
    РегистрСведений.РазмерТарифныхСтавок.СрезПоследних(&парамДатаСобытия, ) КАК РазмерТарифныхСтавок
ПО Начисления.ТарифныйРазряд1 = РазмерТарифныхСтавок.ТарифныйРазряд

ГДЕ
    Начисления.Сотрудник.ТекущееПодразделениеОрганизации = &подразделениеОрганизации
    И Начисления.Сотрудник.ТекущаяДолжностьОрганизации = &Должность
    И Начисления.Сотрудник.Актуальность = ИСТИНА
    И Начисления.ВидРасчета <> Начисления.ВидРасчетаИзмерение



Норма рабочего времени за период.

ВЫБРАТЬ
    |    ГрафикиРаботы.ГрафикРаботы    КАК ГрафикРаботы,
    |    ГрафикиРаботы.Документ        КАК Документ,
    |    СУММА(ГрафикиРаботы.ОсновноеЗначение)    КАК ОсновноеЗначение,
    |    СУММА(ГрафикиРаботы.ДополнительноеЗначение) КАК
ДополнительноеЗначение
    |    ИЗ    РегистрСведений.ГрафикиРаботыПоВидамВремени КАК
ГрафикиРаботы
    |    ГДЕ        НАЧАЛОПЕРИОДА( ГрафикиРаботы.Дата, МЕСЯЦ ) =
НАЧАЛОПЕРИОДА( &парамДатаСобытия, МЕСЯЦ )
    |        И    ГрафикиРаботы.ВидУчетаВремени =
ЗНАЧЕНИЕ(Перечисление.ВидыУчетаВремени.ПоДням)
    |        И НЕ ГрафикиРаботы.Документ ССЫЛКА
Документ.ТабельУчетаРабочегоВремениОрганизации
    |        И НЕ ГрафикиРаботы.Документ ССЫЛКА Документ.СдельныйНаряд
    |        И НЕ ГрафикиРаботы.Документ ССЫЛКА
Документ.ВводИндивидуальныхГрафиковРаботыОрганизации


И обороты по табелю, которые нужно умножить на 75%.

ВЫБРАТЬ
    РабочееВремя.ЧасовОборот
ИЗ
РегистрНакопления.РабочееВремяРаботниковОрганизаций.Обороты(НАЧАЛОПЕРИОДА(&парамДатаСобытия, МЕСЯЦ), КОНЕЦПЕРИОДА(&парамДатаСобытия, МЕСЯЦ), МЕСЯЦ, Сотрудник=&парамНазначение) КАК РабочееВремя


Как правильно соединить эти таблицы в один запрос?
Просмотров: 100, оставить комментарий   
Хочу купить комп [раздел Офф-топик]
Автор Vofka — 12.02.19, 16:09 — 11 комментариев
Привет!

Хочу обновить комп. Точнее хочу купить новый комп с запасом лет на 5-10. Процессор ядер 4-6 (физических), оперативной памяти гигабайта 32, видео гиг 4-6, SSD какой-нибудь гигабайт на ~250 (с возможностью поставить дополнительно HDD хотя бы на 1 Тб).

Может кто подскажет где можно по хорошей цене подобрать себе что-то?

Или может кто-нибудь сам занимается сборкой компов (может для организации в которой работает) и есть проверенные не дорогие поставщики и может будет интересно накинуть себе какой-то процент за работу и собрать что-то путнее.
Просмотров: 217, последний комментарий от nmf   
Установка цен по оприходыванию разным партиям [раздел 1С Управление Торговым Предприятием 8]
Автор kot488 — 12.02.19, 13:15 — 7 комментариев
Уважаемые гуру, имеется в базе только один тип цен Цена. Цены устанавливаются на товар в ручную. Появилась необходимость изменить политику ведения цен. Сделать например Цена_приход и Цена_Продажа. Продажная цена это +30 от базовой Цена_приход. Но и товар приходит партиями, есть партия старая в которой оприходование было например за 1 позицию в 1 грн, а новая партия уже в 10 грн. Подскажите пожалуйста как штатными средствами установить товару Цена_приход ту цену за которую закупалась партия?
Просмотров: 156, последний комментарий от sava1   
Ошибка в обработчике события ПередОбработкойВыгрузки группы свойств [раздел Конфигурация "1С:Конвертация данных"]
Автор Vofka — 11.02.19, 12:33 — 3 комментариев
Привет!

Из УТ 2.3 выгружаются данные в Бухгалтерию 1.2 через Универсальный обмен данными XML. Правила для обмена писал другой неизвестный мне человек когда-то давно. Сейчас появилась необходимость выгружать новый вид документов, которые ранее не выгружались. При попытке выгрузить пишет такое:



Загрузив правила в конвертацию данных, поклацав везде, куда хватило фантазии, а так же погуглив опосля, я не нашел где описываются обработчики событий именно для группы свойств. В файле правил (xml-е) я вижу этот обработчик, но не могу найти как из интерфейса к нему добраться.

Может кто-то подскажет куда там тыкать надо?
Просмотров: 119, последний комментарий от VXIIIZ   
RSS Текстовая версия Сейчас: 20.02.19, 14:02
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!

Курсы валют: доллар США к гривне Курсы валют: евро к гривне Курсы валют: российский рубль к гривне